Сайт | Скачать | Видео | Wiki

Автор Тема: pacman-a pacman-arm pacman-ha : pacman2pfs (не выкачивает *pkg: error 404)  (Прочитано 11275 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн krasnyh

  • Ветеран
  • *****
  • Сообщений: 2575
  • Репутация: +86/-1
Re: pra6408 и pacman
« Ответ #30 : 15 Июль 2019, 22:22:21 »
Давно искал что-то подобное.
Но есть нюансы которые не дают в полной мере пересесть на данный дистр.
Почему-то pacman не даёт устанавливать пакеты. Постоянно на всё ошибка 404.
Репозитории раскоментировал
Да, уже обратили внимание на это в PRA6408 Проблемы с созданием модулей pacman2pfs (не выкачивает пакеты) 

И пока ни к чему не пришли:
Цитата: al от 10 Июль 2019, 10:04:52

    Получается если срез репы пра6408 частично потерли то всё, мёртвая система ?

Нет. Но некоторые пакеты придется выкачивать руками - см. выше
Может быть поможет сдвиг даты репы вперед...
Надо накопить статистику. Что-то не получится собрать - пишите


Как я вижу ситуацию, это пересобирать базу (001-prar-c-180101) на свежий срез, понятно что не руками пользователей.
Как видит ситуацию sfs - скачивать пакеты вручную https://www.archlinux.org/packages/ или переходить на pra-roll http://forum.puppyrus.org/index.php?topic=19901.msg152496#msg152496

По поводу pra-roll я не советчик, т.к. не в теме.
« Последнее редактирование: 15 Июль 2019, 22:27:22 от krasnyh »

Оффлайн knn

  • Ветеран
  • *****
  • Сообщений: 1668
  • Репутация: +24/-0
Re: pra6408 и pacman
« Ответ #31 : 16 Июль 2019, 06:08:36 »
скачивать пакеты вручную
с xsel только так и удалось
Samsung RV510: intel pent.T4500; чипсет intel Gl40; ATI mob. Radeon HD 5145, RAM=3Gb; hd1 - Grub2; hd2 - Gr4D; PRA frugal, copy2ram.
Sams-n110: N270 - 1,6 ГГц, Intel GMA 950, RAM=2 ГБ

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 28159
  • Репутация: +194/-0
    • PuppyRus-A
скачивать пакеты вручную https://www.archlinux.org/packages/
Пока самый простой путь :
1. pacman2pfs пакет
2. Если есть сообщения "error 404" - выкачиваем не найденные пакеты браузером из https://www.archlinux.org/packages/  (попробую написать скрипт) в  /var/cache/pacman/pkg/
3. pacman2pfs -p пакет
Не самый сложный рецепт. Трагедии не наблюдаю. Тем более готовых модулей полно на все случаи жизни

« Последнее редактирование: 16 Июль 2019, 10:13:48 от sfs »

Оффлайн yzyz

  • Новичок
  • *
  • Сообщений: 9
  • Репутация: +0/-0
Как я вижу ситуацию, это пересобирать базу (001-prar-c-180101) на свежий срез, понятно что не руками пользователей.
Как видит ситуацию sfs - скачивать пакеты вручную https://www.archlinux.org/packages/ или переходить на pra-roll http://forum.puppyrus.org/index.php?topic=19901.msg152496#msg152496

По поводу pra-roll я не советчик, т.к. не в теме.

Ну выкачивать вручную честно говоря то ещё удовольствие, ибо зависимостей толпа.

И ещё один вопрос появился, а ядро pf с какими модулями собрано?
Чем пожертвовали в угоду скорости работы? 
Или оно стандартное?
Если нет то какие нюансы сборки под PRA нужно учесть?
« Последнее редактирование: 16 Июль 2019, 10:38:57 от sfs »

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 28159
  • Репутация: +194/-0
    • PuppyRus-A
Пытался собирать пакеты скачивая с archlinux репозитория вручную и собирая их mkpfs.
C редактором nano вышло, а вот lxc и libvirt не даются (скачивал и собирал отдельно все зависимости модулями, а далее уже объединял в один).
Это не самые простые проги. Для чего используете? Чем не устроил virtualbox ?
lxc - через него можно Xorg проги внитри контейнера запускать?

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 28159
  • Репутация: +194/-0
    • PuppyRus-A
выкачивать вручную честно говоря то ещё удовольствие
попробую написать скрипт
Можно попробовать собрать в 1811 а потом перенести в 1801. glibc для подобного в 1801 обновляю до свежего. Ну или в обновленном pra-roll точно все должно получиться без проблем

Про ядро ответил здесь. 1 вопрос = 1 тема

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 28159
  • Репутация: +194/-0
    • PuppyRus-A
Посмотрел внимательнее. Архивы старее 0101 2019 удалены из https://archive.archlinux.org/ в Historical Archive
pacman -Sy тоже сломано...
Хранятся только за текущий год. pacman-ом их не достать

Написал pacman-a (в аттаче). Он  достает . Поддерживаются только ключи -S[wdd]. Другие и не нужны. Надо только выкачать в /var/cache/pacman/pkg. Остальное сделает pacman
+ заменяем  pacman2pfs из аттача ( в 125 строке pacman <-> pacman-a : из репы <-> из Historical_Archive)
и проблема решена

Подробности

Может там и других дистров пакеты есть... Тогда можно любой дистр заморозить
« Последнее редактирование: 09 Август 2019, 11:39:20 от sfs »

Оффлайн krasnyh

  • Ветеран
  • *****
  • Сообщений: 2575
  • Репутация: +86/-1
Соответственно - меняем в pacman2pfs в 125 строке pacman на pacman-a и проблема решена
Проверил в pra6408.
Скрин.


upd. Добавил скрин команды sudo pacman-a -Sw audacious
« Последнее редактирование: 17 Июль 2019, 19:24:34 от krasnyh »

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 28159
  • Репутация: +194/-0
    • PuppyRus-A
Поправил
По итогу pacman во всех PRA получается не рабочий. Как донести до юзера инфу из этой темы...

Можно положить заглушку в /usr/local/bin/pacman , в которой распарсить ключи и на S[wdd] подставить pacman-a

Костыльно. Лучше , но сложней через hook
https://aur.archlinux.org/cgit/aur.git/tree/pkgfile.hook?h=pacman-pkgfile-hook
« Последнее редактирование: 04 Август 2019, 11:24:43 от sfs »

Оффлайн krasnyh

  • Ветеран
  • *****
  • Сообщений: 2575
  • Репутация: +86/-1
Поправил
* pacman-a.gz (0.53 КБ - загружено 1 раз.)
* pacman2pfs.gz (1.76 КБ - загружено 1 раз.)
Это вообще-то проверялось на работоспособность? Или там реализовано в виде идеи, без практического тестирования?
Скрин из-под PRA6408.

Оффлайн krasnyh

  • Ветеран
  • *****
  • Сообщений: 2575
  • Репутация: +86/-1
Покажите sh -vx pacman-a -Sw audacious
Прикрепил.

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 28159
  • Репутация: +194/-0
    • PuppyRus-A
Понятно. Похоже pacman -Sy тоже сломано...
Код
pacman -Sw --print-format "%n" audacious
  не работает. Поэтому и мой скрипт - тоже
Код
pacman -Ss --print-format "%n" audacious
   работает
Подключите pkg*.pfs. Только ДО pacman -Sy или распакуйте его в корень - чтоб наверняка
« Последнее редактирование: 20 Июль 2019, 08:37:03 от sfs »

Оффлайн krasnyh

  • Ветеран
  • *****
  • Сообщений: 2575
  • Репутация: +86/-1
Понятно. Похоже pacman -Sy тоже сломано...
Мне показалось что-то с доступом к нашим репозитариям у меня. Причем в браузере захожу, пинг тоже есть.
Код
live@prar-1811 ~ % ping mirror.yandex.ru
PING mirror.yandex.ru (213.180.204.183) 56(84) bytes of data.
64 bytes from mirror.yandex.ru (213.180.204.183): icmp_seq=1 ttl=57 time=10.4 ms
64 bytes from mirror.yandex.ru (213.180.204.183): icmp_seq=2 ttl=57 time=9.78 ms
64 bytes from mirror.yandex.ru (213.180.204.183): icmp_seq=3 ttl=57 time=8.96 ms
64 bytes from mirror.yandex.ru (213.180.204.183): icmp_seq=4 ttl=57 time=9.55 ms
64 bytes from mirror.yandex.ru (213.180.204.183): icmp_seq=5 ttl=57 time=9.72 ms
64 bytes from mirror.yandex.ru (213.180.204.183): icmp_seq=6 ttl=57 time=9.33 ms

--- mirror.yandex.ru ping statistics ---
6 packets transmitted, 6 received, 0% packet loss, time 13ms
rtt min/avg/max/mdev = 8.961/9.619/10.378/0.449 ms

Но ни скачать ничего не могу через sfs-get, ни обновить наши базы (pra6407extra; 2a-any  и т.д.) через pacman -Syy. Только сегодня такое.
Так что с тестированием сегодня я пас.

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 28159
  • Репутация: +194/-0
    • PuppyRus-A
У меня тоже проблемы с яндексом. вчера тоже
Для этих экспериментов яндекс не нужен
http://file.puppyrus.org/users/roll/pkg-prar-180101-sf02.pfs выложил временно на наш

Оффлайн krasnyh

  • Ветеран
  • *****
  • Сообщений: 2575
  • Репутация: +86/-1
pkg-prar-180101-sf02.pfs
Да, я уже скачал его и проверил, все работает.
Прикрепил лог.


p.s. Получил рабочий модуль audacious.pfs. Единственно audacious плохой пример для теста, т.к. для полноценной работы там надо вручную доустанавливать разные кодеки. Такой вот 'хитрый' пакет.