Сайт | Скачать | Видео | Wiki

Автор Тема: Upgrade glibc и gtk  (Прочитано 44629 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн sfs

  • Администратор
  • Ветеран
  • *****
  • Сообщений: 18005
  • Репутация: +138/-0
    • PuppyRus-A
Upgrade glibc и gtk
« : 05 Январь 2013, 00:24:00 »
Это основные системные библиотеки. Сейчас в 218 glibc-2.14. В оф. репе есть 2.16. 2.17 уже релиз.
gtk в 218 2. В репе есть 3
Некоторые проги уже не собираются.  :'(
Какие планы на этот счет? Каковы возможные "масштабы разрушений"?
Можно ли как-то обмануть: добавить новые либы, не удаляя старые или как-то еще...

В аттаче пример файла настроек gtk3. Положить в ~/.config/gtk-3.0
« Последнее редактирование: 26 Январь 2013, 22:59:31 от sfs »

Оффлайн Pro

  • Модератор
  • Ветеран
  • ****
  • Сообщений: 8536
  • Репутация: +92/-0
Re:Upgrade glibc и gtk
« Ответ #1 : 05 Январь 2013, 05:05:58 »
никаких действий.
Я загружаю новые пакеты сюда: http://file.puppyrus.ml/users/ а дальше можно найти самостоятельно.

Оффлайн Pro

  • Модератор
  • Ветеран
  • ****
  • Сообщений: 8536
  • Репутация: +92/-0
Re:Upgrade glibc и gtk
« Ответ #2 : 10 Январь 2013, 02:29:35 »
Перейти на glibc-2.17 ? да хоть щас.
Я загружаю новые пакеты сюда: http://file.puppyrus.ml/users/ а дальше можно найти самостоятельно.

Оффлайн sfs

  • Администратор
  • Ветеран
  • *****
  • Сообщений: 18005
  • Репутация: +138/-0
    • PuppyRus-A
Re:Upgrade glibc и gtk
« Ответ #3 : 10 Январь 2013, 09:12:14 »
Жду модуль  ;)
Каких и где ждать сюрпризов?

Оффлайн Pro

  • Модератор
  • Ветеран
  • ****
  • Сообщений: 8536
  • Репутация: +92/-0
Re:Upgrade glibc и gtk
« Ответ #4 : 10 Январь 2013, 09:32:10 »
Придет серенький волчок и напишет что дистриб стал УГ и разработчики не придерживаются ориентации на стабильную работу.
Я загружаю новые пакеты сюда: http://file.puppyrus.ml/users/ а дальше можно найти самостоятельно.

Оффлайн sfs

  • Администратор
  • Ветеран
  • *****
  • Сообщений: 18005
  • Репутация: +138/-0
    • PuppyRus-A
Re:Upgrade glibc и gtk
« Ответ #5 : 14 Январь 2013, 11:21:37 »
130110
Когда УГ морально устаревшее тоже не фонтан.
В нормальных дистрах есть ветка testing. Готов опробовать на Байте

130114
http://forum.puppyrus.org/index.php/topic,13473.msg71333.html#msg71333
Пытаюсь опробовать glibc217
Закопировал в базу поверх, пересобрал
iconv -V
bash: /usr/bin/iconv : Нет такого файла
А он есть. С другими бинарниками пакета из /usr/bin аналогично
Что я не так сделал? Как надо?

Начинает проясняться. В старом libiconv отдельным модулем...
« Последнее редактирование: 14 Январь 2013, 11:50:26 от sfs »

Оффлайн Pro

  • Модератор
  • Ветеран
  • ****
  • Сообщений: 8536
  • Репутация: +92/-0
Re:Upgrade glibc и gtk
« Ответ #6 : 14 Январь 2013, 12:12:09 »
тут все очень тонко iconv в glibc конфликтует с libiconv и особенно это проявляется при компиляции.
какой правильнее ясности нет.
Я загружаю новые пакеты сюда: http://file.puppyrus.ml/users/ а дальше можно найти самостоятельно.

Оффлайн sfs

  • Администратор
  • Ветеран
  • *****
  • Сообщений: 18005
  • Репутация: +138/-0
    • PuppyRus-A
Re:Upgrade glibc и gtk
« Ответ #7 : 14 Январь 2013, 12:35:38 »
От нового iconv ничего другого (см. выше) получить не удалось
dev модуль Вы не выложили.
Не дорос я еще до такого уровня задач. Подсказывайте или ничего не остается кроме как ждать от Вас более готового решения...

Оффлайн Pro

  • Модератор
  • Ветеран
  • ****
  • Сообщений: 8536
  • Репутация: +92/-0
Re:Upgrade glibc и gtk
« Ответ #8 : 14 Январь 2013, 15:30:09 »
есть мнение, что такой важный пакет как glibc простым подключением нельзя ставить, только замена старого пакета в базовом sfs.
Я загружаю новые пакеты сюда: http://file.puppyrus.ml/users/ а дальше можно найти самостоятельно.

Оффлайн sfs

  • Администратор
  • Ветеран
  • *****
  • Сообщений: 18005
  • Репутация: +138/-0
    • PuppyRus-A
Re:Upgrade glibc и gtk
« Ответ #9 : 14 Январь 2013, 15:49:27 »
Тоже об этом уже подумал. Пересобрал базу с заменой. Без улучшений  :'(

Оффлайн Pro

  • Модератор
  • Ветеран
  • ****
  • Сообщений: 8536
  • Репутация: +92/-0
Re:Upgrade glibc и gtk
« Ответ #10 : 14 Январь 2013, 15:52:12 »
да нормально, обычное дело при обновлении glibc
Я загружаю новые пакеты сюда: http://file.puppyrus.ml/users/ а дальше можно найти самостоятельно.

Оффлайн sfs

  • Администратор
  • Ветеран
  • *****
  • Сообщений: 18005
  • Репутация: +138/-0
    • PuppyRus-A
Re:Upgrade glibc и gtk
« Ответ #11 : 14 Январь 2013, 16:01:34 »
А чего делать-то? Может размахнулись 217. В основном 215 во всех дистрах. Или номер проблем не уменьшит?

Оффлайн Pro

  • Модератор
  • Ветеран
  • ****
  • Сообщений: 8536
  • Репутация: +92/-0
Re:Upgrade glibc и gtk
« Ответ #12 : 15 Январь 2013, 14:20:29 »
перекачай пакет, я убрал из него iconv, должна использоваться та что в libiconv
Я загружаю новые пакеты сюда: http://file.puppyrus.ml/users/ а дальше можно найти самостоятельно.

Оффлайн Pro

  • Модератор
  • Ветеран
  • ****
  • Сообщений: 8536
  • Репутация: +92/-0
Re:Upgrade glibc и gtk
« Ответ #13 : 15 Январь 2013, 14:22:07 »
Я загружаю новые пакеты сюда: http://file.puppyrus.ml/users/ а дальше можно найти самостоятельно.

Оффлайн sfs

  • Администратор
  • Ветеран
  • *****
  • Сообщений: 18005
  • Репутация: +138/-0
    • PuppyRus-A
Re:Upgrade glibc и gtk
« Ответ #14 : 15 Январь 2013, 14:37:27 »
"Положил" и "есть в системе и devx" - вещи разные   ;)
glibc больше подпирает.
перекачай пакет, я убрал из него iconv, должна использоваться та что в libiconv
Только сейчас заметил. Если отредактировать сообщение - оно в новых не появляется. Писал об этом Юрию. Сам создаю новое, старое удаляю

Такой эффект у меня получился при пересборе базы. iconv - работает , но он естественно 214. Остальное - без улучшений.
Может попробовать 215 от slackware?