Сайт | Скачать | Видео | Wiki

Голосование

Нужна ли дальнейшая поддержка LFA1801 (бывший pra6408 и prar1801)

Да. Использую постоянно. PRAR не устраивает (на форум или в комментарий - чем)
1 (33.3%)
Нет. Использую LFD10
0 (0%)
Нет. Использую PRA-Roll
1 (33.3%)
Нет. Использую DDR01
1 (33.3%)

Проголосовало пользователей: 3

Автор Тема: LFA1801 : надо ли поддерживать два Arch дистроибутива x86_64 ?  (Прочитано 1036 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 31412
  • Репутация: +208/-0
  • Автор темы
    • PuppyRus-A
Т.к. есть LFD10 - который для фругала лучше (меньше размером, репа дебиана больше и свежей арча среза 1801). Почти 3 года для линукса - это уже возраст...
Компилить под дебианом сложнее, но prar никуда не денется. Он не много больше размером , чем   LFА1801. Планирую регулярно обновлять срез репы prar. Вроде prar начинает народу заходить
Для совместимости достаточно обновлять в  LFD10 glibc (может еще ТК)
Да и обновлять имеет смысл только браузеры (тут без компиляции и уже автоматом) и smplayer (когда перестает воспроизводить ютуб)
LF01*iso - c двумя ОС , кучей DE и вариантов - жесть. Надо упрощать - хотя бы как ddr
Делал отдельный LFА1801*iso - качали меньше , чем LF01*iso. возможно из-за того, что народ хочет именно LFD10.iso - выпущу его 1 ноября отдельно, посмотрю счетчики
« Последнее редактирование: 13 Март 2021, 12:07:48 от sfs »

Оффлайн Neyel

  • Ветеран
  • *****
  • Сообщений: 1360
  • Репутация: +26/-0
Re: LFA1801 : надо ли поддерживать 2 Arch x86_64 ?
« Ответ #1 : 21 Октябрь 2020, 10:48:15 »
PRAR нужно прописывать UUID флешки в груб4досе, а так больше отличий не вижу. Возможно если LFA сольют, перейду на прар (так как привык к архлинуксу). То есть основная моя мотивация - привык к архлинуксу  :D

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 31412
  • Репутация: +208/-0
  • Автор темы
    • PuppyRus-A
Re: LFA1801 : надо ли поддерживать 2 Arch x86_64 ?
« Ответ #2 : 28 Октябрь 2020, 09:03:55 »
PRAR нужно прописывать UUID флешки в груб4досе
C pra-porteus initrd отличие PRAR2008 от LFA1801 только в срезе репы и наличии systemd

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 31412
  • Репутация: +208/-0
  • Автор темы
    • PuppyRus-A
Re: LFA1801 : надо ли поддерживать 2 Arch x86_64 ?
« Ответ #3 : 11 Ноябрь 2020, 15:31:31 »
Цитата: sfs от 02 Ноябрь 2020, 13:46:55
    выпустил LFD10 отдельно
Спасибо. Котлеты отдельно от мух - всегда лучше.
Народ больше качает двойной дистр. Почти в 2 раза больше
Пробовал выпускать отдельно LFA - было то же самое

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 31412
  • Репутация: +208/-0
  • Автор темы
    • PuppyRus-A
Re: LFA1801 : надо ли поддерживать 2 Arch x86_64 ?
« Ответ #4 : 20 Январь 2021, 13:57:59 »
Не пора ли заканчивать поддержку lfa1801...
Кто-то еще его юзает? Почему не прар2008?
Использую. Почему бы не делать образы lfd и lfa? prar давно перестал запускаться, перекопирование пакетов ничего не дало, все молчат... Просто удалал с винта...
ПРАР даже у дяди Шурика работает
Остальные подробности в шапке

Возможно lf01-2101 будет последним. Дальшн только lfd10 и prar
Так что - если любите арч - восстанавливайте прар

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 31412
  • Репутация: +208/-0
  • Автор темы
    • PuppyRus-A
Re: LFA1801 : надо ли поддерживать 2 Arch x86_64 ?
« Ответ #5 : 13 Март 2021, 11:47:05 »
Цитата: sfs от 09 Март 2021, 09:16:43
    lfa1801 планирую слить
Не думаю, что это выход. В prar, тоже можно столкнуться с необходимостью обновления репы чаще чем раз в год, иначе какое-то приложение откажется запускаться.
Уже сделал из prar2008 аналог такого и такого - т.е. легкообновляемый почти монолит. Скоро выложу. Думаю его сделать prar2103, а prar2008 переименовать в lfa2008 и долго поддерживать
Обновлять полумонолит можно хоть каждый день (тогда проще фул поставить)
А нужные модули дособрать pacman2pfs из арч или моей портированной репы
Большинству достаточно того же LFA, но с обновляемыми браузерами, плюс еще пара-тройка приложений, которые желательно поддерживать в актуальном состоянии. Стоит ли ради этого биться с необходимостью иметь свежайшую репу. 
Сейчас не так?

Если кто-то хочет продолжить поддержку lfa1801 - я не против и советами помогу
Активнее голосуем в шапке темы
« Последнее редактирование: 13 Март 2021, 11:49:23 от sfs »

Оффлайн krasnyh

  • Ветеран
  • *****
  • Сообщений: 4108
  • Репутация: +121/-1
Re: LFA1801 : надо ли поддерживать 2 Arch x86_64 ?
« Ответ #6 : 13 Март 2021, 11:56:22 »
Обновлять полумонолит можно хоть каждый день
В идеале, а на практике не так все просто. Я видел как обновлялся IceArch и люди, с огромным багажем знаний, решали сопутствующие проблемы. И как один раз пришлось морозить репу, иначе тупик...
Тем более не уверен, что обычный пользователь осилит подобное, когда столкнется.

Оффлайн krasnyh

  • Ветеран
  • *****
  • Сообщений: 4108
  • Репутация: +121/-1
Если только использовать репу Manjaro. Говорят она выходит с задержкой, пока оттестируют...

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 31412
  • Репутация: +208/-0
  • Автор темы
    • PuppyRus-A
на практике не так все просто.
Чтобы убедиться как раз и сделал из прар2008 полумонолит. Ничего сложного. Пришлось добавить пару fake пакетов для избавления зависимостей. Времени в пределах часа
не уверен, что обычный пользователь осилит подобное
Ну так для тех, кто сам не осилит, но надо свежий тяжелый софт и будет п.1
В этом направлении и планирую двигаться:
1. Раз в пол года полумонолит - и делайте под него модули хоть из арч репы, хоть из моей портитрованной. Или просто поставьте в Фул и сами автообновляйте и морозьте
2. LFA модульный , с портированным, перекомпиленным софтом раз в год - два -три. LFA1801 больше 3 продержался
3. LFD, DDR  для флэшек и т.п. с поддержкой минимума софта (примерно как сейчас в его исо). Т.е. для тех, кому кромен браузера и медиаплеера ничего не нужно

Если только использовать репу Manjaro. Говорят она выходит с задержкой, пока оттестируют...
Репа Manjaro = пакеты из арч репы (иногда более старые- не сильно) + немного своих
Архива к ней нет. Т.е. не заморозить. И получается она на 100% не совместима с арч репой
Почти все манджаро пакеты есть в  chaotic-aur репе . Сделанный на этой репе garuda мало чем отличается по дружелюбности от манджаро, но полностью совместим с арч репой.

Т.е. если хочется морозить манджару - собираем по ее списку пакетов на chaotic (или просто переключаемся с манджаро репы на arch+chaotic и pacman -Syu и потом, Отключив chaotic (к ней нет архива) можно морозить