Сайт | Скачать | Видео | Wiki

Голосование

Нужна ли большая сборка PRA-roll ?

Да. XFCE + LXQT
10 (27%)
Да. XFCE
15 (40.5%)
Да. LXQT
2 (5.4%)
Да. С другим DE (Mate, KDE ... - пишите в комментарии)
3 (8.1%)
Нет. Достаточно OLS
7 (18.9%)

Проголосовало пользователей: 37

Автор Тема: PRA-roll. x86_64 (64бит). Frugal + Full c автообновлением пакетов  (Прочитано 116172 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Демьян

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 535
  • Репутация: +7/-0
С СД загрузился, но запустить с хдд не смог, возможно, причина в старом GRUB4DOS. Можно загрузиться с раздела ext с меню-листом без переменных (set), в каком виде?
Ноут Asus X551M с PuppyRus-A 09-1909, DDR01-20.11

Оффлайн krasnyh

  • Ветеран
  • *****
  • Сообщений: 3514
  • Репутация: +110/-1
Вопрос решается (должен решаться) заменой файла grldr в корне своего диска, на grldr из корня iso.

Онлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 30598
  • Репутация: +206/-0
  • Автор темы
    • PuppyRus-A
prar20.08-x86_64-07.iso
Состав iso
По сравнению с prar2008-x86_64-06.iso :
Обновлены : маленькое ядро ; OVS DE (bugfix) ; браузеры ; youtube-dl (и приделан автообновлятор) + минимальный python2 для него ;
Переделан qt5
Добавлены: pamac (пакетный менеджер) ; vlc ; uget

Оффлайн krasnyh

  • Ветеран
  • *****
  • Сообщений: 3514
  • Репутация: +110/-1
Размер (в основном gtk3) оитимизировал методом fake пакетов (пустышка, у которой прописан конфликт с настоящим пакетом)
Т.е. если обновлять дистр в исходном составе - он будет нормально обновляться
Если нужно установить другой софт с не fake зависимостями - менять fake пакет на настоящий
Все хотел спросить, что за способ. Официальный с pacman или что-то костыльное? Как реализован и какие пакеты попали под его действие.

Онлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 30598
  • Репутация: +206/-0
  • Автор темы
    • PuppyRus-A
что за способ.
Создаю пустой пакет-fake с одним только описанием для pacman
В описании прописываю, что он compatable replace и conflict с настоящим пакетом
В итоге пакета нет, но пакман думает, что есть
На замороженной репе пакет не заместится настоящим при установке софта

Т.е. костылей нет. Просто хитрость с побочками:
Если какому-то пакету реально нужны выкинутые либы - получим ошибку при запуске. Бороться просто - по названию либы найти пакет из арч репы : pkgfile либа и стандартно установить настоящий пакет, который без костылей сам удалит fake

На фкл , эти пакеты постепенно обновятся настоящими. На фул экономия места не нужна. Лучше сразу заменить все fake (искать по fake в названии)
Есть идеи лучше?

Оффлайн krasnyh

  • Ветеран
  • *****
  • Сообщений: 3514
  • Репутация: +110/-1
basilisk-gtk3 это большое ненужное Г. Он настолько долго запускается, что я теперь остался без браузера в вирте, неохота даже к нему прикасаться.
А всего-то добавить две либы к palemoon:
Код
live@pra-roll ..moon-ru-p-28.15.0_64-gtk32.pfs/usr/lib % ll
итого 5064
lrwxrwxrwx 1 root root      27 дек 19 16:02 libgdk-x11-2.0.so -> libgdk-x11-2.0.so.0.2400.31
lrwxrwxrwx 1 root root      27 дек 19 16:02 libgdk-x11-2.0.so.0 -> libgdk-x11-2.0.so.0.2400.31
-rwxr-xr-x 1 root root  740656 дек 19 15:55 libgdk-x11-2.0.so.0.2400.31
lrwxrwxrwx 1 root root      27 дек 19 16:02 libgtk-x11-2.0.so -> libgtk-x11-2.0.so.0.2400.31
lrwxrwxrwx 1 root root      27 дек 19 16:02 libgtk-x11-2.0.so.0 -> libgtk-x11-2.0.so.0.2400.31
-rwxr-xr-x 1 root root 4444512 дек 19 15:55 libgtk-x11-2.0.so.0.2400.31
drwxr-xr-x 6 root root     825 дек 19 16:00 palemoon

Для попробовать под gtk3_64bit palemoon-ru-p-28.15.0_64-gtk32.pfs   

Онлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 30598
  • Репутация: +206/-0
  • Автор темы
    • PuppyRus-A
basilisk-gtk3 это большое ненужное Г. Он настолько долго запускается
Не проще подключить 030-gtk2 от lfa1801?
я теперь остался без браузера в вирте
В исо еще хром

Оффлайн krasnyh

  • Ветеран
  • *****
  • Сообщений: 3514
  • Репутация: +110/-1
Не проще, он мне не нужен. Только либы конечно надо не в /usr/lib помещать, раз модуль портабельный.

Хром это тот же вид, только сбоку. В вирте надо легкое. Иногда хватает netsurf, а иногда и с javascript требуется браузер.

Онлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 30598
  • Репутация: +206/-0
  • Автор темы
    • PuppyRus-A
089-upd-2008-sf39.pfs
добавил iptv, обновил списки

Онлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 30598
  • Репутация: +206/-0
  • Автор темы
    • PuppyRus-A
Обновил openssl (был дырявый); mc ; htop; тему graybird
001-prar2008-sf09.pfs
001-prar2008_DEV-sf09.pfs
040-de-xfce-gtk3-4.16-2008-sf05.pfs - перенес оформление в 001
089-upd-2008-sf40.pfs
DEVX-2008-sf09.pfs
Проверяйте и обновлю исо

Онлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 30598
  • Репутация: +206/-0
  • Автор темы
    • PuppyRus-A

Оффлайн yxma

  • Истина - абсолютна. Но не в линуксе )))
  • Ветеран
  • *****
  • Сообщений: 1547
  • Репутация: +9/-0
  • конченый виндеец, местный сумасшедший 8) 8) 8)
и да. Пришлось вручную включать рекламу на ролловском хроме. Зачем было её для своей страницы выключать по умолчанию? Я не сразу и заметил.
успехов в труде и счастья в личной жизни!

Оффлайн Pro

  • Модератор
  • Ветеран
  • ****
  • Сообщений: 10583
  • Репутация: +109/-2
Evince начал печатать и видеть принтеры после добавления
librest-0.7.so.0
libcolord.so.2
Я загружаю новые пакеты сюда: http://file.puppyrus.org/users/ а дальше можно найти самостоятельно.

Онлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 30598
  • Репутация: +206/-0
  • Автор темы
    • PuppyRus-A
librest-0.7.so.0
У него в зависимостях linsoup. Без soup работает?
cups так ставил?

Оффлайн Pro

  • Модератор
  • Ветеран
  • ****
  • Сообщений: 10583
  • Репутация: +109/-2
cups так ставил?
нет конечно, просто pfs лежит с cups

У него в зависимостях linsoup
я докинул руками либы про которые написал, больше ничего
Я загружаю новые пакеты сюда: http://file.puppyrus.org/users/ а дальше можно найти самостоятельно.