Сайт | Скачать | Видео | Wiki

Автор Тема: Не работает wpa_supplicant  (Прочитано 2287 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн krasnyh

  • Ветеран
  • *****
  • Сообщений: 5036
  • Репутация: +130/-1
  • Автор темы
Не работает wpa_supplicant
« : 28 Сентябрь 2019, 17:29:06 »
А на wifi проверялась сборка? Первая строчка menu.lst.
 
Поставил на ноут и не могу добиться wifi. Настраиваю через netctl.sh, профиль создается, но при подключении ошибки, не хватает либ, то libreadline.so.6, то еще чего...


upd. Причем gui скриптом DdShurick сеть поднимается.
« Последнее редактирование: 29 Сентябрь 2019, 07:38:29 от sfs »

Оффлайн sfs

  • Администратор
  • Ветеран
  • *****
  • Сообщений: 33171
  • Репутация: +226/-0
    • PuppyRus-A
Re: Не работает netctl
« Ответ #1 : 28 Сентябрь 2019, 17:47:24 »
на wifi проверялась сборка?
не помню
при подключении ошибки
Покажите вывод
/usr/lib/netctl/network start profile

Оффлайн krasnyh

  • Ветеран
  • *****
  • Сообщений: 5036
  • Репутация: +130/-1
  • Автор темы
Re: Не работает netctl
« Ответ #2 : 28 Сентябрь 2019, 17:58:10 »
Код
live@pra09:~$ sudo /usr/lib/netctl/network start wlan0-XXXXX
Starting network profile 'wlan0-XXXXX'...
wpa_cli: error while loading shared libraries: libreadline.so.6: cannot open shared object file: No such file or directory
wpa_cli: error while loading shared libraries: libreadline.so.6: cannot open shared object file: No such file or directory
wpa_cli: error while loading shared libraries: libreadline.so.6: cannot open shared object file: No such file or directory
WPA association/authentication failed for interface 'wlan0'
wpa_cli: error while loading shared libraries: libreadline.so.6: cannot open shared object file: No such file or directory
wpa_cli: error while loading shared libraries: libreadline.so.6: cannot open shared object file: No such file or directory
Failed to bring the network up for profile 'wlan0-XXXXX'
live@pra09:~$
Если подкинуть libreadline.so.6, то не хватает уже другой либы.

Я конечно, по старой привычке, выкинул то, что не нужно из /modules (base не трогал), но пришлось вернуть modem-pra09 из-за libssl.so.1.0.0 и libcrypto.so.1.0.0.
Может, там где-то еще что-то важное лежит или лежало в modules или optional. Но basa - стандарт, все как в iso.


p.s. pra09-1909b-i686.iso; PRA09 LXDE-gtk2
« Последнее редактирование: 28 Сентябрь 2019, 18:07:53 от krasnyh »

Оффлайн sfs

  • Администратор
  • Ветеран
  • *****
  • Сообщений: 33171
  • Репутация: +226/-0
    • PuppyRus-A
Re: Не работает netctl
« Ответ #3 : 28 Сентябрь 2019, 20:55:24 »
Чтобы два раза не вставать: )
Не понял к чему это и о чем ...

gui скриптом DdShurick сеть поднимается.
Не может быть. Там тоже wpa_supplicant

001-pra09-sf11.pfs
Заменил wpa_supplicant на рабочий
Спасибо+

Оффлайн krasnyh

  • Ветеран
  • *****
  • Сообщений: 5036
  • Репутация: +130/-1
  • Автор темы
Re: Не работает netctl
« Ответ #4 : 28 Сентябрь 2019, 21:19:38 »
001-pra09-sf11.pfs
ok

Скрипт DdShurick дйствительно сработал, но как я и написал выше, пришлось вернуть modem-pra09-sf03 (из-за двух либ), удаленный перед этим.
С 001-pra09-sf11 он уже не нужен (modem-pra09).

Оффлайн sfs

  • Администратор
  • Ветеран
  • *****
  • Сообщений: 33171
  • Репутация: +226/-0
    • PuppyRus-A
Re: Не работает netctl
« Ответ #5 : 29 Сентябрь 2019, 07:38:00 »
Скрипт DdShurick дйствительно сработал, но как я и написал выше, пришлось вернуть modem-pra09-sf03
Да. Тот wpa_supplicant под openssl1.0, который переехал в modem-pra09