Сайт | Скачать | Видео | Wiki

Голосование

Нужна ли большая сборка PRA-roll ?

Да. XFCE + LXQT
11 (27.5%)
Да. XFCE
16 (40%)
Да. LXQT
3 (7.5%)
Да. С другим DE (Mate, KDE ... - пишите в комментарии)
3 (7.5%)
Нет. Достаточно OLS
7 (17.5%)

Проголосовало пользователей: 40

Автор Тема: PRA-roll. x86_64 (64бит). Frugal + Full c автообновлением пакетов  (Прочитано 135336 раз)

0 Пользователей и 2 Гостей просматривают эту тему.

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 31523
  • Репутация: +208/-0
  • Автор темы
    • PuppyRus-A
Это списки пакетов ДЕ. По замыслу по ним надо собирать модули де в chroot2pfs
prar планируется часто пересобираемым :
1. unsquashfs 001*.pfs
2. chrot.sh squashfs-root и обновляем до текущего среза арчрепы
3. chroot2pfs и на базе обловленного 001 собираем остальные модули

Оффлайн RoDoN

  • Модератор
  • Ветеран
  • ****
  • Сообщений: 6104
  • Репутация: +138/-0
    • RoDoN X
Это списки пакетов ДЕ.
Зачем они болтаются в корне? ИМХО, не по феншую )))

Lenovo B590 (i3-3110M, 8 Гб, GeForce 720M)
PRA 16.12 JWM, Runtu 18.04 x64 Openbox/MATE/XFCE

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 31523
  • Репутация: +208/-0
  • Автор темы
    • PuppyRus-A
Зато удобно. Влетел в чрут и сразу pacman2pfs  lxqt
А где их хранить по фэншую и как рассказать юзерам где их брать?

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 31523
  • Репутация: +208/-0
  • Автор темы
    • PuppyRus-A
001-prar-2103-sf03.pfs битый (в плане pfs-util) Не пересобрать с разборкой на подмодули - куча ошибок и в итоге потеря файлов. Возможно собирал какой-то ошибочной версией pfs-util или как-то криво объединились старые и новые форматы списков файлов pfs-util.
Вспомнил - я уже обновлял 001 pacman- ом со сменой репы. Т.е. Он и не должен разобраться на составляющие. /etc/packages надо удалить. Плюс ошибочные файлы в хомяке + gbus-glib + доразобраться с этим = перевыпустить исо

Оффлайн Pro

  • Модератор
  • Ветеран
  • ****
  • Сообщений: 10619
  • Репутация: +110/-2
Поставил на ноутбук,
Инсталлятор недоработал - в простом режиме не скопировал vmlinuz (он у меня под таким именем без добавок версии)
В режиме Эксперта инсталлятор упорно жаловался что каталог /mnt не пуст, хотя в пункте выбора раздела я выбирал /mnt/sda2 - вобщем не поставило ничего.

Поставил систему вручную, xfce неплохо, мусор в корне есть да,  и история команд у рута :) .
в консоли набрал reboot, выскочило окно с запросом пароля, НО оно широченное, в переводе явно пропустили \n гдето.
Я загружаю новые пакеты сюда: http://file.puppyrus.org/users/ а дальше можно найти самостоятельно.

Оффлайн yxma

  • Истина - абсолютна. Но не в линуксе )))
  • Ветеран
  • *****
  • Сообщений: 1613
  • Репутация: +9/-0
  • конченый виндеец, местный сумасшедший 8) 8) 8)
Зачем они болтаются в корне? ИМХО, не по феншую )))
а что, список в один экран не влазит? Если влазит, то и не страшно. Виндомейкеры такими мелочами не заморачиваются. Думаю, sfs нашел разумное решение. Как всегда. Между прочим, у меня соло на клавиатуре слету запускается под лф )))
успехов в труде и счастья в личной жизни!

Оффлайн krasnyh

  • Ветеран
  • *****
  • Сообщений: 4181
  • Репутация: +121/-1
Код
live@roll2103 /memory/bundles % sudo find 001-prar-2103-sf03.pfs -name autostart -type d
001-prar-2103-sf03.pfs/etc/xdg/autostart
001-prar-2103-sf03.pfs/home/live/autostart
А что у нас, изменилась директория autostart в хомяке? Всегда же было /home/live/.config/autostart.

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 31523
  • Репутация: +208/-0
  • Автор темы
    • PuppyRus-A
куча левых каталогов в хомяке (см.скрин)
Проблема есть
Буду чинить уже при обновлении среза репы. Жду свежего glibc

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 31523
  • Репутация: +208/-0
  • Автор темы
    • PuppyRus-A
Начал делать prar2110. Новых идей нет. Если у кого есть - пишите

Оффлайн krasnyh

  • Ветеран
  • *****
  • Сообщений: 4181
  • Репутация: +121/-1
Если у кого есть - пишите
1. На базе fix сделать аналог файла pra.ini.
Т.к. у меня это есть и я использую, поэтому не настаиваю. Это всего лишь идея подкинутая в воздух. :)

2. Все настройки системы и скрипты pra-utils поместить в отдельный модуль, аналог 88-magos.xzm и 100-2102-ublinux.pfs.
Зачем? Во-первых, удобство обновления, ведь этот модуль будет очень маленького размера. Можно будет отказаться от 089-upd, но не факт. Во-вторых, эти  настройки по сути одинаковы для всех сборок, и можно будет легче разработчику создавать/обновлять сборки, а затем добавлять этот новый модуль настроек. В-третьих, любой юзер, желающий создать свою небольшую сборочку, ) например с pacstrap, может без утомительной настройки просто присоединить этот новый модуль.

Это еще одна идея, подкинутая в воздух, но уже намного выше. :)
« Последнее редактирование: 30 Сентябрь 2021, 09:41:41 от sfs »

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 31523
  • Репутация: +208/-0
  • Автор темы
    • PuppyRus-A
аналог файла pra.ini
Выложите свое. Пока не очень понял идею
настройки системы
Делал подобное : pra-roll-filesystem и для ДЕ - настройки с зависимостями. Не прижилось
Можно будет отказаться от 089-upd
Вряд ли . с ним удобно
можно будет легче разработчику создавать/обновлять сборки
Мне и так норм. Больше никто не собирает
с pacstrap, может без утомительной настройки просто присоединить этот новый модуль.
Все опакечено. Просто добавляйте мою репу и пакеты из нее

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 31523
  • Репутация: +208/-0
  • Автор темы
    • PuppyRus-A
001-prar-2110-sf03.pfs
001-prar-2110-sf03_DEV.pfs
030-qt5-noicu-5.15.2-2110-sf02.pfs
040-de-ovs-gtk3-2110-sf01.pfs
089-upd-2110-sf01.pfs
pkg-2110-sf01.pfs
DEVX-2110-sf01.pfs
gtk3 перекомпилил. Родной много лишнего тянул. Убрал tracker colord canberra Юбунтовские патчи к gtk3 взял для эксперимента. Что-то в них полезного пока не нашел
http://mirror.yandex.ru/puppyrus/puppyrus-a64/pra64-07/pkg/pra6407extra/gtk3-ubuntu-light-3.24.23-1-x86_64.pkg.tar.xz
pavucontrol заменил на  https://github.com/VixenUtils/Myxer - у кого много звуковых устройств - проверьте - не хуже? Зависимостей меньше
« Последнее редактирование: 14 Октябрь 2021, 12:11:15 от sfs »

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 31523
  • Репутация: +208/-0
  • Автор темы
    • PuppyRus-A


Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 31523
  • Репутация: +208/-0
  • Автор темы
    • PuppyRus-A
network-manager-1.32.12-2110-sf01.pfs
nm проблемный получился
089-upd-2110-sf04.pfs
Допилил запуск pulse и сделал параметр ядра nopulse . Проверяется в скрипте /usr/local/bin/start-pulseaudio-x11 В прар pulse в 001*.pfs
« Последнее редактирование: 04 Октябрь 2021, 13:20:49 от sfs »