Сайт | Скачать | Видео | Wiki

Автор Тема: Настройка видеорежимов  (Прочитано 18509 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Pro

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 10725
  • Репутация: +113/-2
Re:Настройка видеорежимов
« Ответ #15 : 01 Март 2011, 02:46:14 »
по видеорежимам никаких проблем нету.
но в старом ядре nouveau модуль был еще не слишком работоспособен, а на новом ядре старые компьютеры не работают.
Я загружаю новые пакеты сюда: http://file.puppyrus.org/users/ а дальше можно найти самостоятельно.

Оффлайн Fotka

  • Пользователь
  • **
  • Сообщений: 29
  • Репутация: +0/-0
  • Автор темы
Re:Настройка видеорежимов
« Ответ #16 : 01 Март 2011, 18:17:53 »
а на новом ядре старые компьютеры
Это приблизительно какие?

Оффлайн Pro

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 10725
  • Репутация: +113/-2
Re:Настройка видеорежимов
« Ответ #17 : 02 Март 2011, 02:21:48 »
Это приблизительно какие?
читайте раздел багтрак и ищите, вам пофлеймить охота или чего?
к какому решению вы пытаетесь привести нас? напишите прямым текстом.
Я загружаю новые пакеты сюда: http://file.puppyrus.org/users/ а дальше можно найти самостоятельно.

Оффлайн Fotka

  • Пользователь
  • **
  • Сообщений: 29
  • Репутация: +0/-0
  • Автор темы
Re:Настройка видеорежимов
« Ответ #18 : 02 Март 2011, 09:52:58 »
Это приблизительно какие?
читайте раздел багтрак и ищите, вам пофлеймить охота или чего?
к какому решению вы пытаетесь привести нас? напишите прямым текстом.
Да ни к чему я вас не хочу привести - вы и так уже много сделали и без моих советов. Разве что только хотелось бы универсальности в отношении используемого железа.

Оффлайн ttuner

  • Пользователь
  • **
  • Сообщений: 51
  • Репутация: +0/-0
Re:Настройка видеорежимов
« Ответ #19 : 08 Апрель 2011, 14:20:27 »
Никак не меняется разрешение i830m
xorg предлагает только 640*480 как подходит для видеокарты, остальные неподходят. Xvesa предлагает только 640*480*16, хотя в listmodes есть и другие режимы. Всунул 0х0105 1024*768*8 и заработало. Но 8 цветов уныло. Можно ли принудительно запустить в xorg 1024*768 или как-то в vesa true color сделать?

Оффлайн ~Vadim~

  • Новичок
  • *
  • Сообщений: 3
  • Репутация: +0/-0
Re:Настройка видеорежимов
« Ответ #20 : 30 Июль 2011, 16:39:24 »
никак не могу  поставить свое разрешение екрана 1920x1080 О.С: PuppyRus Jeans-1.3.0-Update

Видео карта:  NVIDIA GeForce4 MX 440 with AGP8X 64 Мбайт

Монитор: SAMSUNG SyncMaster PX2370
Частота развертки (гор.)    30 - 81 КГц
Частота развертки (верт.)  56 - 60 Гц

Материнская плата Zida Technologies Модель CreateBXi-ATX Чипсет Intel i440X/ZX Южный мост Intel 82371EB/MB (PIIX4E/M)
Процессор:  Intel Celeron
Ядро: Mendocino   
Форм-фактор: Socket 370 PPGA
Спецификация Intel Celeron 433 Мгц
Серия, модель, степпинг: 6, 6, 5 (Pentium II/Pentium II Xeon/Celeron)
Инструкции: MMX
Ядро: 541 MHz
Множытель: x 6.5
Част. шины: 83.3 Мгц
Размер кэша: 128kb

Оперативная память: 288MB
#1 SDRAM 256 Мбайт 133 Мгц 
#2 SDRAM 32 Мбайт 100 Мгц

Установил видео драйвер NVIDIA-964301-k2.6.21.7.pet перезапускаю иксы выбираю xorg вручную настраиваю параметры монитора, и разрешение 1920x1080.
но запускаитца только с разрешением 1024x768 в настройках NVIDIA X Server Setting моего разрешения нет, максимум 1600x1200
вот мой конфик  xorg.conf и Xorg.0.log

Оффлайн vityk

  • Старожил
  • ****
  • Сообщений: 356
  • Репутация: +24/-0
Re:Настройка видеорежимов
« Ответ #21 : 30 Июль 2011, 19:09:34 »
Попробуйте другие драйвера для ядра k2.6.21.7, с этим не определяется монитор, или укажите требуемый modeline для разрешения 1920x1080.

Оффлайн ~Vadim~

  • Новичок
  • *
  • Сообщений: 3
  • Репутация: +0/-0
Re:Настройка видеорежимов
« Ответ #22 : 31 Июль 2011, 16:52:37 »
Другие драйвера не подходят, есть официальный драйвер с оф. сайта NVIDIA http://ru.download.nvidia.com/XFree86/Linux-x86/100.14.11/NVIDIA-Linux-x86-100.14.11-pkg1.run
но Я Новичок. И у меня возникают трудности с установкой официального драйвера, он видаёт ошибку.

Прописал modeline в xorg.conf без установленного NVIDIA драйвера разрешение коректно отрображалось 1920x1080
установил драйвер NVIDIA-964301-k2.6.21.7.pet перезапустил X сервер разрешение изминилось на 1024x768
Открываю NVIDIA X Server Setting выбираю разрешение 1920x1080 и на екране появляется 4 рабочих стола  Может нужно ещё чтото добавить в xorg.conf ?
xorg.conf   Xorg.0.log
« Последнее редактирование: 31 Июль 2011, 19:47:34 от ~Vadim~ »

Оффлайн vityk

  • Старожил
  • ****
  • Сообщений: 356
  • Репутация: +24/-0
Re:Настройка видеорежимов
« Ответ #23 : 31 Июль 2011, 20:07:06 »
Другие драйвера не подходят
- Пробовали этот?
Xorg.0.log получен после каких манипуляций?
Попробуйте исправленный конфиг.
« Последнее редактирование: 31 Июль 2011, 20:27:18 от vityk »

Оффлайн ~Vadim~

  • Новичок
  • *
  • Сообщений: 3
  • Репутация: +0/-0
Re:Настройка видеорежимов
« Ответ #24 : 01 Август 2011, 03:36:24 »
Цитата
- Пробовали этот?
Пробувал следующие драйвера:
NVIDIA-718601-k2.6.21.7.pet разрешение максимум 1600x1200
NVIDIA-964301-k2.6.21.7.pet разрешение максимум 1024x768
NVIDIA-100.14.19-k2.6.21.7.pet         не работает
NVIDIA-Linux-x86-173.14.05-pkg1.pet не работает
NVIDIA-2.6.21.7-173.14.09-pkg1.pet   не работает
NVIDIA-Linux-x86-100.14.11-pkg1.run не устанавливается
Цитата
Xorg.0.log получен после каких манипуляций?
Xorg.0.log получен после:
1 установил PuppyRus Jeans-1.3.0-Update
2 сконфигурировал xorg
3 указал modeline в xorg.conf
4 установил NVIDIA-964301-k2.6.21.7.pet
всех вышеуказанных манипуляций (1-4).

Попробовал ваш исправленный конфиг, теперь разрешение корректно отображается
Выражаю свою благодарность vityk за уделённое внимание и ваш исправленный конфиг
« Последнее редактирование: 08 Август 2011, 18:35:22 от ~Vadim~ »

Оффлайн vityk

  • Старожил
  • ****
  • Сообщений: 356
  • Репутация: +24/-0
Re:Настройка видеорежимов
« Ответ #25 : 01 Август 2011, 23:46:06 »
+ Вопросы
Ответил в личку.

Оффлайн alexey_laa

  • alexey_laa
  • Новичок
  • *
  • Сообщений: 17
  • Репутация: +0/-0
  • alexey_laa
    • http://twitter.com/alexey_laa
Re:Настройка видеорежимов
« Ответ #26 : 08 Апрель 2012, 21:12:58 »
Я установил на одном ПК PuppyRus ( LupuRus-520-M1.iso ). Сначала установился видеорежим 1024х768х16 с частотой 85 Гц (нет мерцания). Потом почему-то экран потемнел, как будто сильно уменьшили яркость. Я стал пробовать менять видеорежимы, пробовать другие драйверы. Нормальную яркость сумел получить только с драйвером Vesa. Правда, экран стал мерцать (наверное, 60 Гц). Так поработало, потом снова стал темный экран с более высокой частотой (нет мерцания).

Видеоадаптер Radeon 9600

Как это можно исправить? Может, нужен другой драйвер? Монитор и видеокарта исправные, раньше на компьютере была Win XP, таких потемнений не было.

Оффлайн alexey_laa

  • alexey_laa
  • Новичок
  • *
  • Сообщений: 17
  • Репутация: +0/-0
  • alexey_laa
    • http://twitter.com/alexey_laa
Re:Настройка видеорежимов
« Ответ #27 : 14 Апрель 2012, 20:49:36 »
Цитата
Потом почему-то экран потемнел, как будто сильно уменьшили яркость.

По поводу проблемы с темнеющим экраном: я нашел на http://www.murga-linux.com/puppy/viewtopic.php?t=65900 про такую же проблему, причем тоже на версии Puppy 5.2, и драйвер тоже "radeon". Написано, что яркость сбивается на видеорежиме 1024x768x16, но работает нормально на 1024x768x24. Собираюсь проверить, но пока не могу, т. к. это не на моем компьютере.