Сайт | Скачать | Видео | Wiki

Автор Тема: pacman-a pacman-arm pacman-ha : pacman2pfs (не выкачивает *pkg: error 404)  (Прочитано 22971 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн al

  • Пользователь
  • **
  • Сообщений: 35
  • Репутация: +0/-0
  • Автор темы
Решение

Здравствуйте, в PRA6408-01 решил создать модуль программы audacious, средствами системы через программирование-поиск софта и создание модуля. Софт нашёлся, модуль audacious.pfs создался, успешно подключился, никаких ошибок не было, но в меню не появился ярлык программы и соответственно её не запустить. Пробовал с другими программами, перенёс в папку modules, перезагружался - всё тоже самое.В inxi в Модули активированые во время загрузки и в Подключенные модули ,мой модуль есть. Что не так ? Как запустить программу ?
« Последнее редактирование: 09 Август 2019, 11:35:22 от sfs »

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 32970
  • Репутация: +225/-0
    • PuppyRus-A
Re: PRA6408. Проблемы с созданием audacious*.pfs
« Ответ #1 : 03 Июль 2019, 10:23:27 »
Вероятно какие-то пакеты не скачались. Недавно  http://archive.archlinux.org почистили. Теперь некоторые пакеты приходится оттуда качать руками
Делайте в консоле  : pacman2pfs и внимательно читайте консоль при сборке

Оффлайн krasnyh

  • Ветеран
  • *****
  • Сообщений: 4966
  • Репутация: +127/-1
Re: PRA6408. Проблемы с созданием audacious*.pfs
« Ответ #2 : 03 Июль 2019, 10:26:37 »
Вероятно какие-то пакеты не скачались. Недавно  http://archive.archlinux.org почистили.
Так и есть. Пакеты не полностью скачиваются, но пустой audacious.pfs создается, вводя пользователей в заблуждение.
Скрин.


P.s. Думаю можно добавить audacious в наши репозитарии раз есть к нему интерес. Я его тоже использую, правда собирал давно в AUR (audacious-gtk3-3.10-1_64). Pro вроде говорил, что тоже пользуется.
« Последнее редактирование: 03 Июль 2019, 10:31:57 от krasnyh »

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 32970
  • Репутация: +225/-0
    • PuppyRus-A
Re: PRA6408. Проблемы с созданием audacious*.pfs
« Ответ #3 : 03 Июль 2019, 10:47:57 »
Думаю можно добавить audacious в наши репозитарии
да. Выкладывайте
Недавно  http://archive.archlinux.org почистили. Теперь некоторые пакеты приходится оттуда качать руками
Печально.... И года не прошло
Пакеты не полностью скачиваются, но пустой audacious.pfs создается
Тогда: скачать пакает в браузере и pacman2pfs -U audacious - и опять же
внимательно читайте консоль при сборке
« Последнее редактирование: 03 Июль 2019, 10:50:00 от sfs »

Оффлайн krasnyh

  • Ветеран
  • *****
  • Сообщений: 4966
  • Репутация: +127/-1
Выкладывайте
Выложить не сложно, но у кого он будет работать кроме меня  :)
Все таки собирался давно на AUR и для GTK3 http://file.puppyrus.org/users/pra64/pfs-portable-test/

Оффлайн al

  • Пользователь
  • **
  • Сообщений: 35
  • Репутация: +0/-0
  • Автор темы
Re: PRA6408. Проблемы с созданием audacious*.pfs
« Ответ #5 : 03 Июль 2019, 11:04:45 »
Пакеты не полностью скачиваются
c этим : pulseaudio 12.2, pulseeffects, iagno, chess похоже тоже самое, печально.
Думаю можно добавить audacious в наши репозитарии раз есть к нему интерес
Был бы очень признателен.

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 32970
  • Репутация: +225/-0
    • PuppyRus-A
собирался давно на AUR и для GTK3
скачать пакает в браузере и pacman2pfs -U audacious

Оффлайн krasnyh

  • Ветеран
  • *****
  • Сообщений: 4966
  • Репутация: +127/-1
Печально.... И года не прошло
Если я правильно понял здесь https://wiki.archlinux.org/index.php/Arch_Linux_Archive, то архивы переносятся потом в "специальную коллекцию" https://archive.org/details/archlinuxarchive. И уже оттуда их можно выкачать?

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 32970
  • Репутация: +225/-0
    • PuppyRus-A
оттуда их можно выкачать?
https://archive.archlinux.org/packages/a/audacious/
Пакеты не вообще удалили и не все
Просто версия не совпадает и поэтому пакман не выкачивает

Оффлайн krasnyh

  • Ветеран
  • *****
  • Сообщений: 4966
  • Репутация: +127/-1
https://archive.archlinux.org/packages/a/audacious/
Что толку что он там лежит если pacman ищет исходя из url в /etc/pacman.d/mirrorlist Server=http://archive.archlinux.org/repos/2018/01/01/$repo/os/$arch (pra6408).
https://archive.archlinux.org/repos/2018/01/01/extra/os/x86_64/
Audacious там уже нет.

Здесь есть https://archive.archlinux.org/repos/2019/01/01/extra/os/x86_64/
Но и mirrorlist должен быть обновлен до Server=http://archive.archlinux.org/repos/2019/01/01/$repo/os/$arch

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 32970
  • Репутация: +225/-0
    • PuppyRus-A
скачать пакает в браузере и pacman2pfs -U

Оффлайн krasnyh

  • Ветеран
  • *****
  • Сообщений: 4966
  • Репутация: +127/-1
скачать пакает в браузере и pacman2pfs -U
Не получится, ошибка на libguess. Я в виртуалке правил mirrorlist
Server=http://archive.archlinux.org/repos/2019/01/01/$repo/os/$arch
Потом:
1. pacman -Syy
2. sudo pacman2pfs audacious -- ошибки
2. sudo pacman2pfs -p  ###модуль audacios все равно на выходе не рабочий
3. опять поправил mirrorlist Server=http://archive.archlinux.org/repos/2018/01/01/$repo/os/$arch
4. pacman -Syy
 :)
Скрин.


Должно быть проще конечно. Обычно достаточно:
скачать пакает в браузере и pacman2pfs -U
« Последнее редактирование: 03 Июль 2019, 21:50:16 от krasnyh »

Оффлайн krasnyh

  • Ветеран
  • *****
  • Сообщений: 4966
  • Репутация: +127/-1
Но в полученном модуле невозможно воспроизвести онлайн радио. Я вроде поэтому и собирал в AUR, да и версия тогда была поновее там.
Скрин.

Ссылка для проверки http://webcast.apexradio.ru:8000/90. Воспроизводится в моем модуле и не воспроизводится в модуле по инструкции выше.
« Последнее редактирование: 03 Июль 2019, 13:03:07 от krasnyh »

Оффлайн krasnyh

  • Ветеран
  • *****
  • Сообщений: 4966
  • Репутация: +127/-1
Я в своем модуле вручную доустанавливал пакеты. У меня url ссылки в основном в .aac
Код
% pfspkg audacious-gtk3-3.10-1-1806-kr1.pfs 
audacious-gtk3
audacious-plugins-gtk3
faad2
flac
libogg
mpg123
neon

Вроде автору сборщику пакета задавали вопрос, почему из коробки толком ничего не работает и приходится доустанавливать пакеты. Это типа сделано, чтобы каждый пользователь мог иметь только то что ему нужно.
https://www.linux.org.ru/forum/desktop/9554269?cid=9555363
« Последнее редактирование: 03 Июль 2019, 16:10:05 от krasnyh »

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 32970
  • Репутация: +225/-0
    • PuppyRus-A
И здесь так же надо. В опциональных зависимостях все написано
audacious-gtk2-3.10.1-1801-sf01.pfs
www радио воспроизводит