Сайт | Скачать | Видео | Wiki

Голосование

Нужна ли большая сборка PRA-roll ?

Да. XFCE + LXQT
11 (26.2%)
Да. XFCE
18 (42.9%)
Да. LXQT
3 (7.1%)
Да. С другим DE (Mate, KDE ... - пишите в комментарии)
3 (7.1%)
Нет. Достаточно OLS
7 (16.7%)

Проголосовало пользователей: 42

Автор Тема: PRA-roll. x86_64 (64бит). Frugal + Full c автообновлением пакетов  (Прочитано 183122 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 32944
  • Репутация: +224/-0
  • Автор темы
    • PuppyRus-A
089-upd-2110-sf36.pfs
Код
# pfsinfo 089-upd-2110-sf36.pfs 
089-upd-2110-sf34
expat-2.4.5-2-x86_64
glibc-2.35-2-x86_64
libxcrypt-4.4.28-2-x86_64
libxml2-noicu-2.9.12-6-x86_64
Обновил эти либы.
glibc , libxcrypt - для совместимости с другими свежими линукс. У кого было отдельным модулем - удалите
expat - был дырявый

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 32944
  • Репутация: +224/-0
  • Автор темы
    • PuppyRus-A

Оффлайн krasnyh

  • Ветеран
  • *****
  • Сообщений: 4957
  • Репутация: +127/-1
089-upd-2110-sf37.pfs
Собран неправильно:
Код
$ pfsinfo 089-upd-2110-sf37.pfs
?


upd. Причем это уже не в первый раз, во всяком случае я неоднократно сообщал о подобном. Неплохо бы доработать скрипт mkpfs, для проверки наличия подмодулей и подстановки соответствующих ключей. Это хорошо, что есть я, :) а иначе бы эти баги висели неделями, если не месяцами. Лучше на программном уровне озаботиться. Имхо.
« Последнее редактирование: 16 Март 2022, 18:51:49 от krasnyh »

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 32944
  • Репутация: +224/-0
  • Автор темы
    • PuppyRus-A
Убрал. Завтра починю
Лучше на программном уровне озаботиться
Проверять /usr/bin в корне? или как что проверять?

Оффлайн krasnyh

  • Ветеран
  • *****
  • Сообщений: 4957
  • Репутация: +127/-1
Я не хочу искать в своих сообщениях, но это не первый раз, когда я указываю на неправильно собранный модуль. Как это можно контролировать на уровне скрипта, без понятия, но не буду же я вечно указывать на одну и ту же ошибку.

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 32944
  • Репутация: +224/-0
  • Автор темы
    • PuppyRus-A

Оффлайн Pro

  • Модератор
  • Ветеран
  • ****
  • Сообщений: 10725
  • Репутация: +113/-2
Никто не замечал в dmesg?:
Код
[51769.480688] pool-pup-volume[748299]: segfault at 40 ip 00007f0049c0bfc0 sp 00007f00489fdd98 error 4 in libpupvm.so.0.0.0[7f0049c00000+12000]

Кажется пора пересобрать pup-volume под новый glibc
« Последнее редактирование: 27 Март 2022, 04:21:00 от Pro »
Я загружаю новые пакеты сюда: http://file.puppyrus.org/users/ а дальше можно найти самостоятельно.

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 32944
  • Репутация: +224/-0
  • Автор темы
    • PuppyRus-A
prar2110 089-upd-2110-sf38.pfs xfce ssd без флэшек : у меня норм
Код
$ dmesg |grep volum
live@roll2110:~$ ps ax |grep vol
    595 ?        Sl     0:00 pup-volume-monitor
И в ФМ [от]монтирует нормально

Оффлайн Pro

  • Модератор
  • Ветеран
  • ****
  • Сообщений: 10725
  • Репутация: +113/-2
незнаю куда засунуть, но  автор Yad удалил русскую локаль. Если обновлять будете, то надо реверт коммита делать
https://github.com/v1cont/yad/commit/e38f7fa71aa9b2dff408ae14ca7133e4fdc4b02a
Я загружаю новые пакеты сюда: http://file.puppyrus.org/users/ а дальше можно найти самостоятельно.

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 32944
  • Репутация: +224/-0
  • Автор темы
    • PuppyRus-A

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 32944
  • Репутация: +224/-0
  • Автор темы
    • PuppyRus-A
prar21.10-x86_64-05.iso
Состав iso
 - обновлен initrd-rafs2 и 070*.pfs.; gparted. Chrome заменен на yandex-browser (автообновлятор в 084*.pfs)

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 32944
  • Репутация: +224/-0
  • Автор темы
    • PuppyRus-A

Оффлайн krasnyh

  • Ветеран
  • *****
  • Сообщений: 4957
  • Репутация: +127/-1
1. Скрипт iso-make-hybrid.sh наверно настало время перетряхнуть
Собирал данное iso со своими изменениями, скриптом iso-make-hybrid.sh и при запуске в вирте постоянно получал ошибку 15. Перепроверил все пути раз сто, в итоге оказалось, что у моего uird.lfa.cpio.xz права root:root и этого было достаточно для нестарта.


upd. Там права вообще были куцые. Как-то так вышло. Если для запуска iso-make-hybrid.sh и исправления прав, требуется sudo, то прописать уведомление как в pfs-utils. А то когда помню, когда нет.
Код
$ ll uird.lfa_error.cpio.xz
-rw------- 1 root root 35082828 июл  5 21:55 uird.lfa_error.cpio.xz
« Последнее редактирование: 06 Июль 2022, 01:32:56 от krasnyh »

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 32944
  • Репутация: +224/-0
  • Автор темы
    • PuppyRus-A
Добавить в  iso-make-hybrid.sh проверку на рута?

Оффлайн krasnyh

  • Ветеран
  • *****
  • Сообщений: 4957
  • Репутация: +127/-1
прописать уведомление как в pfs-utils
Забыл, что там более сложно организовано и опирается на функцию allow_only_root из /usr/local/bin/pfs.

Добавить в  iso-make-hybrid.sh проверку на рута?
Да, с выходом из скрипта, если не пройдена.


Помнится, в старых темах форума, были вопросы по error 15 (grub4dos). И всем здешним сообществом не могли помочь, в итоге отнеся это к кривым ручкам неопытного пользователя. :) А тут сам столкнулся с похожим и впору было обращаться к небесам с вопросом "что происходит-то!!!!?"