Сайт | Скачать | Видео | Wiki

Автор Тема: lupurus 520  (Прочитано 206751 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн bit777

  • Почетный участник
  • Ветеран
  • *
  • Сообщений: 1037
  • Репутация: +127/-0
  • Автор темы
Re:lupurus 520
« Ответ #75 : 01 Февраль 2011, 22:19:25 »
У меня с жесткого диска стартует так:
title Загрузка LupuRus с XFCE
root (hd0,6)
kernel (hd0,6)/lupu/vmlinuz psubdir=luci-test pmedia=idehd wm=xfce
initrd (hd0,6)/lupu/initrd.gz

title Загрузка LupuRus с openbox и jwm
root (hd0,6)
kernel (hd0,6)/lupu/vmlinuz psubdir=luci-test pmedia=idehd wm=openbox
initrd (hd0,6)/lupu/initrd.gz

Оффлайн pureproft

  • Старожил
  • ****
  • Сообщений: 206
  • Репутация: +5/-1
Re:lupurus 520
« Ответ #76 : 01 Февраль 2011, 23:43:31 »
я практически не пользуюсь параметром pmedia, если и без него всё работает где могут быть подводные камни?
p.s. с давнего момента освоения grub4dos не нарезал не одной исошки.
---
и ещё заметил разные пути для ядра,инитрд  и psubdir... не знал, что это допустимо...
« Последнее редактирование: 01 Февраль 2011, 23:50:43 от pureproft »
fRUgal OS  ...читаю между букв...

Оффлайн victorvl

  • Старожил
  • ****
  • Сообщений: 311
  • Репутация: +0/-0
Re:lupurus 520
« Ответ #77 : 02 Февраль 2011, 00:26:06 »
Загрузилась с пункта plop. Но иксы не стартанули. Я так понял не заданы параметры. Дайте кто нибудь правильный текст syslinux.cfg для флешки.
Не знаю точно правильно или нет, так как пользуюсь в основном grub4dos, но можете попробовать
Код
default LupuRus_XFCE
display boot.msg
prompt 1
timeout 50

F1 boot.msg
F2 help.msg

label LupuRus_XFCE
kernel vmlinuz
append initrd=initrd.gz pmedia=cd wm=xfce i915.modeset=1 video=640x480

label LupuRus_Openbox
kernel vmlinuz
append initrd=initrd.gz pmedia=cd wm=openbox i915.modeset=1 video=640x480

В меню обязательно добавляйте параметр wm=xfce или wm=openbox
Так не идет. pmedia=cd я так понимаю указывает на СиДи, а не на ЮСБи.

Оффлайн victorvl

  • Старожил
  • ****
  • Сообщений: 311
  • Репутация: +0/-0
Re:lupurus 520
« Ответ #78 : 02 Февраль 2011, 00:52:58 »
Загрузилась с пункта plop. Но иксы не стартанули. Я так понял не заданы параметры. Дайте кто нибудь правильный текст syslinux.cfg для флешки.
Не знаю точно правильно или нет, так как пользуюсь в основном grub4dos, но можете попробовать
Код
default LupuRus_XFCE
display boot.msg
prompt 1
timeout 50

F1 boot.msg
F2 help.msg

label LupuRus_XFCE
kernel vmlinuz
append initrd=initrd.gz pmedia=cd wm=xfce i915.modeset=1 video=640x480

label LupuRus_Openbox
kernel vmlinuz
append initrd=initrd.gz pmedia=cd wm=openbox i915.modeset=1 video=640x480

В меню обязательно добавляйте параметр wm=xfce или wm=openbox
Изменил cd на usbflash и система начала грузится. Но меню для выбора не появилось. Загрузка пошла сразу по умолчанию.

Оффлайн bit777

  • Почетный участник
  • Ветеран
  • *
  • Сообщений: 1037
  • Репутация: +127/-0
  • Автор темы
Re:lupurus 520
« Ответ #79 : 02 Февраль 2011, 08:04:13 »
About XLupuRus-LUX.
Как быть тем, кто привык работать с флешкой, на которой несколько PuppyRus'ов в папках с тремя файлами и загрузкой через Grub4Dos? Поставил в новую папку XLupuRus-LUX (sfs - все 4 файла)
Проверил. Установил на флешку. Все грузится. Вот мое меню:
Код
title Загрузка LupuRus xfce
kernel (hd0,4)/lupu520/vmlinuz pmedia=usb psubdir=lupu520 wm=xfce
initrd (hd0,4)/lupu520/xlpr-initrd.gz

title Загрузка LupuRus openbox
kernel (hd0,4)/lupu520/vmlinuz pmedia=usb psubdir=lupu520 wm=openbox
initrd (hd0,4)/lupu520/initrd.gz
(hd0,4) - второй раздел флешки.

Оффлайн bit777

  • Почетный участник
  • Ветеран
  • *
  • Сообщений: 1037
  • Репутация: +127/-0
  • Автор темы
Re:lupurus 520
« Ответ #80 : 02 Февраль 2011, 08:04:55 »
Изменил cd на usbflash и система начала грузится.
Все правильно - это я ошибся.

Оффлайн melviX

  • Инициатор проекта
  • Администратор
  • Ветеран
  • *****
  • Сообщений: 2091
  • Репутация: +96/-0
    • PuppyRus Linux
Re:lupurus 520
« Ответ #81 : 02 Февраль 2011, 09:45:04 »
Загрузка пошла сразу по умолчанию
А может вместо label написать title?
Free software for free people

Оффлайн SerVikt

  • Пользователь
  • **
  • Сообщений: 97
  • Репутация: +2/-0
Re:lupurus 520
« Ответ #82 : 02 Февраль 2011, 11:33:03 »
Совсем ничего не понял... Попробовал на своей мульти флешке (2G FAT-16, если что) оба предложенных варианта загрузки (папка LupuRus-LUX лежит в корне!) все - на примере XFCE:
kernel /LupuRus-LUX/vmlinuz pmedia=usbflash wm=xfce i915.modeset=1 video=640x480
initrd /LupuRus-LUX/initrd.gz
и
kernel (hd0,0)/LupuRus-LUX/vmlinuz pmedia=usb psubdir=LupuRus-LUX wm=xfce
initrd (hd0,0)/LupuRus-LUX/initrd.gz
Имею тот же результат:
Kernel panic - not syncing: Out of memory and no killable processes.
Никогда ранее с этим не сталкивался: все дистрибутивы Puppy раньше на этой флешке спокойно запускались! :-\
« Последнее редактирование: 02 Февраль 2011, 14:34:41 от SerVikt »

Оффлайн kostik

  • Постоялец
  • ***
  • Сообщений: 123
  • Репутация: +19/-0
Re:lupurus 520
« Ответ #83 : 02 Февраль 2011, 11:55:37 »
загрузка pfix=nox затем xorgwizard ... не работает, у кого работает?

Оффлайн bit777

  • Почетный участник
  • Ветеран
  • *
  • Сообщений: 1037
  • Репутация: +127/-0
  • Автор темы
Re:lupurus 520
« Ответ #84 : 02 Февраль 2011, 14:54:11 »
загрузка pfix=nox затем xorgwizard ... не работает, у кого работает?
А если после этого дать xwin то нормально загружаются X. Если затем выйти из X и набрать xorgwizard то xorgwizard работает как обычно. Почему так происходит будет ясно если посмотреть сам скрипт xorgwizard строки 53-82. В оригинальном lupu-520 это и был xorgwizard за исключением строк 54,79 и 81 и строка 77 была раскометирована. Начиная с 86 и далее все это был скрипт xorg-setup. Я переделал так чтобы можно было создавать собственный Puppy liveCD. Если есть другие предложения как сделать лучше - предлагайте обсудим.
« Последнее редактирование: 02 Февраль 2011, 16:30:23 от bit777 »

Оффлайн victorvl

  • Старожил
  • ****
  • Сообщений: 311
  • Репутация: +0/-0
Re:lupurus 520
« Ответ #85 : 02 Февраль 2011, 14:59:03 »
Изменил cd на usbflash и система начала грузится.
Все правильно - это я ошибся.

Все хорошо, но меню не появляется. Грузится по дефолту сразу первая позиция.

Оффлайн bit777

  • Почетный участник
  • Ветеран
  • *
  • Сообщений: 1037
  • Репутация: +127/-0
  • Автор темы
Re:lupurus 520
« Ответ #86 : 02 Февраль 2011, 15:28:02 »
Посмотрите парметр timeout не равен ли он нулю.

Оффлайн victorvl

  • Старожил
  • ****
  • Сообщений: 311
  • Репутация: +0/-0
Re:lupurus 520
« Ответ #87 : 02 Февраль 2011, 15:30:45 »
Посмотрите парметр timeout не равен ли он нулю.
Нет поставил 100.

Оффлайн victorvl

  • Старожил
  • ****
  • Сообщений: 311
  • Репутация: +0/-0
Re:lupurus 520
« Ответ #88 : 02 Февраль 2011, 15:31:55 »
Загрузка пошла сразу по умолчанию
А может вместо label написать title?
Так не грузится вообще.

Оффлайн kostik

  • Постоялец
  • ***
  • Сообщений: 123
  • Репутация: +19/-0
Re:lupurus 520
« Ответ #89 : 02 Февраль 2011, 15:57:36 »
Цитата
А если после этого дать xwin то нормально загружаются X
как же нормально загрузятся иксы xwin-ом, когда xorgwizard так и не даёт сконфигурять то, что надо  ???