Сайт | Скачать | Видео | Wiki

Автор Тема: Wary и Racy.  (Прочитано 37757 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн rodin.s

  • Почетный участник
  • Ветеран
  • *
  • Сообщений: 1179
  • Репутация: +96/-0
Wary и Racy.
« : 11 Январь 2011, 23:26:09 »
Создавал эту тему на новом форуме, но новый форум больше не работает. Повторю здесь.
29 декабря 2010 г. вышел Wary Puppy 5.0. http://bkhome.org/blog/?viewDetailed=02057

Дальше моя попытка перевести цитату Барри Каулера:
Wary Puppy - реализация нашей продолжающейся приверженности поддержке старого оборудования. Puppy, построенные на последнем ядре Линукс и X.org могут неправильно работать на старых компьютерах. Например, некоторые драйверы аналоговых модемов не могут быть скомпилированы с последними ядрами. Еще одна большая область - старое видеооборудование не работающее с последними драйверами X.org. Многие из наших ведущих Puppy собраны на последнем ядре и X.org, однако Wary построен со старым ядром (сейчас 2.6.31.14) и X.org 7.3 чтобы обеспечить лучшие драйвера для старого оборудования. Однако во всех других аспектах Wary на переднем крае, как и другие Puppy, с последними приложениями и поддержкой современных устройств (принтеров, сканеров, фотоаппаратов, цифровых модемов и т. д.) Также Wary построен на последнем Woof, так, что имеет такую же инфраструктуру, как и другие современные Puppy.

Пакеты, использованные для постройки Puppy были изначально скомпилированы из исходников в T2, затем созданы бинарные PET-пакеты. Сейчас Wary построен из PET-пакетов с маленьким, но растущим репозитарием. Т.к. Wary намерен стать нашим проектом долгой поддержки, в нем не будет большого апгрейда, только дополнительные улучшения такие, как обновление приложений и исправление ошибок. Таким образом PET-репозитарий Wary будет оставаться жизнеспособным на годы вперед и будет продолжать расти, по мере того, как разработчики будут добавлять пакеты.


Wary Puppy - единственный из современных Puppy, который нормально работает на моем ПК. Я начал постепенно переводить его начиная с бета-версий и продолжаю сейчас т.к. еще не все скрипты переведены. PET-пакеты локализации находятся в теме: http://forum.puppyrus.org/index.php/topic,5340.0.html

Кроме обычной версии существует версия размером 100Мб. Именно ее я скачал себе. Там нет флеш-плеера (легко загрузить) и нет драйверов аналоговых модемов.
« Последнее редактирование: 16 Апрель 2012, 19:21:08 от rodin.s »

Оффлайн rodin.s

  • Почетный участник
  • Ветеран
  • *
  • Сообщений: 1179
  • Репутация: +96/-0
Re:Wary Puppy 5.0 Новые версии: Wary 501 beta и Wary500m07.
« Ответ #1 : 04 Февраль 2011, 21:23:04 »
Вышел Wary 501 beta. Еще не совсем готов для массового использования. Также завтра Барри обещает закачать версию с ide-ядром. Для меня это было удивительно, но это была реакция на мое сообщение, о том, что на моем старом ПК новые sata-ядра долго загружаються из-за того, что воспринимают звуковую карту ISA, как еще один IDE и я пользуюсь Wary-0.3. Теперь жду завтрашней верссии Wary 501 c "2.6.31.14-uniprocessor-ide".  http://bkhome.org/blog/?viewDetailed=02130
Также вышла новая версия Мультиязычной Wary500m07 от shinobar. Это также тестовый релиз. Но он получился большой - 216Мб. Поддерживает 100 языков. Вообще при работе будет загружен 104Мб SFS и языковой пакет выбранного языка. http://www.murga-linux.com/puppy/viewtopic.php?t=63503

Оффлайн rodin.s

  • Почетный участник
  • Ветеран
  • *
  • Сообщений: 1179
  • Репутация: +96/-0
Re:Wary Puppy 5.0 Вышел Wary 502 beta
« Ответ #2 : 06 Февраль 2011, 20:06:58 »
Вышел Wary 502 beta с ide-ядром. Должен подойти для моего старого ПК. http://bkhome.org/blog/?viewDetailed=02133
Еще не пробовал на своем старом ПК, но запустил сейчас pfix=ram на домашнем. Или это мое воображение или работает быстрее чем Wary-5.0. Мои пакеты локализации не успевают за Wary. Для этой версии их слегка нужно будет подкорректировать.
Цитировать
А может потом урезать мультипакет до языков СНГ и сделать свой вариант?
Уже сейчас можно скачать и убрать все другие языковые пакеты, кроме русского. Они там в отдельном каталоге. Насчет других языков СНГ не знаю, не интересовался. Возможно, займусь еще украинским языковым пакетом. Хотя, мне всегда нравились короткие волны, нравилась идея чего-то международного и не хочется ничего делить.
« Последнее редактирование: 06 Февраль 2011, 23:18:51 от rodin.s »

Оффлайн rodin.s

  • Почетный участник
  • Ветеран
  • *
  • Сообщений: 1179
  • Репутация: +96/-0
Re:Wary Puppy 5.0 Вышел Wary 503 beta.
« Ответ #3 : 09 Февраль 2011, 23:37:49 »
Вышел Wary 503 beta на ядре  2.6.32.28, которое, возможно станет основным в Wary т.к. это ядро долгой поддержки. http://bkhome.org/blog/?viewDetailed=02137

Оффлайн rodin.s

  • Почетный участник
  • Ветеран
  • *
  • Сообщений: 1179
  • Репутация: +96/-0
Re:Wary Puppy 5.0 Вышел Wary-500m08
« Ответ #4 : 12 Февраль 2011, 20:58:18 »
Вышла новая версия мултиязычного Wary-500m08 от shinobar. http://www.murga-linux.com/puppy/viewtopic.php?t=63503 На этот раз размер .iso - 129Мб. В .iso включены девять языков, среди которых русский. Большой лангпак на 100 языков, теперь скачивается отдельно.

Оффлайн rodin.s

  • Почетный участник
  • Ветеран
  • *
  • Сообщений: 1179
  • Репутация: +96/-0
Re:Wary Puppy 5.0 Вышел Wary 504 (5.1RC)
« Ответ #5 : 17 Февраль 2011, 20:57:03 »
Вышел Wary 504 (5.1RC) на ядре 2.6.32.28. http://bkhome.org/blog/?viewDetailed=02146 К сожалению на моем ПК это ядро ведет себя так-же, как ядро Lupu - ПК вешается, когда вставляю USB-устройство, но в версии Wary-5.1 можно будет выбрать ядро, как в Wary-0.7, одно из ядер будет с IDE. В этой версии, по идее сразу должно работать переключение раскладок в urxvt. Теперь для этого не нужно менять utf8 на UTF-8 http://bkhome.org/blog/?viewDetailed=02141 (см: http://forum.puppyrus.org/index.php/topic,5340.msg39675.html#msg39675 ). Пакеты локализации еще не готовы. Займусь этим. Есть несколько обновленных скриптов и программ. Старые пакеты могут все испортить.
« Последнее редактирование: 18 Февраль 2011, 00:16:37 от rodin.s »

Оффлайн rodin.s

  • Почетный участник
  • Ветеран
  • *
  • Сообщений: 1179
  • Репутация: +96/-0
Re:Wary Puppy 5.0. Вышел мультиязычный Wary-500m09.
« Ответ #6 : 19 Февраль 2011, 16:21:48 »
Вышел мультиязычный Wary-500m09. Это релиз-кандидат. http://murga-linux.com/puppy/viewtopic.php?t=63503 Также shinobar написал, как сделать версию для определенного языка на основе мультиязычной. http://www.murga-linux.com/puppy/viewtopic.php?p=496812#496812 Попробую сделать для русского.

Оффлайн rodin.s

  • Почетный участник
  • Ветеран
  • *
  • Сообщений: 1179
  • Репутация: +96/-0
Re:Wary Puppy 5.0 Вышел Wary Puppy 5.1
« Ответ #7 : 21 Февраль 2011, 19:43:08 »
Вышел Wary Puppy 5.1. http://bkhome.org/blog/?viewDetailed=02149 Основная версия на ядре долгой поддержки 2.6.32.28, и альтернативная сборка на ядре 2.6.31.14 uniprocessor "ide". Для моих обоих ПК подходит второе ядро. На старом ПК первое ядро долго загружается, а на домашнем ПК зависает если вставить флешку. Поэтому спасибо Барри за второе ядро. Для русификации должны подойти пакеты для Wary-504: http://forum.puppyrus.org/index.php/topic,5340.msg47274.html#msg47274

Оффлайн rodin.s

  • Почетный участник
  • Ветеран
  • *
  • Сообщений: 1179
  • Репутация: +96/-0
Re:Wary Puppy 5.0 Вышел Wary Puppy 5.1.1
« Ответ #8 : 25 Февраль 2011, 19:11:26 »
Вышел Wary Puppy 5.1.1. Минимальное обновление Wary Puppy 5.1.0. http://bkhome.org/blog/?viewDetailed=02158 Обновить можно, загрузив дельта-файл. Интересно то, что сделаны несколько версий для разных ядер (2.6.30.5, 2.6.31.14), а также small-версия (2.6.32.28). Альтернативные сборки здесь: http://distro.ibiblio.org/quirky/wary-5.1.1/alternate_isos/ У меня на старом ПК (AMD K6-3D 333МГц 256Мб ОЗУ) отлично работает версия wary-511-k2.6.31.14-uniproc-ide.iso. Работает мягко и быстро. Один недостаток - ffmpeg скомпилирован для i686 и не работает на i586 (На i686 работает нормально). Использую бинарик mplayer от Jeans-1.3.0. (Использовал его раньше на Puppy-4.3.0 вместо xine).
Впоследствии взял ffmpeg из Wary-0.3, скачал с сайта Барри пакет t2 ffmpeg-2010-06-14.tar.bz, распаковал и сделал pet-пакет (удалил файлы исходников). После установки этого пакета заработал встроенный mplayer на i586.
Для русификации должны подходить пакеты для Wary-504, хотя на выходных займусь обновлением.
Редакт: Обновил пакеты локализации для этой версии http://forum.puppyrus.org/index.php/topic,5340.msg48184.html#msg48184
« Последнее редактирование: 30 Март 2011, 00:12:10 от rodin.s »

Оффлайн rodin.s

  • Почетный участник
  • Ветеран
  • *
  • Сообщений: 1179
  • Репутация: +96/-0
Re:Wary Puppy 5.0 Вышел Quickset Wary.
« Ответ #9 : 01 Март 2011, 19:51:05 »
Вышел Quickset Wary (так переименовали мултиязычный). Размер .iso (wary-501q-k2.6.31.14-small.iso) теперь 101Мб. Он не содержит языковых пакетов, их нужно скачивать отдельно. Размер русского лангпака - около 1,6Мб. http://murga-linux.com/puppy/viewtopic.php?p=499852#499852
И этот Wary, кажется, "заразился" от PuppyRus-2.0 "неподхватыванием" сейв-файла. Live-CD не подхватывает сохраненку с жесткого диска...

Оффлайн rodin.s

  • Почетный участник
  • Ветеран
  • *
  • Сообщений: 1179
  • Репутация: +96/-0
Re:Wary Puppy 5.0 Вышел Quickset Wary 502q.
« Ответ #10 : 02 Март 2011, 21:37:30 »
Исправлена ошибка с файлом сохранения в мультиязычном Wary. Теперь есть две версии: 138Мб с языковыми пакетами, на ядре k2.6.32.28 и 101Мб без языковых пакетов, на ядре k2.6.31.14.  http://murga-linux.com/puppy/viewtopic.php?p=500244#500244

Оффлайн rodin.s

  • Почетный участник
  • Ветеран
  • *
  • Сообщений: 1179
  • Репутация: +96/-0
Re:Wary Puppy 5.0. Вышел Quickset Wary-503q
« Ответ #11 : 06 Март 2011, 21:10:46 »
Вышел Quickset Wary-503q - версия small на ядре k2.6.32.28, размер образа 101MB. Языковые пакеты не включены. Подойдет от предыдущей версии или можно скачать отдельно. Размер русского языкового пакета 1.5Мб.  http://murga-linux.com/puppy/viewtopic.php?p=501414#501414
Сделал ext4-сохраненку. Или мне кажется или на ней на самом деле работает быстрее. И  ext4-сохраненку, кажется, можно сделать только через PupSaveConfig.

Оффлайн rodin.s

  • Почетный участник
  • Ветеран
  • *
  • Сообщений: 1179
  • Репутация: +96/-0
Re:Wary Puppy 5.0. Вышел Quickset Wary-504q.
« Ответ #12 : 10 Март 2011, 20:21:02 »
Вышел  Quickset Wary-504q. Размер 101Мб. Есть дельта-файл - 2Мб. Языковой пакет нужно качать отдельно. Он также был обновлен. http://murga-linux.com/puppy/viewtopic.php?p=502963#502963

Оффлайн rodin.s

  • Почетный участник
  • Ветеран
  • *
  • Сообщений: 1179
  • Репутация: +96/-0
Re:Wary Puppy 5.0 Вышел Quickset Wary-5.1.1q
« Ответ #13 : 27 Март 2011, 01:05:44 »
Вышел Quickset Wary-5.1.1q. Это релиз-кандидат. Версия без языковых пакетов занимает 101Мб. Версия с языковыми пакетами занимает 192Мб. http://murga-linux.com/puppy/viewtopic.php?p=507637&sid=aea3ae1580c25dca4da18854fe7ebef3#507637 Повторю, что русский языковой пакет можно скачать отдельно чтобы не скачивать большую версию. http://182.164.208.118/puppy/wary/languages/lang_pack_ru-0.7-w5.pet
101Мб - это small-версия без flash-плеера и драйверов модемов. Есть полная версия, но там не работает Seamonkey.
Также пока, что не устранен баг с закрытием Seamonkey если нажать на Insert, когда пишешь сообщение на форуме.
« Последнее редактирование: 29 Апрель 2011, 17:34:32 от yvz »

Оффлайн rodin.s

  • Почетный участник
  • Ветеран
  • *
  • Сообщений: 1179
  • Репутация: +96/-0
Re:Wary Puppy 5.0 Вышел Quickset Wary-5.1.1-01q-k2.6.32.28-small
« Ответ #14 : 12 Апрель 2011, 23:47:42 »
Вышел Quickset Wary-5.1.1-01q-k2.6.32.28-small. Еще один релиз-кандидат. Исправлены некоторые ошибки. http://www.murga-linux.com/puppy/viewtopic.php?p=512549&sid=252d3f7d800b929e67d7a5776abfe38a#512549