Сайт | Скачать | Видео | Wiki

Автор Тема: apt-get для lupurus  (Прочитано 8311 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн returning2009

  • Старожил
  • ****
  • Сообщений: 386
  • Репутация: +19/-0
apt-get для lupurus
« : 09 Июнь 2010, 08:56:16 »
Ddshurick как вам удалось задействовать работу atp-get ,я подключил выложенный вами sfs aptitude,при команде apt-get install программа ,консоль матернулась на отсутствие dpkg,скачал поставил,сконфигурировал его  по совету той же матерящейся консоли,скопировал из ubuntu по списку  path ,ldconfig а также preconfigure ,apt-get наконец-то начал качать но к сожалению только обявленый пакет то есть зависимости не тянет,apt-get update делал..Ddshurick пожалуйста если у вас есть время опишите кратко метод коректного запуска aptitude,если оно заработает в lupurus я ему всё прощу   :D ,даже его нелубовь к моей видео карте,спасибо вам...
« Последнее редактирование: 09 Июнь 2010, 08:58:04 от returning2009 »

Оффлайн DdShurick

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 4885
  • Репутация: +135/-0
  • Старый чайник
Re: apt-get для lupurus
« Ответ #1 : 09 Июнь 2010, 10:19:23 »
 У меня подключен тот же самый apt-get-lucid.sfs и заработал он сразу без настройки. dpkg в состав пакета входит (/usr/bin/dpkg)  ???
 lupurus-500
Моноблок Lenovo IdeaCentre c200
Netbook Acer 722 c6ckk
Netbook Lenovo IdeaPad S10-3c

Оффлайн imp

  • /dev/бубен
  • Ветеран
  • *****
  • Сообщений: 543
  • Репутация: +25/-1
  • Пусть воюют другие
Re:apt-get для lupurus
« Ответ #2 : 25 Август 2011, 00:35:52 »
Собрал еще один недоделок
Synaptic  (менеджер пакетов убунту): http://www.mediafire.com/?21a3eo9uakq6tdm
Появляется в меню в разделе system
Положить руссификацию вспомнил после того, как залил недотяпок, вот - держите
http://www.mediafire.com/?ak54vggbp896ijj
Положить в /usr/share/locale/ru/LC_MESSAGES

После установки в консоли выполнить
# adduser hplip        и нажать enter
потом еще 2 раза enter
Потом запустить и обновить базу пакетов (две такие закольцованные стрелочки)

Если начнет сильно ругаться при установке - в /var/lib/dpkg найти файл status
и в нем строки:
Package: libc6-i686
Status: install ok not-installed   -  здесь заменить на Status: install ok installed
Или взять мой: http://www.mediafire.com/?sywmwqw504cku2p

Один черт при установке некоторых пакетов может материться. Не все проблемы убрал в status.
Ругается на зависимости, которые не могут быть установлены.
Решается при помощи
# dpkg --force-depends -i /путь/имя пакета

Короче говоря - курите маны по dpkg ;)

А вообще в кеш выкачивает исправно. Надеюсь, что пригодится
Не бейте сильно :angel:
Компьютер имеет то преимущество перед мозгом, что им пользуются.

Оффлайн imp

  • /dev/бубен
  • Ветеран
  • *****
  • Сообщений: 543
  • Репутация: +25/-1
  • Пусть воюют другие
Re:apt-get для lupurus
« Ответ #3 : 02 Январь 2014, 02:33:46 »
Понову собрал апты с dpkg и синаптиками. Теря даже устанавливает, удаляет, обновляет из гуя.
Но есть одно но - некоторые пакеты (которые к непосредственно системе относятся) хрен удалишь, или если нужно удаление, при разруливании зависимостей - хрен установишь.

1. Кто-нить знает, какую клизму поставить этим аптам?

2. Кому-нить такое надо? Если что - выложу.

3.Может, таки лучше допилить slapt-get или packman (packman не пробовал, как с зависимостями - хз)
Компьютер имеет то преимущество перед мозгом, что им пользуются.

Оффлайн sfs

  • Администратор
  • Ветеран
  • *****
  • Сообщений: 17494
  • Репутация: +137/-0
    • PuppyRus-A
Re:apt-get для lupurus
« Ответ #4 : 02 Январь 2014, 08:46:01 »
1. Кто-нить знает, какую клизму поставить этим аптам?
pacman. Там база установленного не в одном файле, как у апт
Если система не собиралась апт-ом через свою репу (любым ПМ) - апт сломает пупи
2. Кому-нить такое надо? Если что - выложу.
http://forum.puppyrus.org/index.php/topic,12651.msg85971.html#msg85971
синаптик-то зачем? Представляю сколько весит.
3.Может, таки лучше допилить slapt-get или packman (packman не пробовал, как с зависимостями - хз)
См. комментарий к 1 про любой ПМ или добро пожаловать в PRA. Там эти проблемы решены