Сайт | Скачать | Видео | Wiki

Автор Тема: glibc 2.30 для запуска свежего софта свежих дистрибутивов  (Прочитано 708 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн sfs

  • Администратор
  • Ветеран
  • *****
  • Сообщений: 28882
  • Репутация: +195/-0
    • PuppyRus-A
glibc 2.30 вышел. В deb10 , насколько я понимаю его не будет - там 228
Но в арче и пр. бодрых дистрах скоро появится и бинарники не будут запускаться со старым glibc
Пока таких для теста не нашел. С ДДР01 сейчас glibc228 (из деб 10) . Т.е. проблема уже будет и с 229 - который во многих дистрах уже

Попробовал скомпилить деб. методом
ftp://ftp.yandex.ru/puppyrus/ddr/ddr01/pkg/glibc-2.30
Жесть. В арче 1 пакет. Пара патчей. Здесь десятки пакетов и патчей
С горем пополам скомпилил на деб.  шаблонах glibc224 (родного деб-у 9)
Патчи взял только арчевые

libc6_2.30-ddr01-sf03.pfs
С libc6-bin. У меня с ним почему-то не запускается lxterminal. Не находил либу vte (она есть)

libc6_2.30-ddr01-sf04.pfs
Без libc6-bin.
Положить в /base
Проблем пока не выявил
« Последнее редактирование: 05 Август 2019, 12:36:04 от sfs »