Сайт | Скачать | Видео | Wiki

Автор Тема: PRA6408-1904 Не работает Pacman.  (Прочитано 130 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн lynya5

  • Пользователь
  • **
  • Сообщений: 32
  • Репутация: +0/-0
PRA6408-1904 Не работает Pacman.
« : 01 Ноябрь 2019, 11:36:32 »
ошибка: недопустимый параметр '--force'
ошибка: файл /etc/pacman.conf, строка 40: 'SigLevel' недопустимый параметр, поддержка подписей недоступна.
Перестает работать после сохранения в 090-save.pfs. может как то pacman.conf подредактировать? спасибо.

Оффлайн sfs

  • Администратор
  • Ветеран
  • *****
  • Сообщений: 27173
  • Репутация: +184/-0
    • PuppyRus-A
Re: PRA6408-1904 Не работает Pacman.
« Ответ #1 : 01 Ноябрь 2019, 12:17:40 »
--force давно слит в свежих версиях pacman
SigLevel - подписи уже я слил для экономии места. Надо отключать на всех репах

Оффлайн krasnyh

  • Ветеран
  • *****
  • Сообщений: 2238
  • Репутация: +75/-0
Re: PRA6408-1904 Не работает Pacman.
« Ответ #2 : 01 Ноябрь 2019, 13:07:55 »
Использовать аргумент --overwrite. Но там не так просто как было с --force, я сам до сих пор не наловчился. Сейчас проще не допускать таких ситуаций, чем использовать его.  :)
Цитата
pacman -S --overwrite glob package

"Failed to commit transaction (conflicting files)" error
pacman (man)


Статья от одного из авторов pacman:
Pacman-5.1 – Don’t Use the Force, Luke!
Опция --overwrite была заменена более года и является точным хирургическим инструментом по сравнению с тупым молотом --force. (c)
« Последнее редактирование: 01 Ноябрь 2019, 13:36:05 от krasnyh »