Сайт | Скачать | Видео | Wiki

Автор Тема: Компиляция проприетарных видеодрайверов и пр. модулей ядра  (Прочитано 991 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Neyel

  • Ветеран
  • *****
  • Сообщений: 473
  • Репутация: +18/-0
kernel-4.20.15
Если будет время, могу попробовать собрать nvidia-390.87 для этого ядра. Модуль DEVX в DDR01 есть? Нужен ещё linux-headers для этого ядра.
« Последнее редактирование: 29 Май 2019, 17:04:41 от sfs »

Оффлайн krasnyh

  • Ветеран
  • *****
  • Сообщений: 1897
  • Репутация: +63/-0

Оффлайн sfs

  • Администратор
  • Ветеран
  • *****
  • Сообщений: 26490
  • Репутация: +179/-0
    • PuppyRus-A
Компилить модули ядра можно под любым дистром. главное иметь именно его сырцы
Самый простой путь - взять самое свежее c дровами от Pro
ftp://mirror.yandex.ru/puppyrus/puppyrus-a/kernel/0ld-01/4.9.5-pf4-videodrv/
Почему никто не рассматривает этот вариант? С этим ядром что-то не так?

Оффлайн Neyel

  • Ветеран
  • *****
  • Сообщений: 473
  • Репутация: +18/-0
ftp://mirror.yandex.ru/puppyrus/puppyrus-a/kernel/0ld-01/4.9.5-pf4-videodrv/
Почему никто не рассматривает этот вариант? С этим ядром что-то не так?
В ddr01 нет же этого ядра
Компилить модули ядра можно под любым дистром. главное иметь именно его сырцы
То есть в принципе можно перенести ядро ddr01 (4.20) на пра03 и там откомпилить? И драйвера так же заработают на ddr01?

Оффлайн sfs

  • Администратор
  • Ветеран
  • *****
  • Сообщений: 26490
  • Репутация: +179/-0
    • PuppyRus-A
В ddr01 нет же этого ядра
Потому и нет, что не тестировали
Нет ядер DDR PRA. Есть только 32\64
можно перенести ядро ddr01 (4.20) на пра03 и там откомпилить? И драйвера так же заработают на ddr01?
да

Оффлайн Neyel

  • Ветеран
  • *****
  • Сообщений: 473
  • Репутация: +18/-0
Ядро перенёс (на пра03-фат), при компиляции ошибка следующая:
Код
make[1]: вход в каталог «/usr/lib/modules/4.20.15-pf7/build»
make[1]: *** Нет правила для сборки цели «modules».  Останов.

Как я понимаю правила для сборки должны содержаться в linux-headers, но этот модуль у меня подключен - https://mirror.yandex.ru/puppyrus/puppyrus-a/kernel/new/4.20.15-pf7/linux_headers-4.20.15-pf7.pfs - вообщем не знаю что и делать

Оффлайн krasnyh

  • Ветеран
  • *****
  • Сообщений: 1897
  • Репутация: +63/-0
make[1]: вход в каталог «/usr/lib/modules/4.20.15-pf7/build»
make[1]: *** Нет правила для сборки цели «modules».  Останов
Сталкивался с подобной ошибкой, когда пробовал ядро собрать.
Интересно, что спецы скажут.

p.s. Или не ядро. Но ошибку такую встречал при компиляции чего-то.
« Последнее редактирование: 29 Май 2019, 15:46:04 от krasnyh »

Оффлайн sfs

  • Администратор
  • Ветеран
  • *****
  • Сообщений: 26490
  • Репутация: +179/-0
    • PuppyRus-A

Оффлайн Neyel

  • Ветеран
  • *****
  • Сообщений: 473
  • Репутация: +18/-0
Надо https://mirror.yandex.ru/puppyrus/puppyrus-a/kernel/new/4.20.15-pf7/kernel4.20.15-pf7_src_patched.pfs
Компиляция пошла, но завершилась ошибкой:
Код
cc1: некоторые предупреждения считаются ошибками
scripts/Makefile.build:291: ошибка выполнения рецепта для цели «/home/live/nvidia/src/NVIDIA-Linux-x86-390.87/kernel/nvidia-drm/nvidia-drm-encoder.o»
make[2]: *** [/home/live/nvidia/src/NVIDIA-Linux-x86-390.87/kernel/nvidia-drm/nvidia-drm-encoder.o] Ошибка 1
make[2]: *** Ожидание завершения заданий…
/home/live/nvidia/src/NVIDIA-Linux-x86-390.87/kernel/nvidia-drm/nvidia-drm-connector.c: В функции «nv_drm_connector_get_modes»:
/home/live/nvidia/src/NVIDIA-Linux-x86-390.87/kernel/nvidia-drm/nvidia-drm-connector.c:229:9: ошибка: implicit declaration of function «drm_mode_connector_update_edid_property»; did you mean «drm_connector_update_edid_property»? [-Werror=implicit-function-declaration]
         drm_mode_connector_update_edid_property(
         ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
         drm_connector_update_edid_property
cc1: некоторые предупреждения считаются ошибками
scripts/Makefile.build:291: ошибка выполнения рецепта для цели «/home/live/nvidia/src/NVIDIA-Linux-x86-390.87/kernel/nvidia-drm/nvidia-drm-connector.o»
make[2]: *** [/home/live/nvidia/src/NVIDIA-Linux-x86-390.87/kernel/nvidia-drm/nvidia-drm-connector.o] Ошибка 1
Makefile:1562: ошибка выполнения рецепта для цели «_module_/home/live/nvidia/src/NVIDIA-Linux-x86-390.87/kernel»
make[1]: *** [_module_/home/live/nvidia/src/NVIDIA-Linux-x86-390.87/kernel] Ошибка 2
make[1]: выход из каталога «/usr/src/linux-4.20.15-pf7»
Makefile:79: ошибка выполнения рецепта для цели «modules»
make: *** [modules] Ошибка 2
==> ОШИБКА: Произошел сбой в build().
    Прерывание...
« Последнее редактирование: 29 Май 2019, 17:09:09 от sfs »

Оффлайн sfs

  • Администратор
  • Ветеран
  • *****
  • Сообщений: 26490
  • Репутация: +179/-0
    • PuppyRus-A
Как компилите? откуда исходники и патчи?

Попробуйте https://gitlab.manjaro.org/packages/extra/linux420-extramodules/nvidia-390xx
Там есть патч по это ядро
А может gcc надо свежее

Оффлайн k0l0p0k

  • Ветеран
  • *****
  • Сообщений: 1332
  • Репутация: +20/-1
первое попавшееся объяснение
https://ru.stackoverflow.com/questions/621983/%D0%9E%D1%82%D0%BA%D1%83%D0%B4%D0%B0-%D0%BE%D1%88%D0%B8%D0%B1%D0%BA%D0%B0-warning-implicit-declaration-of-function-xxx
функция где-то заранее не объявлена
в опциях gcc попытаться выключить\убрать -Werror=implicit-function-declaration
?

« Последнее редактирование: 29 Май 2019, 16:59:37 от k0l0p0k »
1.нетбук  Samsung N145 (оси: Debian+OLS, ddr01)
2.стационары(пеньки,2-8Gb,Radeon RX460,HD7850 ubuntu+openBox+LXPanel, PRA, ddr01)

Оффлайн sfs

  • Администратор
  • Ветеран
  • *****
  • Сообщений: 26490
  • Репутация: +179/-0
    • PuppyRus-A
первое попавшееся объяснение
Посмотрите патч и сделайте вывод, что не ядерному программеру такое не написать
Так что правильный подход - взять рецепт , патчи и исходники  из какого-нибудь дистра под Вашу версию ядра

Оффлайн k0l0p0k

  • Ветеран
  • *****
  • Сообщений: 1332
  • Репутация: +20/-1
что не ядерному программеру такое не написать
согласен полностью
я не к тому что патч не правильно написан, нет
скорее рецепт компиляции неверен(как правильно замечено)
« Последнее редактирование: 29 Май 2019, 17:29:23 от k0l0p0k »
1.нетбук  Samsung N145 (оси: Debian+OLS, ddr01)
2.стационары(пеньки,2-8Gb,Radeon RX460,HD7850 ubuntu+openBox+LXPanel, PRA, ddr01)

Оффлайн Pro

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 10300
  • Репутация: +103/-2
NVIDIA-Linux-x86-390.87/
нужно более свежую версию 390.116 и выше и патчить не придется
Я загружаю новые пакеты сюда: http://file.puppyrus.org/users/ а дальше можно найти самостоятельно.

Оффлайн Neyel

  • Ветеран
  • *****
  • Сообщений: 473
  • Репутация: +18/-0
NVIDIA-Linux-x86-390.87/
нужно более свежую версию 390.116 и выше и патчить не придется
390.116 откомпилил без проблем, выполнил sudo modpobe nvidia - всё в порядке, перезагрузил X-ы а inxi -G выдал следующее:
Код
live@pra:~$ inxi -G
Resuming in non X mode: glxinfo not found. For package install advice run: inxi --recommends
Graphics:  Card: NVIDIA GF108 [GeForce GT 630]
           Display Server: X.org 1.16.2.901 drivers: nv,vesa,nouveau (unloaded: modesetting,fbdev)
           tty size: 112x38
- т.е. драйвера не подцепились - в чём может быть проблема? версия Xorg не подходит?