Сайт | Скачать | Видео | Wiki

Автор Тема: PRA Roll - не могу установить программы  (Прочитано 541 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн spirid1990

  • Постоялец
  • ***
  • Сообщений: 139
  • Репутация: +0/-0
PRA Roll - не могу установить программы
« : 03 Сентябрь 2018, 09:41:33 »
В поиске нахожу нужные программы, устанавливаю флажок и нажимаю Применить. Появляется окно "Ошибка git". Ввожу в строке поиска "git" - нет результатов. Что я делаю неправильно?

Оффлайн sfs

  • Администратор
  • Ветеран
  • *****
  • Сообщений: 23706
  • Репутация: +173/-0
    • PuppyRus-A
Re: PRA Roll - не могу установить программы
« Ответ #1 : 03 Сентябрь 2018, 09:54:21 »
Что я делаю неправильно?
Не указываете в каком поиске какой программы и какую вообще задачу решаете, тип установки дистра
Учитесь задавать вопросы

Оффлайн spirid1990

  • Постоялец
  • ***
  • Сообщений: 139
  • Репутация: +0/-0
Re: PRA Roll - не могу установить программы
« Ответ #2 : 05 Сентябрь 2018, 08:36:09 »
pra roll установлен на флешке c fat32 путем копирования и использования grub4dos. Загружаюсь в флешки на планшете с EFI и диском GPT.  Система-Установка и удаление программ.
В поисковой строке набираю "Visual". Ставлю флажок рядом с "visual-studio-code-bin", нажимаю Применить.
Появляется диалоговое окно с заголовком "Ошибка подготовки транзакции" и текстом внутри окна "объект не найден: git". Та же ситуация при наборе в поиске "Yandex" и попытке установить яндекс браузер бета. Что нужно сделать, чтобы программы устанавливались?

Оффлайн spirid1990

  • Постоялец
  • ***
  • Сообщений: 139
  • Репутация: +0/-0
Re: PRA Roll - не могу установить программы
« Ответ #3 : 05 Сентябрь 2018, 08:50:36 »
Еще заметил следующее:
1. В трее оранжевый значок с восклицательным знаком "ALSA не активирована"
2. В Установка и удаление программ нажимаю Update, появляется список обновлений. Нажимаю Применить - в терминальном окне появляется сообщение "Запуск полного обновления системы" и ничего не происходит.
У меня  последняя версия Pra roll с gtk3.

Оффлайн sfs

  • Администратор
  • Ветеран
  • *****
  • Сообщений: 23706
  • Репутация: +173/-0
    • PuppyRus-A
Re: PRA Roll - не могу установить программы
« Ответ #4 : 05 Сентябрь 2018, 09:15:00 »
frugal?
В поисковой строке набираю "Visual"
Так и не понял в какой проге делаете поиск
Установить :
sudo pacman -Sy visual-studio-code-bin
Сделать модуль :
sudo pacman2pfs visual-studio-code-bin
Подробнее в вики

1. В трее оранжевый значок с восклицательным знаком "ALSA не активирована"
Звук есть?
2. В Установка и удаление программ нажимаю Update
Что хотите на выходе этой операции?

1 проблема - 1 тема
« Последнее редактирование: 05 Сентябрь 2018, 09:16:39 от sfs »

Оффлайн spirid1990

  • Постоялец
  • ***
  • Сообщений: 139
  • Репутация: +0/-0
Re: PRA Roll - не могу установить программы
« Ответ #5 : 05 Сентябрь 2018, 10:55:57 »
Поиск - нажимаю значок меню в левом нижнем углу, далее выбираю установка и удаление программ

Оффлайн spirid1990

  • Постоялец
  • ***
  • Сообщений: 139
  • Репутация: +0/-0
Re: PRA Roll - не могу установить программы
« Ответ #6 : 05 Сентябрь 2018, 11:05:05 »
Наверное, frugal. Я подключил iso в Windows 10, скопировал его на флешку, отформатированную в фат32, запустил администратором grub4dosgui и установил его на флешку
 

Оффлайн sfs

  • Администратор
  • Ветеран
  • *****
  • Сообщений: 23706
  • Репутация: +173/-0
    • PuppyRus-A
Re: PRA Roll - не могу установить программы
« Ответ #7 : 05 Сентябрь 2018, 11:06:01 »

Оффлайн spirid1990

  • Постоялец
  • ***
  • Сообщений: 139
  • Репутация: +0/-0
Re: PRA Roll - не могу установить программы
« Ответ #8 : 15 Сентябрь 2018, 12:32:03 »
Что-то у меня не получилось установить Visual Studio Code:sudo pacman -Sy visual-studio-code-bin
:: Обновление баз данных пакетов...
 pra6407extra не устарел
 2a-any не устарел
 core не устарел
 extra не устарел
 community не устарел
 art-aur не устарел
 revenge_repo                        38,9 KiB   512K/s 00:00 [################################] 100%
 herecura не устарел
 archlinuxcn                        892,0 KiB  2,90M/s 00:00 [################################] 100%
разрешение зависимостей...
предупреждение: не удалось разрешить "glibc>=2.28-4", зависимость "visual-studio-code-bin"
:: Этот пакет не может быть обновлен из-за неразрешимых зависимостей:
      visual-studio-code-bin

:: Вы уверены что хотите пропустить этот пакет при обновлении? [y/N]
Как решить эту проблему?

Оффлайн sfs

  • Администратор
  • Ветеран
  • *****
  • Сообщений: 23706
  • Репутация: +173/-0
    • PuppyRus-A
Re: PRA Roll - не могу установить программы
« Ответ #9 : 16 Сентябрь 2018, 10:38:46 »
не удалось разрешить "glibc>=2.28-4",В ролл1806 я это обновил, в 1801 пока нет
Скачайте свежий пакет glibc и pacman2pfs -U glibc*
Подученный модуль в >base + перезагрузиться. Проверить версию glibc : iconv -V

Оффлайн spirid1990

  • Постоялец
  • ***
  • Сообщений: 139
  • Репутация: +0/-0
Re: PRA Roll - не могу установить программы
« Ответ #10 : 16 Сентябрь 2018, 18:24:26 »
Попробовал найти glibc>=2.28-4. Не получилось:sudo pacman -Ss glibc
core/glibc 2.26-8 (base) [установлен]
    GNU C Library
core/lib32-glibc 2.26-8
    GNU C Library (32-bit)
extra/nss-mdns 0.10-6
    glibc plugin providing host name resolution via mDNS
community/aarch64-linux-gnu-glibc 2.26-1
    GNU C Library ARM64 target
archlinuxcn/arm-linux-gnueabihf-glibc 2.28-1
    GNU C Library (arm-linux-gnueabihf)
Как еще можно найти нужные пакеты?

Оффлайн krasnyh

  • Ветеран
  • *****
  • Сообщений: 817
  • Репутация: +39/-0
Re: PRA Roll - не могу установить программы
« Ответ #11 : 16 Сентябрь 2018, 19:21:27 »
Что-то у меня не получилось установить Visual Studio Code:
$ packer visual-studio-code-bin
0 archlinuxcn/visual-studio-code-bin 1.27.2-1
      Visual Studio Code: Editor for building and debugging modern web and cloud
      applications (official binary version)
1 aur/visual-studio-code-bin 1.27.2-1 (735)
    Visual Studio Code: Editor for building and debugging modern web and cloud
    applications (official binary version)

Type numbers to install. Separate each number with a space.
Numbers: 1
разрешение зависимостей...
проверка конфликтов...

Пакеты (2) gconf-3.2.6+11+g07808097-3  visual-studio-code-bin-1.27.2-1

Будет загружено:   43,56 MiB
Будет установлено:  198,40 MiB
pra-roll-1806-gtk3-01
 Подключил модули: DEVX-prar-1806-sf02, nss-3.37.1-1806-sf02, polkit-0.114-1806-sf01.
Докинул в /usr/lib две либы (libavahi-common.so.3, libavahi-client.so.3).
$ ldd /opt/visual-studio-code/code |grep not
libavahi-common.so.3 => not found
libavahi-client.so.3 => not found
Все прекрасно запустилось. Скриншот:

Оффлайн spirid1990

  • Постоялец
  • ***
  • Сообщений: 139
  • Репутация: +0/-0
Re: PRA Roll - не могу установить программы
« Ответ #12 : 16 Сентябрь 2018, 20:03:09 »
Все прекрасно запустилось
А у меня такие результаты:
live@pra-roll:~$ sudo pacman -Syy
:: Обновление баз данных пакетов...
 pra6407extra                        93,4 KiB  3,80M/s 00:00 [################################] 100%
 2a-any                              23,1 KiB  1922K/s 00:00 [################################] 100%
 core                               126,2 KiB   809K/s 00:00 [################################] 100%
 extra                             1643,2 KiB  4,83M/s 00:00 [################################] 100%
 community                            4,3 MiB  3,40M/s 00:01 [################################] 100%
 art-aur                             10,3 KiB  0,00B/s 00:00 [################################] 100%
 revenge_repo                        38,9 KiB   512K/s 00:00 [################################] 100%
 herecura                            67,1 KiB   258K/s 00:00 [################################] 100%
 archlinuxcn                        892,1 KiB  1477K/s 00:01 [################################] 100%
live@pra-roll:~$ sudo packer visual-studio-code-bin
0 archlinuxcn/visual-studio-code-bin 1.27.2-1
      Visual Studio Code: Editor for building and debugging modern web and cloud applications
      (official binary version)
1 aur/visual-studio-code-bin 1.27.2-1 (735)
    Visual Studio Code: Editor for building and debugging modern web and cloud applications
    (official binary version)

Type numbers to install. Separate each number with a space.
Numbers: 0
разрешение зависимостей...
предупреждение: не удалось разрешить "glibc>=2.28-4", зависимость "visual-studio-code-bin"
:: Этот пакет не может быть обновлен из-за неразрешимых зависимостей:
      visual-studio-code-bin
:: Вы уверены что хотите пропустить этот пакет при обновлении? [y/N] n
ошибка: не удалось подготовить транзакцию (не удалось удовлетворить зависимости)
:: visual-studio-code-bin: требует glibc>=2.28-4

Оффлайн krasnyh

  • Ветеран
  • *****
  • Сообщений: 817
  • Репутация: +39/-0
Re: PRA Roll - не могу установить программы
« Ответ #13 : 16 Сентябрь 2018, 20:23:59 »
А у меня такие результаты:
live@pra-roll:~$ sudo packer visual-studio-code-bin
1. packer запускается без sudo
2. Посмотреть мое  сообщение выше. У меня выбрана вторая позиция.
Цитировать
Type numbers to install. Separate each number with a space.
Numbers: 1

Оффлайн spirid1990

  • Постоялец
  • ***
  • Сообщений: 139
  • Репутация: +0/-0
Re: PRA Roll - не могу установить программы
« Ответ #14 : 16 Сентябрь 2018, 21:19:40 »
Что-то у меня не получается:sudo pacman -Syy
:: Обновление баз данных пакетов...
 pra6407extra                        93,4 KiB  3,80M/s 00:00 [################################] 100%
 2a-any                              23,1 KiB  5,63M/s 00:00 [################################] 100%
 core                               126,2 KiB   809K/s 00:00 [################################] 100%
 extra                             1643,2 KiB  4,14M/s 00:00 [################################] 100%
 community                            4,3 MiB  5,00M/s 00:01 [################################] 100%
 art-aur                             10,3 KiB  0,00B/s 00:00 [################################] 100%
 revenge_repo                        38,9 KiB   540K/s 00:00 [################################] 100%
 herecura                            67,1 KiB   134K/s 00:01 [################################] 100%
 archlinuxcn                        892,1 KiB  2,18M/s 00:00 [################################] 100%
live@pra-roll:~$ packer visual-studio-code-bin
0 archlinuxcn/visual-studio-code-bin 1.27.2-1
      Visual Studio Code: Editor for building and debugging modern web and cloud applications
      (official binary version)
1 aur/visual-studio-code-bin 1.27.2-1 (735)
    Visual Studio Code: Editor for building and debugging modern web and cloud applications
    (official binary version)

Type numbers to install. Separate each number with a space.
Numbers: 1
разрешение зависимостей...
предупреждение: не удалось разрешить "glibc>=2.28-4", зависимость "visual-studio-code-bin"
:: Этот пакет не может быть обновлен из-за неразрешимых зависимостей:
      visual-studio-code-bin

:: Вы уверены что хотите пропустить этот пакет при обновлении? [y/N] y
проверка конфликтов...
 делать больше нечего