Сайт | Скачать | Видео | Wiki

Автор Тема: PRA-roll 1806. Предварительное тестирование  (Прочитано 4271 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Онлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 23160
  • Репутация: +167/-0
    • PuppyRus-A
Re: PRA-roll 1806. Предварительное тестирование
« Ответ #30 : 01 Июнь 2018, 09:55:34 »
Разобрался.
все правильно

Онлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 23160
  • Репутация: +167/-0
    • PuppyRus-A
Re: PRA-roll 1806. Предварительное тестирование
« Ответ #31 : 01 Июнь 2018, 11:00:25 »
Ни в одном vte2 терминале мышка в mc не работает
Менял версии mc xorg lxterm , пробовал с systemd и minirc - без улучшений
Надо попробовать в другом арче....
Попробовал в arcolinux-v6.7.1-2018.04.26.iso (xorg 1.19) так же плохо
Взял vte из Альта (c ncurces5) - без улучшений

Больше идей нет. Разве что написать на форум арча или в comments
Кто силен в английском? Помогите
Добавил в шапку. Пока оставляю так
« Последнее редактирование: 01 Июнь 2018, 11:03:23 от sfs »

Онлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 23160
  • Репутация: +167/-0
    • PuppyRus-A

Онлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 23160
  • Репутация: +167/-0
    • PuppyRus-A
Re: PRA-roll 1806. Предварительное тестирование
« Ответ #33 : 01 Июнь 2018, 14:09:56 »
В pra-roll-180101-gtk3-02 мышь работает в mc (lxterminal). Это потому, что GTK3? 
да. Проблема только в ролл1806-gtk2

Онлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 23160
  • Репутация: +167/-0
    • PuppyRus-A
Re: PRA-roll 1806. Предварительное тестирование
« Ответ #34 : 01 Июнь 2018, 14:19:12 »
Почему панель именно tint,
Начал с самой простой. Другие тоже будут

Оффлайн RoDoN

  • Модератор
  • Ветеран
  • ****
  • Сообщений: 5437
  • Репутация: +118/-0
    • RoDoN
Re: PRA-roll 1806. Предварительное тестирование
« Ответ #35 : 01 Июнь 2018, 14:57:40 »
Начал с самой простой. Другие тоже будут
А может быть все-таки стоит определиться уже с DE или c WM+ФМ+панель и пилить что-то одно, чтобы было удобно пользоваться из коробки, чтобы настройки были не дефолтными, а удобными, чтобы его не надо было каждый раз при выходе новой версии iso обрабатывать "драчевым напильником", а только возможно слегка подправлять "надфильком".

Acer Aspire One AO751h (Atom Z520, Intel GMA500)
Acer Extensa 5620Z (T7500, Intel 965GM)
PuppyRus-JWM-13.12, PRA, Upup Precise, Tahr Puppy, Runtu 14.04 XFCE.

Оффлайн Pro

  • Модератор
  • Ветеран
  • ****
  • Сообщений: 9800
  • Репутация: +100/-0
Re: PRA-roll 1806. Предварительное тестирование
« Ответ #36 : 01 Июнь 2018, 15:03:17 »
Начал с самой простой. Другие тоже будут
А может быть все-таки стоит определиться уже с DE или c WM+ФМ+панель и пилить что-то одно, чтобы было удобно пользоваться из коробки, чтобы настройки были не дефолтными, а удобными, чтобы его не надо было каждый раз при выходе новой версии iso обрабатывать "драчевым напильником", а только возможно слегка подправлять "надфильком".

Давайте конкретные предложения, что надо исправлять (с)sfs

Я загружаю новые пакеты сюда: http://file.puppyrus.org/users/ а дальше можно найти самостоятельно.

Оффлайн RoDoN

  • Модератор
  • Ветеран
  • ****
  • Сообщений: 5437
  • Репутация: +118/-0
    • RoDoN
Re: PRA-roll 1806. Предварительное тестирование
« Ответ #37 : 01 Июнь 2018, 15:26:55 »
И как насчет графического ФМ? А то только mc не всегда удобно.
pacman2pfs фм
Решил воспользоваться советом и поставить тунар.
Сделал пакет, подключил, а тунар не запускается:
live@pra-roll:~$ thunar
thunar: error while loading shared libraries: libxfce4util.so.6: cannot open shared object file: No such file or directory

Поставил просто пакманом, а результат тот же:
live@pra-roll:~$ sudo pacman -Sy thunar
:: Обновление баз данных пакетов...
 pra6407extra не устарел
 2a-any не устарел
 core не устарел
 extra не устарел
 community не устарел
 art-aur не устарел
 revenge_repo                        38,9 KiB   256K/s 00:00 [################################] 100%
 herecura не устарел
 archlinuxcn не устарел
ошибка: противоречивая информация в базе данных 2a-any: не совпадает имя пакета frozen
ошибка: противоречивая информация в базе данных 2a-any: не совпадает версия пакета frozen
разрешение зависимостей...
проверка конфликтов...

Пакеты (10) db-5.3.28-3  exo-0.10.7-2  gdbm-1.14.1-1  libexif-0.6.21-3  libxfce4ui-4.10.0-2
            libxfce4util-4.12.1-1  perl-5.26.2-1  perl-uri-1.74-1  xfconf-4.12.1-4  thunar-1.6.15-1

Будет загружено:  17,05 MiB
Будет установлено:  71,49 MiB

:: Приступить к установке? [Y/n] y
:: Получение пакетов...
 libxfce4ui-4.10.0-2-x86_64         161,0 KiB   474K/s 00:00 [################################]   0%
 exo-0.10.7-2-x86_64                719,1 KiB   519K/s 00:01 [################################]   4%
 gdbm-1.14.1-1-x86_64               871,5 KiB   451K/s 00:02 [################################]   4%
 db-5.3.28-3-x86_64                1969,1 KiB   600K/s 00:03 [################################]  11%
 perl-5.26.2-1-x86_64                15,5 MiB   838K/s 00:19 [################################]  91%
 libexif-0.6.21-3-x86_64             15,9 MiB   832K/s 00:20 [################################]  93%
 libxfce4util-4.12.1-1-x86_64        16,0 MiB   824K/s 00:20 [################################]  93%
 xfconf-4.12.1-4-x86_64              16,1 MiB   817K/s 00:20 [################################]  94%
 perl-uri-1.74-1-any                 16,2 MiB   810K/s 00:20 [################################]  94%
 thunar-1.6.15-1-x86_64              17,0 MiB   808K/s 00:22 [################################] 100%
(10/10) проверка ключей                                      [################################] 100%
(10/10) проверка целостности пакета                          [################################] 100%
(10/10) загрузка файлов пакетов                              [################################] 100%
(10/10) проверка конфликтов файлов                           [################################] 100%
(10/10) проверка доступного места                            [################################] 100%
:: Обработка изменений пакета...
( 1/10) установка libexif                                    [################################] 100%
( 2/10) установка libxfce4util                               [################################] 100%
( 3/10) установка xfconf                                     [################################] 100%
( 4/10) установка gdbm                                       [################################] 100%
( 5/10) установка db                                         [################################] 100%
( 6/10) установка perl                                       [################################] 100%
( 7/10) установка libxfce4ui                                 [################################] 100%
( 8/10) установка perl-uri                                   [################################] 100%
( 9/10) установка exo                                        [################################] 100%
(10/10) установка thunar                                     [################################] 100%
Дополнительные зависимости для 'thunar'
    gvfs: for trash support, mounting with udisk and remote filesystems
    xfce4-panel: for trash applet
    tumbler: for thumbnail previews
    thunar-volman: manages removable devices
    thunar-archive-plugin: create and deflate archives
    thunar-media-tags-plugin: view/edit id3/ogg tags
:: Запуск post-transaction hooks...
(1/3) Warn about old perl modules
(2/3) Updating icon theme caches...
(3/3) Updating the desktop file MIME type cache...
live@pra-roll:~$ thunar
thunar: error while loading shared libraries: libxfce4util.so.6: cannot open shared object file: No such file or directory
live@pra-roll:~$

Странно, устанавливается libxfce4util.so.7, а ругается на libxfce4util.so.6  ???

Acer Aspire One AO751h (Atom Z520, Intel GMA500)
Acer Extensa 5620Z (T7500, Intel 965GM)
PuppyRus-JWM-13.12, PRA, Upup Precise, Tahr Puppy, Runtu 14.04 XFCE.

Онлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 23160
  • Репутация: +167/-0
    • PuppyRus-A
Re: PRA-roll 1806. Предварительное тестирование
« Ответ #38 : 01 Июнь 2018, 15:29:23 »
может быть все-таки стоит определиться уже с DE или c WM+ФМ+панель и пилить что-то одно
Я уже запилил (см. pacman -Ss pra-de). И не только одну ДЕ. У меня пока  нет больше идей по их изменению.
У кого есть - предлагайте
чтобы его не надо было каждый раз при выходе новой версии iso обрабатывать "драчевым напильником", а только возможно слегка подправлять "надфильком".
На мой взгляд уже так и есть
Собрал ols - пришлось подправить только lxterminal-gtk2 (т.к. его выпилили из арчрепы)
xfce - не менял pra-de-xfce, но перекомпилил xfce-session (убрал зависимость polkit, т.к. свежий  очень раздулся и кстати выпилил его из 070)
Т.е. изменения приходится делать только связанные с изменениями версий пакетов арчрепы. От этого никуда не деться

030-qt5-1806-sf02.pfs выкинул чужие локали
089-de-ols-gtk2-1806-sf01.pfs
089-de-xfce-gtk2-1806-sf02.pfs
Обе ДЕ тестировал очень мало



Оффлайн Pro

  • Модератор
  • Ветеран
  • ****
  • Сообщений: 9800
  • Репутация: +100/-0
Re: PRA-roll 1806. Предварительное тестирование
« Ответ #39 : 01 Июнь 2018, 15:38:13 »
Pro, хватит прикалываться, хотя лето ж наступает, затишье )))
Просто я уже эти стадии прошел и в моем виде вы результат видите: roll я даже не пытаюсь тестировать, ядро компилирую практически закрыв глаза :))

Thunar видимо перекомпилировать забыли под новую версию либы :))
Я загружаю новые пакеты сюда: http://file.puppyrus.org/users/ а дальше можно найти самостоятельно.

Онлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 23160
  • Репутация: +167/-0
    • PuppyRus-A
Re: PRA-roll 1806. Предварительное тестирование
« Ответ #40 : 01 Июнь 2018, 15:50:19 »
Странно, устанавливается libxfce4util.so.7, а ругается на libxfce4util.so.6  ???
Мой косяк. Переделал libxfce4ui-4.10.0-2-x86_64 в libxfce4ui4.10-4.10.0-2-x86_64.pkg.tar.xz.
переделай
sudo pacman -Sy && sudo pacman2pfs thunar libxfce4ui-gtk2

Оффлайн RoDoN

  • Модератор
  • Ветеран
  • ****
  • Сообщений: 5437
  • Репутация: +118/-0
    • RoDoN
Re: PRA-roll 1806. Предварительное тестирование
« Ответ #41 : 01 Июнь 2018, 16:38:29 »
089-de-ols-gtk2-1806-sf01.pfs
089-de-xfce-gtk2-1806-sf02.pfs
Обе ДЕ тестировал очень мало
OLS запустился без проблем, а вот XFCE почему-то не хочет

Acer Aspire One AO751h (Atom Z520, Intel GMA500)
Acer Extensa 5620Z (T7500, Intel 965GM)
PuppyRus-JWM-13.12, PRA, Upup Precise, Tahr Puppy, Runtu 14.04 XFCE.

Онлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 23160
  • Репутация: +167/-0
    • PuppyRus-A
Re: PRA-roll 1806. Предварительное тестирование
« Ответ #42 : 01 Июнь 2018, 16:58:16 »
OLS запустился без проблем, а вот XFCE почему-то не хочет
У меня запускается. Без сохраненки пробовал?

089-de-lxqt-1806-sf01.pfs в зависимостях модули 030-qt и polkit
polkit-0.114-1806-sf01.pfs

Онлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 23160
  • Репутация: +167/-0
    • PuppyRus-A
Re: PRA-roll 1806. Предварительное тестирование
« Ответ #43 : 01 Июнь 2018, 17:15:01 »
modemmanager-1.8rc2-1806-sf02.pfs
networkmanager-gtk2-0.9.8.10-1806-sf01.pfs
Обоим нужен polkit*.pfs
Проверял только на запуск. Кто проверит на связь - отпишитесь на какую
« Последнее редактирование: 01 Июнь 2018, 17:33:12 от sfs »

Оффлайн RoDoN

  • Модератор
  • Ветеран
  • ****
  • Сообщений: 5437
  • Репутация: +118/-0
    • RoDoN
Re: PRA-roll 1806. Предварительное тестирование
« Ответ #44 : 01 Июнь 2018, 17:25:35 »
Без сохраненки пробовал?
Да.
Пишет что-то про невозможность старта multiload-ng, точно прочитать не успеваю, мелькает курсор и опять старт иксов и так по кругу.
Тестирую правда на более старом ядре 4.4.1-pf3, т.к. с ядром 4.15.4 мой ноут зависает при выключении или ребуте. Но с тинт и OLS все нормально грузится и работает.

Acer Aspire One AO751h (Atom Z520, Intel GMA500)
Acer Extensa 5620Z (T7500, Intel 965GM)
PuppyRus-JWM-13.12, PRA, Upup Precise, Tahr Puppy, Runtu 14.04 XFCE.