Сайт | Скачать | Видео | Wiki

Голосование

Нужна ли большая сборка PRA-roll ?

Да. XFCE + LXQT
9 (31%)
Да. XFCE
13 (44.8%)
Да. LXQT
0 (0%)
Да. С другим DE (Mate, KDE ... - пишите в комментарии)
3 (10.3%)
Нет. Достаточно OLS
4 (13.8%)

Проголосовало пользователей: 29

Автор Тема: PRA-roll. x86_64 (64бит). Frugal + Full c автообновлением пакетов  (Прочитано 77028 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 27334
  • Репутация: +186/-0
    • PuppyRus-A
Для фругала - чтобы юзать свежие модули из pfs-portable
glibc-2.30-3-1811-sf01.pfs

Оффлайн krasnyh

  • Ветеран
  • *****
  • Сообщений: 2300
  • Репутация: +78/-1
По поводу vlc и его разную работу в prar-1811-gtk3-01, prar-1811-lx-02. Причина в том, что они используют разный 030-qt5. Один тянет с репы 030-qt5-noicu-5.13.2_64-sf06, другой -  из /optional 030-qt5-1811-sf02.

Если дать vlc в prar-1811-gtk3-01 правильный 030-qt5-1811-sf02, то все ok.
Брать в prar-1811-lx-02.iso  в папке optional. В репах он отсутствует.

030-qt5-1811-sf02.pfs или через sfs-get.
« Последнее редактирование: 25 Ноябрь 2019, 19:30:19 от krasnyh »

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 27334
  • Репутация: +186/-0
    • PuppyRus-A
Выложил 030-qt5-1811-sf02.pfs
030-qt5-noicu-5.13.2_64-sf06 - как и почти все перекомпиленное для LF01 - в Ролл тянуть не надо. Будут проблемы с автообновлением

Оффлайн krasnyh

  • Ветеран
  • *****
  • Сообщений: 2300
  • Репутация: +78/-1
в Ролл тянуть не надо
В смысле тянуть. Пользователь запускает prar-1811-gtk3-01, скачивает vlc через sfs-get. Подтягивается и скачивается зависимость 030-qt5. И то что sfs-get находил и предлагал только 030-qt5-noicu-5.13.2_64 это ведь не является виной юзера? )

Хорошо что наконец исправлено.

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 27334
  • Репутация: +186/-0
    • PuppyRus-A
Да. Но и сейчас в sfs-get  будут вылезать оба qt5
Надо выбирать 1811


Оффлайн krasnyh

  • Ветеран
  • *****
  • Сообщений: 2300
  • Репутация: +78/-1
Раньше base являлся группой пакетов и при установке его можно было редактировать, что-то исключая например. Сейчас же это обычный пакет со своими зависимостями. Это так, для справки. )


Была у меня идея, делать фругал с не замороженной репой, просто при необходимости обновлять базовые модули (папка /base) с pfsrebuild. Но для этого в модулях не должно быть правок, сокращений, и удалений пакетов, либ.
Подобно Magos, только для Arch. Т.е. берем стандартную систему и как есть 'фругалим' ее. Может только разбив ее для удобства по большим модулям.

Такая сборка, конечно, будет стоять особняком по отношению к привычным. И из-за большего размера, и из-за требованиям к производительности железа.
Но это так, мысли вслух. :)

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 27334
  • Репутация: +186/-0
    • PuppyRus-A
Сейчас же это обычный пакет со своими зависимостями
Это метапакет - т.е. пустышка с зависимостями. Т.е. по сути то же самое
Зачем так сделали я не знаю
Вместо выбора пакетов из группы можно pacman -Rsdd

 
фругал с не замороженной репой
Это был первый вариант пра-ролл.
paulus пособирал какое-то время. Больше никого не заинтересовало
prar1811 делался уже под full установку. Там почти ничего не вырезано и добавлено по минимуму.
Причем совсем свое - отдельным опциональным модулем
из-за требованиям к производительности железа.
На простых ДЕ особой разницы не будет
Только смысл? На стационаре удобнее фул с возможностью заморозки. Сквоши и модульность тут только мешают
На флэшке - вряд ли надо самый свежий срез
То что я в соседней теме затеваю - что-то среднее