Сайт | Скачать | Видео | Wiki

Автор Тема: Pulseaudio. Решение проблем со skype, firefox52 и "нет звука"  (Прочитано 4380 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Онлайн Pro

  • Модератор
  • Ветеран
  • ****
  • Сообщений: 9805
  • Репутация: +100/-0
с моим который 1.6git я собрал недавно и выложил.
не могу найти, только apulse-0.1.6-1-i686.pfs с которым фокс не жалуется, но и звук не играет.
http://mirror.yandex.ru/puppyrus/puppyrus-a/pra03/pfs-test/apulse-0.1.6git-pr01.pfs
Я загружаю новые пакеты сюда: http://file.puppyrus.org/users/ а дальше можно найти самостоятельно.

Оффлайн paulus

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 1607
  • Репутация: +23/-0
apulse-0.1.6git-pr01.pfs
Спб, этот работает! :)

Оффлайн paulus

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 1607
  • Репутация: +23/-0
это неправильный путь. по идее start.sh должен
Согласен.  Дайте правильный start.sh :)

Онлайн Pro

  • Модератор
  • Ветеран
  • ****
  • Сообщений: 9805
  • Репутация: +100/-0
Дайте правильный start.sh :)
нету, я только поболтать.
Я загружаю новые пакеты сюда: http://file.puppyrus.org/users/ а дальше можно найти самостоятельно.

Оффлайн paulus

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 1607
  • Репутация: +23/-0
нету
Тогда это будет типа портированный модуль фокса :)

Онлайн Pro

  • Модератор
  • Ветеран
  • ****
  • Сообщений: 9805
  • Репутация: +100/-0
Тогда это будет типа портированный модуль фокса :)
не портированный а составной, хотя если библиотеки положить в каталог firefox, то основной системе они мешать не будут и тогда будет портированный
Я загружаю новые пакеты сюда: http://file.puppyrus.org/users/ а дальше можно найти самостоятельно.

Онлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 23168
  • Репутация: +167/-0
    • PuppyRus-A
арчевые сборки фокса снова хотят пульсу
А с оф.сайта?
Дайте правильный start.sh
Нужен правильный apulse
http://forum.puppyrus.org/index.php?topic=19467.msg132710#msg132710

Онлайн Pro

  • Модератор
  • Ветеран
  • ****
  • Сообщений: 9805
  • Репутация: +100/-0
Нужен правильный apulse
http://forum.puppyrus.org/index.php?topic=19467.msg132710#msg132710
то что там набросано побыстрому, не является содержимым start.sh
Скорей уж ты набросал скрипт запуска для программы, но это не то.
Я загружаю новые пакеты сюда: http://file.puppyrus.org/users/ а дальше можно найти самостоятельно.

Онлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 23168
  • Репутация: +167/-0
    • PuppyRus-A
Чем хуже определить наличие пульсы и при отсутствии подсунуть апульс (который можно и включить, чтобы не заморачиваться с отдельным модулем)?
start.sh и так костыль, а ты еще хочешь в него логические схемы ...

Онлайн Pro

  • Модератор
  • Ветеран
  • ****
  • Сообщений: 9805
  • Репутация: +100/-0
start.sh и так костыль, а ты еще хочешь в него логические схемы ...
вот это номер, я удивлен. Всегда думал что для такого он и делался

Чем хуже определить наличие пульсы и при отсутствии подсунуть апульс
конечно все в руках автора, но в том своем "правильном варианте" ты никак не обозначаешь ГДЕ ЖЕ ТЫ ЭТОТ КОД ПРЕДЛАГАЕШЬ ИСПОЛЬЗОВАТЬ, а мы телепаты слова князя толкуем по разному
Я загружаю новые пакеты сюда: http://file.puppyrus.org/users/ а дальше можно найти самостоятельно.

Онлайн Pro

  • Модератор
  • Ветеран
  • ****
  • Сообщений: 9805
  • Репутация: +100/-0
Что лучше, сделать логику в двух модулях, или в каждом модуле программы которая хочет пульсу, делать костыли для определения наличия пульсы или апульсы (а то и запихивать внутрь apulse, на всякий случай).
вопрос риторический, отвечать ненадо.
Я загружаю новые пакеты сюда: http://file.puppyrus.org/users/ а дальше можно найти самостоятельно.

Онлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 23168
  • Репутация: +167/-0
    • PuppyRus-A
ГДЕ ЖЕ ТЫ ЭТОТ КОД ПРЕДЛАГАЕШЬ ИСПОЛЬЗОВАТЬ
В скрипе apulse и запускать все pulse-приложения apulse приложение (или встраивать эту логику в стартовый скрипт приложения
Так будет максимально универсально

start.sh не надо перегружать: sfs-get-dep и больше не баловаться. Он же еще парсится при старте системы на предмет недостающих зависимостей

Онлайн Pro

  • Модератор
  • Ветеран
  • ****
  • Сообщений: 9805
  • Репутация: +100/-0
запускать все pulse-приложения apulse приложение
это требует дополнительных знаний от того кто делает модуль, совет pacman2pfs толкается везде, но все более неактуален.
Он же еще парсится при старте системы на предмет недостающих зависимостей
это и хорошо, два модуля разом не пройдут
Я загружаю новые пакеты сюда: http://file.puppyrus.org/users/ а дальше можно найти самостоятельно.

Онлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 23168
  • Репутация: +167/-0
    • PuppyRus-A
совет pacman2pfs толкается везде, но все более неактуален.
Почему? Он притащит pulse и все норм
Может поставить пульс в базу? Какие минусы?

Оффлайн paulus

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 1607
  • Репутация: +23/-0
А с оф.сайта?
С оф.сайта и подавно на пульсе. И последняя сборка пакета от мозилловцев с апульсом. Так размер меньше всего получается. И почему это пользователи пульсы будут без звука, если портированные либы внутри и на пульс фокс не должен вестисть? Какой тогда смысл в этих потрированиях?