Сайт | Скачать | Видео | Wiki

Автор Тема: Проблемы с gtk3 >=3.22 themes  (Прочитано 5108 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 27375
  • Репутация: +186/-0
    • PuppyRus-A
Проблемы с gtk3 >=3.22 themes
« : 28 Май 2016, 09:14:09 »
Запарился найти нормальную тему.  Главная проблема на скринах (pra64 ffoxlite46-gtk3)
1 - пустые radio сливаются с фоном. В итоге иногда не понятно что здесь можно что-то выбрать. Greybird (причем в ubuntu - ок)
2 - нашел Breez, CobiBird. Обе не радуют
Подумал, что проблема в нехватки icon - поэкспериментировал с добавлением - нет

Причем со сменой версии gtk3 внешний вид приложений может измениться. Особенно заметно на gtkhash в PRA64
Эксперименты в pra03 показали, что вид тем gtk3 зависит от версии. Нащупал 3 категории
а. до 3.14 Проблема "radio" решается темой gtk3 Mist из ftp://mirror.yandex.ru/puppyrus/puppyrus-a/pra03/pfs/084-theme-humanity-grey_any-sf11.pfs
б. 3.14-3.18 084-theme-humanity-grey_any-sf11.pfs - все ок
с. 3.20 - есть еще проблема с полосой прокрутки (возможно фича).
В итоге пока решил остановиться на б.
Как и чем (кроме текстового редактора) редактировать темы не нашел

Похоже я не одинок
https://www.linux.org.ru/forum/desktop/12588681?lastmod=1463411688950#comment-12589154
https://www.linux.org.ru/forum/desktop/12599351

В идеале бы взять Mist (самый маленький - всего 3 .css) и довести
« Последнее редактирование: 18 Март 2019, 14:40:58 от sfs »

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 27375
  • Репутация: +186/-0
    • PuppyRus-A
Re: Проблемы с gtk3 themes
« Ответ #1 : 21 Июнь 2016, 11:15:42 »
084-theme-adwaita-3.20.2_pb02.pfs, но из-за бага в pra64 ложить в modules (не в base!). На pra32 не тестировал.
Описанная проблема есть. gtkhash - нормально. Полоса прокрутки без ползунка

Оффлайн paulus

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 1639
  • Репутация: +24/-0
Re: Проблемы с gtk3 themes
« Ответ #2 : 22 Июнь 2016, 12:28:25 »
Описанная проблема есть. gtkhash - нормально. Полоса прокрутки без ползунка
Что у вас там есть не знаю и gtkhash не использую, НО все есть и нормально работает (adwaita) и ползунок есть.
« Последнее редактирование: 22 Июнь 2016, 12:33:08 от paulus »

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 27375
  • Репутация: +186/-0
    • PuppyRus-A
Re: Проблемы с gtk3 themes
« Ответ #3 : 22 Июнь 2016, 12:56:23 »
На Вашем скрине точно gtk320? Он должен в ПРА64-07 подгружаться модулем из /optional . По умолчанию gtk318

Оффлайн paulus

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 1639
  • Репутация: +24/-0
Re: Проблемы с gtk3 themes
« Ответ #4 : 22 Июнь 2016, 14:12:20 »
На Вашем скрине точно gtk320?
Сорри, столько раз все менял пока искал проблему с адвайтой и профукал, что удалил gtk3.20. На скрине действительно gtk3.18. Таки да, с gtk3.20 пока есть проблемы с темами. Странно, что гномеры адвайту не подлатали...

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 27375
  • Репутация: +186/-0
    • PuppyRus-A
Re: Проблемы с gtk3 themes
« Ответ #5 : 22 Июнь 2016, 14:18:17 »
Странно, что гномеры адвайту не подлатали...
С прокруткой- возможно не глюк, а фича
С ффоксом - возможно проблемы ффокса
По любому какой-то пользы от gtk320 я не нашел

Оффлайн paulus

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 1639
  • Репутация: +24/-0
gtk3 ffox
« Ответ #6 : 22 Июнь 2016, 18:33:58 »
Gtk3-light-3.8.8-sf02.pfs не достаточно?
Оказалось достаточно, но вырвиглазно на многих темах (ambiance, adwaita). Нормально только "стандартных" для pra Stardust и Raleigh, так что пользоваться можно :)

sfs, может gtk3-3.18, как в pra64, сделаешь? Там все темы вроде бы нормально работают с firefox. Тогда его спокойно можно ставить в исо.

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 27375
  • Репутация: +186/-0
    • PuppyRus-A
Re: gtk3 ffox
« Ответ #7 : 23 Июнь 2016, 09:03:42 »
Нормально только "стандартных" для pra Stardust и Raleig
В этих темах ПРА вообще нет gtk3 тем. Поэтому и вырвиглазно.
может gtk3-3.18, как в pra64, сделаешь?
Что это даст по сравнению с Gtk3-light-3.8.8-sf02.pfs ?

Оффлайн paulus

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 1639
  • Репутация: +24/-0
Re: Проблемы с gtk3 themes
« Ответ #8 : 23 Июнь 2016, 14:25:32 »
Порылся тут сети: https://www.linux.org.ru/forum/desktop/11448502?cid=11448533
firefox не gtk приложение, не стоит на него ориентироваться при выборе тем gtk, хотите сделать firefox «красивым» ставьте темы и юзерстили. Использую темную тему ft deepdark https://addons.mozilla.org/ru/firefox/addon/ft-deepdark/?src=search

Но красивую тему под фф47 так и не нашел, которая бы меняла и фон/шрифт (а то белый на белом и значки жесть, c вашим gtk-3.8.8 и моим амбиансе).


Оффлайн paulus

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 1639
  • Репутация: +24/-0
Re: gtk3 ffox
« Ответ #9 : 23 Июнь 2016, 15:07:31 »
В этих темах ПРА вообще нет gtk3 тем. Поэтому и вырвиглазно.
Ты не понял, наоборот с ними нормально и gtk3.8.8, а с gtk3 темами ff жутко выглдядит со стандартной темой.
Вот никак не получается фф47 запустить с темой отличной от установленной по умолчанию:
Код
для gtk2
bash -c "GTK2_RC_FILES=/usr/share/themes/Stardust/gtk-2.0/gtkrc firefox"
или gtk3:
GTK_THEME=Adwaita:light firefox
Кто знает как это победить? А насчет gtk3.18 и далее, думал будет с оформлением получше. Ведь на pra64 c этим нормально у фф.

скрин амбиансе+дефолт фф+gtk3.8.8
На форумах советуют искать темы фокса, но влияющих на все пару и очень темные. Подходящих не нашел.

Если stsrdust системный, то фокс выглядит нормально. Как оставить тему амбиансе, а фокс запустить со startdust?

Что это даст по сравнению с Gtk3-light-3.8.8-sf02.pfs?
ff должен работать на 3.18 и выше, что бы все было как в нормальных дистрибутивах. К черту старые обрубки, на которых нормально не работает. И как следствие надо обновить пакеты mesa и т.д.  В пра64 с фф проблем нет, вот и на пра32 не должно быть... Вот что должно дать. Зачем такие вопросы вообще задавать?
« Последнее редактирование: 24 Июнь 2016, 07:10:31 от paulus »

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 27375
  • Репутация: +186/-0
    • PuppyRus-A
Re: Проблемы с gtk3 themes
« Ответ #10 : 24 Июнь 2016, 11:56:43 »
firefox не gtk приложение, не стоит на него ориентироваться при выборе тем gtk, хотите сделать firefox «красивым» ставьте темы и юзерстили. Использую темную тему ft deepdark https://addons.mozilla.org/ru/firefox/addon/ft-deepdark/?src=search
Да. это помогает с gtk3.8. Хорошей темы тоже не нашел
В итоге скомпилил ftp://mirror.yandex.ru/puppyrus/puppyrus-a/pra03/pfs/Gtk3-light-3.14.9-sf02.pfs . Похоже он совместим с 3.18 по темам. Подробнее - см. 2й обзац шапки. Чтобы скомпилить свежее надо обновить glib2 pango - стремно (тогда уж срез репы обновлять)
Предлагаю остановиться в ПРА на Gtk3-light-3.14.9-sf02.pfs

Оффлайн paulus

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 1639
  • Репутация: +24/-0
Re: Проблемы с gtk3 themes
« Ответ #11 : 25 Июнь 2016, 13:51:00 »
084-theme-humanity-grey_any-sf11.pfs надо переделывать, чтобы он нормально заработал с верхним меню jwm (нет иконок) :(
[/quote]
тогда уж срез репы обновлять
пора бы уж и обновить. imho
« Последнее редактирование: 25 Июнь 2016, 13:53:27 от paulus »

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 27375
  • Репутация: +186/-0
    • PuppyRus-A
Re: Проблемы с gtk3 themes
« Ответ #12 : 27 Июнь 2016, 09:19:11 »
084-theme-humanity-grey_any-sf11.pfs надо переделывать, чтобы он нормально заработал с верхним меню jwm (нет иконок)
Затачивал под middle\light. Готов доделывать под xfсe. Поддержку jwm ни в каком виде не планирую. Собирайте поклонников jwm - доводите модули - выпустим jwm-iso
пора бы уж и обновить. imho
Не уверен. По опыту PRA64 свежий софт сильно раздувает размер и мало добавляет функционала.

Оффлайн paulus

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 1639
  • Репутация: +24/-0
Re: Проблемы с gtk3 themes
« Ответ #13 : 28 Июнь 2016, 19:17:30 »
Поддержку jwm ни в каком виде не планирую. Собирайте поклонников jwm - доводите модули - выпустим jwm-iso
Сменим обои и тоже сделаем iso ;) Если модули тем будут только в таком виде, легче в модуле jwm изменить пути к иконкам или использовать свой модуль тем. Зачем плодить кучу iso? Кому оно надо перелапачивать все  ваши модули и выкидывать из них вашу поддержку не нужных DE/WM и остального? ;)

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 27375
  • Репутация: +186/-0
    • PuppyRus-A
Re: Проблемы с gtk3 themes
« Ответ #14 : 29 Июнь 2016, 09:35:26 »
поддержку не нужных DE/WM
Кроме Вас никто не вспоминает про jwm. Насчет "не нужных DE" - все молчат - делаю вывод : значит "как есть" всех устраивает