Сайт | Скачать | Видео | Wiki

Автор Тема: Проблемы с gtk3 >=3.22 themes  (Прочитано 4996 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн paulus

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 1639
  • Репутация: +24/-0
Re: Проблемы с gtk3 themes
« Ответ #15 : 05 Июль 2016, 18:30:27 »
Кроме Вас никто не вспоминает про jwm.
Громко сказано, есть еще пару человек ;)

К слову, с gtk3.14.9 firefox не может менять тему отличную от стандартной, на 3.18 работает:
Код
GTK_THEME=Adwaita:dark firefox

Онлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 27120
  • Репутация: +184/-0
    • PuppyRus-A
Re: Проблемы с gtk3 themes
« Ответ #16 : 06 Июль 2016, 09:07:23 »
есть еще пару человек
Ну так объедините усилия  ;)
с gtk3.14.9 firefox не может менять тему отличную от стандартной
314 перекомпилен с урезанием всего. Возможно в этом проблема.
вообще с gtk3 и темами - тема еще та :(

Онлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 27120
  • Репутация: +184/-0
    • PuppyRus-A
Re: Проблемы с gtk3 themes
« Ответ #17 : 30 Август 2016, 14:29:39 »
Темы под gtk3.20 начинают появляться. Собрал в http://mirror.yandex.ru/puppyrus/puppyrus-a64/pfs-portable-test/085-theme-gtk320-olive_any-sf01.pfs . В основном из archbang
Положить в pra6407 в /base  вместе с
http://mirror.yandex.ru/puppyrus/puppyrus-a64/pfs-portable/084-theme-humanity-grey_any-sf11.pfs
и http://mirror.yandex.ru/puppyrus/puppyrus-a64/pra64-07/pfs/gtk3-3.20.6-1-x86_64.pfs
Если других предложений не будет - ставлю в 1608light в таком виде
В pra03 c gtk3.14 эти темы косячат

Онлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 27120
  • Репутация: +184/-0
    • PuppyRus-A
Re: Проблемы с gtk3 themes
« Ответ #18 : 16 Сентябрь 2016, 11:27:24 »
http://mirror.yandex.ru/puppyrus/puppyrus-a64/pfs-portable-test/085-theme-gtk320-olive_any-sf02.pfs
В transmission градусник белое на белом - заменил гтк тему на menta

Оффлайн pureproft

  • Постоялец
  • ***
  • Сообщений: 164
  • Репутация: +4/-1
Re: LF. DebianDogRetro Rus (DDR01) Stretch LXDE gtk2 qt4 i686
« Ответ #19 : 18 Март 2019, 13:51:38 »
...........
Таким образом в ДД в отличии от пра03 gtk3 свежий и проблем с ним нет

sfs, есть понимание в области тем оформления gtk2/3 ?
Например в Runtu 18.04 minwaita а в свежей rosa lxqt обнаружилась не менее удачная rosa-elementary.
Мои не очень настойчивые попытки перенести minwaita даже на runtu 16.04 не увенчались успехом.
Если в DDR появится тема также согласованная между 2 и 3, один счастливый пользователь точно появится.
minwaita в Runtu например(в rosa lxqt rosa-elementary аналогично)

Во многих других темах gtk3 кнопки и надписи на них разбегаются в не предсказуемых направлениях.
« Последнее редактирование: 18 Март 2019, 14:08:47 от pureproft »
f RU gal OS читаю между букв...

Онлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 27120
  • Репутация: +184/-0
    • PuppyRus-A
Re: Re: LF. DebianDogRetro Rus (DDR01) Stretch LXDE gtk2 qt4 i686
« Ответ #20 : 18 Март 2019, 14:05:15 »
есть понимание в области тем оформления gtk2/3 ?
Для gtk>=3.22 нужны темы именно под него. Более старые gtk3 могут давать различные чудеса
Для qt5 больше возможностей (подогнать под внешний вид gtk) по интерактивной настройке дает qt5ct
В свежих темах 084 у меня так и сделано

На Вашем скрине что-то не так? Я плохого не заметил....

Оффлайн pureproft

  • Постоялец
  • ***
  • Сообщений: 164
  • Репутация: +4/-1
Re: Re: LF. DebianDogRetro Rus (DDR01) Stretch LXDE gtk2 qt4 i686
« Ответ #21 : 18 Март 2019, 14:13:56 »
На скрине как раз всё так. Это пример из purebasic 5.70 где не меняя ни строчки кода, а только указывая компилятору что использовать gtk2/gtk3/qt получаешь соответствующий бинарник, но с gtk3 редко на какой теме так всё удачно. На minwaita и проверенной мной rosa-elementary(я именно про gtk3 тему) всё так, как на скрине.

p.s. qt5 в случае DDR01 не важно, просто за компанию на скрин попало.
Например в этом плане умолчальные темы в runtu lite 14.04 были тоже удачными :)
« Последнее редактирование: 18 Март 2019, 14:25:56 от pureproft »
f RU gal OS читаю между букв...

Онлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 27120
  • Репутация: +184/-0
    • PuppyRus-A
Re: Проблемы с gtk3 >=3.22 themes
« Ответ #22 : 18 Март 2019, 14:41:59 »
с gtk3 редко на какой теме так всё удачно
Перенес обсуждение
Для gtk>=3.22 нужны темы именно под него. Более старые gtk3 могут давать различные чудеса
« Последнее редактирование: 18 Март 2019, 14:44:41 от sfs »

Оффлайн pureproft

  • Постоялец
  • ***
  • Сообщений: 164
  • Репутация: +4/-1
Re: Проблемы с gtk3 >=3.22 themes
« Ответ #23 : 18 Март 2019, 14:52:16 »
Это замечательно, что перенесли...
Но мой вопрос, более конкретно: как в DDR01 сделать оформление, аналогичное runtu 18.04 т.е. перенести тему minwaita?
В данную минуту нет под руками DDR01, но прошлые попытки с другими дистрибутивами простым переносом папки с темой нужного эффекта не давали.
« Последнее редактирование: 18 Март 2019, 15:01:49 от pureproft »
f RU gal OS читаю между букв...

Онлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 27120
  • Репутация: +184/-0
    • PuppyRus-A
Re: Проблемы с gtk3 >=3.22 themes
« Ответ #24 : 18 Март 2019, 15:00:24 »
как в DDR01 сделать оформление, как runtu 18.04 т.е. перенести тему minwaita?
Если эта тема не рассчитана на gtk3.22 - или править тему под него или опускать версию gtk3
Судя по https://github.com/godlyranchdressing/Minwaita/commit/83746967fe3ed95eb1866305a30794fc70533b7d - проблемы быть не должно (если у Вас minwaita свежая)
попытки с другими дистрибутивами простым переносом папки с темой нужного эффекта не давали.
Для переноса темы gtk в любом дистре достаточно скопировать ее в /usr/share/themes и иногда нужна либа gtk-engine-*
« Последнее редактирование: 18 Март 2019, 15:04:02 от sfs »

Оффлайн pureproft

  • Постоялец
  • ***
  • Сообщений: 164
  • Репутация: +4/-1
Re: Проблемы с gtk3 >=3.22 themes
« Ответ #25 : 18 Март 2019, 16:27:18 »
Для переноса темы gtk в любом дистре достаточно скопировать ее в /usr/share/themes и иногда нужна либа gtk-engine-*
Пока по прежнему не приступал к DDR01, но проверил на том что под руками, а именно ещё раз по пытался перенести minwaita из runtu 18.04 в runtu 16.04 xfce и на первый взгляд всё замечательно, всё есть, но ломается в gtk3 app меню, панели кнопок, обрамление кнопок и т.д. и т.п. Хотя при этом место положение кнопок и надписей аналогично gtk2. т.е. всё есть но всётаки чего то не хватает )))
Поэтому первое что я спросил:
Цитата: pureproft от Сегодня в 17:51:38
sfs,  есть понимание в области тем оформления gtk2/3 ?
О том, что в общем случае достаточно я знаю, я о том, что делать, если окажется не достаточно кто то знает? )

p.s. если удастся разобраться, будет чем поделится полезным не только мне.
« Последнее редактирование: 18 Март 2019, 16:33:10 от pureproft »
f RU gal OS читаю между букв...

Онлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 27120
  • Репутация: +184/-0
    • PuppyRus-A
Re: Проблемы с gtk3 >=3.22 themes
« Ответ #26 : 18 Март 2019, 17:34:57 »
puppyrus-a64/pra64-07/pkg/art-aur/gtk-theme-minwaita-1.6-3-any.pkg.tar.xz