Сайт | Скачать | Видео | Wiki

Автор Тема: chromium, chrome  (Прочитано 10771 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн I-Jurij

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 516
  • Репутация: +16/-0
« Последнее редактирование: 31 Октябрь 2017, 10:54:49 от sfs »

Оффлайн paulus

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 1616
  • Репутация: +23/-0
chromium
« Ответ #1 : 07 Март 2016, 14:35:55 »
Леплю тут chromium 32bit.... Хотелось бы без перла в pfs, но надо как-то на bash слепить /usr/bin/chromium Хотя может проблема и не в нем.

У меня пока так:
#!/bin/sh
export LD_LIBRARY_PATH="/opt/ffmpeg/lib"
exec /usr/lib/chromium/chromium --ppapi-flash-path=/usr/lib/chromium/PepperFlash/libpepflashplayer.so --ppapi-flash-version=20.0.0.306

но вылазит проблема, не знаю как убрать:
live@pra:~$ chromium
/usr/lib/chromium/chromium: /usr/lib/libdbus-1.so.3: no version information available (required by /usr/lib/chromium/chromium)
/usr/lib/chromium/chromium: /usr/lib/libpci.so.3: version `LIBPCI_3.4' not found (required by /usr/lib/chromium/chromium)
/usr/lib/chromium/chromium: /usr/lib/libdbus-1.so.3: no version information available (required by /usr/lib/libpulse.so.0)
/usr/lib/chromium/chromium: /usr/lib/libdbus-1.so.3: no version information available (required by /usr/lib/pulseaudio/libpulsecommon-8.0.so)
/usr/lib/chromium/chromium: /usr/lib/libdbus-1.so.3: no version information available (required by /usr/lib/libavahi-client.so.3)
« Последнее редактирование: 08 Март 2016, 16:49:26 от paulus »

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 23740
  • Репутация: +173/-0
    • PuppyRus-A
Re: chromium
« Ответ #2 : 07 Март 2016, 15:33:51 »
У нас же был рабочий модуль - посмотрите и сделайте по аналогии

Оффлайн Pro

  • Модератор
  • Ветеран
  • ****
  • Сообщений: 10014
  • Репутация: +103/-0
Re: chromium
« Ответ #3 : 07 Март 2016, 15:46:56 »
LIBPCI_3.4 хочет. имеющаяся видимо или новее или старее, а этот хочет именно 3.4
все остальное не смертельно.
Я загружаю новые пакеты сюда: http://file.puppyrus.org/users/ а дальше можно найти самостоятельно.

Оффлайн paulus

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 1616
  • Репутация: +23/-0
Re: chromium
« Ответ #4 : 07 Март 2016, 16:05:09 »
LIBPCI_3.4 хочет. все остальное не смертельно.
Спасибо за подсказку, все заработало и без перла :)

сделайте по аналогии
по аналогии с перлом в pfs.

p.s. Что-то большой пакет получается. Его там нельзя замутить без кучи лишней зависимости (pulse, avahi)? 
« Последнее редактирование: 07 Март 2016, 20:53:46 от paulus »

Оффлайн paulus

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 1616
  • Репутация: +23/-0
Re: Re: Модули.pfs от пользователей
« Ответ #5 : 07 Март 2016, 16:16:25 »
chromium-49.0.2623.75_pb01.pfs

I-Jurij, если будешь делать модуль для pra64, то можно и нужно обойтись без перла в pfs. imho
« Последнее редактирование: 07 Март 2016, 16:25:00 от paulus »

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 23740
  • Репутация: +173/-0
    • PuppyRus-A
Re: [Решено] chromium
« Ответ #6 : 08 Март 2016, 13:32:38 »
p.s. Что-то большой пакет получается. Его там нельзя замутить без кучи лишней зависимости (pulse, avahi)? 
Да. Это потому что Вы из арчрепы брали. Вот максимально подрезал http://file.puppyrus.ml/users/pra64/pfs-portable/chromium-p-2623.75_64-sf02.pfs и портировал
Вот без кучи зависимостей https://storage.googleapis.com/chromium-browser-snapshots/index.html?prefix=Linux/262375/
Или http://pkgs.org/slackware-14.1/alienbob-i486/chromium-49.0.2623.75-i486-1alien.txz.html
http://pkgs.org/slackware-14.1/alienbob-i486/chromium-pepperflash-plugin-20.0.0.306-i386-1alien.txz.html
В PRA64- у меня обе альтернативы не запустились

64 нет смысла заморачиваться - юзать google
32 - может лучше в сторону iron смотреть... Будет ли дальше откуда брать свежий 32 бит pepperflash...
« Последнее редактирование: 08 Март 2016, 13:38:53 от sfs »

Оффлайн paulus

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 1616
  • Репутация: +23/-0
Re: [Решено] chromium
« Ответ #7 : 08 Март 2016, 16:47:50 »
В PRA64- у меня обе альтернативы не запустились
Ему там зачем-то 32битные либы нужны - слишком много геморра :(
Зависимость на libltdl можно убрать? Подрезанный и портированный лучше 32битный сделать.
Цитировать
64 нет смысла заморачиваться - юзать google
Возможно, но зачем подсаживать на проприетарную поделку, очередную сборочку хромиума? :) Конечно Хром легче опакечивать и распиаренный :)
Цитировать
32 - может лучше в сторону iron смотреть... Будет ли дальше откуда брать свежий 32 бит pepperflash...
Лучше на прародителе сидеть (chromium, firefox) чем бегать по разным сборочкам, которые завтра могут загнуться?! Типа всяких палемунов, айронов и т.д. Для любых хромоногих PPAPI свежего под 32бита больше не будет, его же из хрома выдергивали.

Оффлайн paulus

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 1616
  • Репутация: +23/-0
Re: Re: Модули.pfs от пользователей
« Ответ #8 : 08 Март 2016, 17:02:41 »
chromium-49.0.2623.75_64-ij01.pfs Перла нет.
Отлично, но зечем:  .BUILDINFO, .INSTALL, .MTREE, .PKGINFO? :)

Оффлайн paulus

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 1616
  • Репутация: +23/-0
Re: chromium
« Ответ #9 : 08 Март 2016, 19:16:27 »
sfs, достаешь ты иногда своей модерацией форума, то темы переносишь (потом не знаешь где искать написанное), то гугло хром залепил в тему о хромиуме (он тут не нужен, да еще и шапкой его сделал).
p.s. Разве что тему сделать Chromium/Chrome и все вопросы по ним тут обсуждать...

Оффлайн I-Jurij

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 516
  • Репутация: +16/-0
Re: Re: Модули.pfs от пользователей
« Ответ #10 : 08 Март 2016, 19:47:18 »
chromium-49.0.2623.75_64-ij01.pfs Перла нет.
Отлично, но зечем:  .BUILDINFO, .INSTALL, .MTREE, .PKGINFO? :)
Упс. Скрытые не проверял, остальное вроде все чистил. Хлам внутри chromium нужен для подключения без зависимостей.
Хотя, честно говоря, мне религия (и KISS тоже) не запрещает google-chrome или yandex-browser, которые из чужих пакетов легче перепаковать для PRA, чем арчевский хромиум.
На 32-ке - мой выбор палемун (загнется, поищем еще что), ввиду слабого железа.

Вывод:
64-ка - ковыряться в хромиуме, в результате не имея никаких плюсов, какой смысл?
32-ка - в гейм хромиум может и нужен, потому что альтернатив (с нормальной поддержкой нового флеша) нет.

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 23740
  • Репутация: +173/-0
    • PuppyRus-A
Re: chromium
« Ответ #11 : 08 Март 2016, 20:04:19 »
Шапку поправил
С выводами  I-Jurij согласен. Только удастся ли где тырить pepper-flash 32

Оффлайн paulus

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 1616
  • Репутация: +23/-0
Re: Re: Модули.pfs от пользователей
« Ответ #12 : 08 Март 2016, 20:58:12 »
На 32-ке - мой выбор палемун (загнется, поищем еще что).
Потыкал я его, ffmpeg для h.264 не поддерживает и не будет, расширений почти не найдешь :(
С остальным, насчет браузеров, согласен.

Оффлайн I-Jurij

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 516
  • Репутация: +16/-0
Re: Re: Модули.pfs от пользователей
« Ответ #13 : 08 Март 2016, 23:31:13 »
На 32-ке - мой выбор палемун (загнется, поищем еще что).
Потыкал я его, ffmpeg для h.264 не поддерживает и не будет, расширений почти не найдешь :(
С остальным, насчет браузеров, согласен.
Даже без вышеперечисленного это лучше, чем дилло, нетсерф или опера12.16.
Для сравнения со старта с одной пустой открытой вкладкой:
хром (хромиум) - ~160 Мб
файрфокс - 140Мб
палемун - 90Мб
опера12 - 60 Мб
Рекламу блокирую через хостс, звук в аштмль5 через джистример0.10-ффмпег + носкрипт для полного счастья, все (фильмы онлайн не смотрю - жаль проц, качаю на жесткий).
« Последнее редактирование: 08 Март 2016, 23:48:27 от I-Jurij »

Оффлайн Roader

  • Ветеран
  • *****
  • Сообщений: 523
  • Репутация: +18/-0
Re: chromium
« Ответ #14 : 09 Март 2016, 09:59:39 »
Только удастся ли где тырить pepper-flash 32
По крайней мере в портабельной сборке slimjet (сейчас подсел на него) всегда в наличии :)