Сайт | Скачать | Видео | Wiki

Автор Тема: Как правильно установить драйвер NVIDIA без интернета  (Прочитано 8189 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн gri102

  • Пользователь
  • **
  • Сообщений: 35
  • Репутация: +0/-0
Добрый день!

система precise-5.7.1-retro-ru
видеоадаптер NVIDIA GeForce FX 5500
компьютер не имеет интернета.
скачнул на флешку NVIDIA-Linux-x86-325.15.run
как его установить с флешки?
это же не .pet или .sfs

Онлайн Pro

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 8513
  • Репутация: +92/-0
качни конкретно пакет для этой системы в формате pet или sfs
искать на murga-linux наверное.

или используйте скрипт getnvidia (на murga-linux есть) который сам сделает вам sfs с драйвером. (потребуется devx и исходники ядра)
Я загружаю новые пакеты сюда: http://file.puppyrus.ml/users/ а дальше можно найти самостоятельно.

Оффлайн RoDoN

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 4631
  • Репутация: +95/-0
    • RoDoN
Eсли активен драйвер nouveau, то его нужно отключить и возможно придется перезагрузиться, поэтому должна быть сохраненка, потом подключаем devx*.sfs, kernel_sources*.sfs и запускаем в консоли скачанный ранее *.run, отвечаем на вопросы и если все ok, то запускаем иксы и радуемся.

Подобный вопрос поднимается пе в первый раз, вот нашел инструкцию установки драйверов из .run.

Для вашей карточки скорее всего нужны дрова NVIDIA-Linux-x86-173.14.*.run.
« Последнее редактирование: 03 Март 2014, 08:38:07 от RoDoN »

Acer Aspire One AO751h (Atom Z520, Intel GMA500)
Acer Extensa 5620Z (T7500, Intel 965GM)
PuppyRus-JWM-13.12, PRA, Upup Precise, Tahr Puppy.

Оффлайн gri102

  • Пользователь
  • **
  • Сообщений: 35
  • Репутация: +0/-0
через xorgwizard сейчас задействован NV простой драйвер NVIDIA
Все работает вроде-бы без видимых проблем.
Просто из любопытства посмотреть как это все будет с нормальным драйвером.

цитата из Вашей инструкции:
1. Нужно удалить модуль ядра nouveau (если он собран) из основного sfs переупаковав его

сплошные вопросы.
 Как удалить модуль ядра из основного sfs?
как переупаковать его.
Может быть наивные вопросы, но это вопросы от новичка в linux

перед этим по очереди устанавливал Это  пытаясь самостоятельно решить вопрос
nvidia-glx-304.43-k3.2.29.sfs
nvidia_legacy-304.88-3.4.52-4g.pet
nvidia_latest-304.64-3.2.33-4g.pet
nvidia_legacy-173.14.36-3.4.17-PAE
Как я и ожидал к успеху это не привело

все время выскакивает сообщение:
нет какого-то модуля в ядре cernel 3.2.48


Оффлайн RoDoN

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 4631
  • Репутация: +95/-0
    • RoDoN
nvidia-glx-304.43-k3.2.29.sfs
nvidia_legacy-304.88-3.4.52-4g.pet
nvidia_latest-304.64-3.2.33-4g.pet
nvidia_legacy-173.14.36-3.4.17-PAE
Эти все дрова сделаны под конкретные ядра. Разве здесь есть 3.2.48? Нет, поэтому и не пошло. И еще версии дров 304.* для современных видеокарт и не поддерживают GF FX5500, я уже писал, что для нее нужно 173.14.*

Удалять или отключать драйвер nouveau нужно, если система работает на нем. Если работает на nv, то идем в консоль и запускаем NVIDIA-Linux-x86-173.14.38.run, предварительно подключив devx*.sfs, kernel_sources*.sfs.
« Последнее редактирование: 03 Март 2014, 09:58:12 от RoDoN »

Acer Aspire One AO751h (Atom Z520, Intel GMA500)
Acer Extensa 5620Z (T7500, Intel 965GM)
PuppyRus-JWM-13.12, PRA, Upup Precise, Tahr Puppy.

Оффлайн gri102

  • Пользователь
  • **
  • Сообщений: 35
  • Репутация: +0/-0

вот здесь Index of /puppylinux/pet_packages-precise/
есть
kernel_src-3.2.29-patched.sfs
kernel_src-3.2.30-nopae-patched.sfs
kernel_src-3.2.44-patched.sfs

какой из них поставить?

Оффлайн KOT

  • Пользователь
  • **
  • Сообщений: 62
  • Репутация: +2/-0
Вам же выше сказали: "Разве здесь есть 3.2.48? Нет"
У вас какое ядро? Под него и надо искать исходники.

Оффлайн shelezyaka

  • Ветеран
  • *****
  • Сообщений: 695
  • Репутация: +39/-0
http://distro.ibiblio.org/quirky/pet_packages-precise/nvidia-173.14.37-k3.2.44-precise.pet
Вот готовый пакет лежащий в репе пресайза,искать как всегда лень,проще огород городить.
Intel Core 2 E7600 ,GeForce 630   ,  3Gb DDR2 , 2 HDD - 160+80 gB

Оффлайн gri102

  • Пользователь
  • **
  • Сообщений: 35
  • Репутация: +0/-0
как  я понял есть два пути установки драйвера

- через .pet пакет. Ядро у меня Kernel 3.2.48. В ссылке , которая приведена выше речь идет о ядре  3.2.44
   Наверное скорее всего этот пакет не подойдет .... или подойдет???....

-проприетарный драйвер NVIDIA-Linux-x86-173.14.39-pkg1
  для этого (как указано выше) нужно установить пакет devx.... sfs и kernel_sources*.sfs
  вот это самое kernel_sources*.sfs ЧТО ЭТО ?!

Оффлайн gri102

  • Пользователь
  • **
  • Сообщений: 35
  • Репутация: +0/-0
по поиску для ядра 3.2.48 ничего нет

Оффлайн RoDoN

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 4631
  • Репутация: +95/-0
    • RoDoN
« Последнее редактирование: 04 Март 2014, 10:19:53 от RoDoN »

Acer Aspire One AO751h (Atom Z520, Intel GMA500)
Acer Extensa 5620Z (T7500, Intel 965GM)
PuppyRus-JWM-13.12, PRA, Upup Precise, Tahr Puppy.

Оффлайн gri102

  • Пользователь
  • **
  • Сообщений: 35
  • Репутация: +0/-0
Цитировать
Удалять или отключать драйвер nouveau нужно, если система работает на нем. Если работает на nv, то идем в консоль и запускаем NVIDIA-Linux-x86-173.14.38.run, предварительно подключив devx*.sfs, kernel_sources*.sfs.

Спасибо за ссылку!

Подключил devx*.sfs, kernel_sources*.sfs.

открываю консоль, далее трудности с командной строкой

набираю: gcc... тут наверное какие-то ключи или опции компилера GCC... входной файл Linux-x86-173.14.38.run   

Где почитать про систему команд, которая используется в данном случае ?

Онлайн Pro

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 8513
  • Репутация: +92/-0
в данном случае просто запустить этот run файл
Я загружаю новые пакеты сюда: http://file.puppyrus.ml/users/ а дальше можно найти самостоятельно.

Оффлайн gri102

  • Пользователь
  • **
  • Сообщений: 35
  • Репутация: +0/-0
Набираю в командной строке:
# root/Linux-x86-173.14.38.run
в ответ:
#bash......................нет такой команды

Онлайн Pro

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 8513
  • Репутация: +92/-0
cd /root
./Linux-x86-143.14.38.run
Я загружаю новые пакеты сюда: http://file.puppyrus.ml/users/ а дальше можно найти самостоятельно.