Сайт | Скачать | Видео | Wiki

Автор Тема: Русская версия Precise-5.7.1.  (Прочитано 130476 раз)

0 Пользователей и 2 Гостей просматривают эту тему.

Оффлайн rodin.s

  • Почетный участник
  • Ветеран
  • *
  • Сообщений: 1179
  • Репутация: +96/-0
Русская версия Precise-5.7.1.
« : 24 Сентябрь 2013, 11:45:16 »
С большим опозданием сделал русскую версию Precise-5.7.1-retro. Никак не мог выбрать время. Есть ещё обычная не ретро версия, которую также планирую сделать немного позже. Пока, что это последние версии от Барри Каулера и пока не совсем понятно, будет ли он дальше выпускать какие-нибудь версии Puppy.
Русская версия Precise-5.7.1-retro имеет размер 205 Mб, в основном потому, что в главном sfs-файле используется сжатие gz, что больше подходит для старых компьютеров. В сборку входит много драйверов для аналоговых модемов, как в Wary. Также используются два браузера: Seamonkey и Opera. Seamonkey более тяжелый и при ОЗУ 256Мб и меньше рекомендуется использовать Opera. Хотя сейчас пишу на ПК c 256 Мб ОЗУ в Seamonkey и все нормально.
В менеджере логинов и безопасности в меню Система можно переключить браузеры на запуск от обычного пользователя Spot. Также я перевёл справку, которая объясняет использование root и spot в Puppy.
Ядро 3.2.48 без PAE с поддержкой новой файловой системы для флешек f2fs.

Образ размером 205 Мб не удалось загрузить на GoogleCode, поэтому использовал GoogleDisk. Поэтому ссылка будет немного странной.

Ссылка изменена Sourceforge.

precise-5.7.1-retro-ru.iso

md5sum: 523db7235c5389316aaedb5d1333c851

На GoogleCode выложил русскую модерн-версию Precise-5.7.1. Ядро 3.9.11 с PAE, сжатие главного iso - xz, размер iso - 156Мб. По сравнению с ретро версией убраны дополнительные драйвера для аналоговых модемов и используется один браузер - Seamonkey.
Также я добавил "мой правый клик" для распаковки и создания pet, sfs и архивов по совету valentin, несколько переведённых скриптов от vkvkvk и программу GTK-Youtube-Viewer. Хотя эта программа не переведена, она мне кажется очень полезной: работает быстрее flash-плеера и браузер не нужен, я, вообще, использую консольную версию, которая вызывается, как youtube-viewer, так работает ещё быстрее. Эта программа добавляет в Puppy важные дополнительные возможности и не занимает много места.

precise-5.7.1-ru.iso  

md5sum: 0e86cd1cf0e6df3046e690583b3f8c92

« Последнее редактирование: 06 Февраль 2014, 20:57:50 от rodin.s »

Оффлайн rodin.s

  • Почетный участник
  • Ветеран
  • *
  • Сообщений: 1179
  • Репутация: +96/-0
Re:Русская версия Precise-5.7.1-retro
« Ответ #1 : 24 Сентябрь 2013, 11:50:18 »
Второе сообщение использую для дополнительной информации.
В русскую версию были добавлены следующие пакеты:
Цитировать
langpack_ru-20130901|Russian language-pack for Puppy Linux, for any Puppy built from Woof later than Feb. 14, 2012
seamonkey-ru-2.19|langpack-ru for Seamonkey-2.19
i18n_robwoj44-130602|i18n scripts from robwoj44
hardinfo-0.5.2pre-i486|System Profiler and Benchmark
fbxkb-i18n-woof-1.2|Индикатор переключения раскладок
pmusic_tray-0.1|i18n-pmusic_tray
console_kb-i18n-woof-ru-1.1|Переключение раскладки в консоли
PuppyPin_precise-1.2|иконки рабочего стола для Presise-5.7.1 retro
xinitrc_test_ru-0.1|xinitrc_test with gxmessage
i18n_precise571-130922|additional i18n for Precise-5.7.1
OpenWithTranslate-0.1|OpenWith translate ru

В модерн-версию Precise-5.7.1 были установлены следующие пакеты:
Цитировать
langpack_ru-20131006|Russian language-pack for Puppy Linux, for any Puppy built from Woof later than Feb. 14, 2012
seamonkey-ru-2.19|langpack-ru for Seamonkey-2.19
i18n_robwoj44-130602|i18n scripts from robwoj44
hardinfo-0.5.2pre-i486|System Profiler and Benchmark
fbxkb-i18n-woof-1.2|Индикатор переключения раскладок
pmusic_tray-0.1|i18n-pmusic_tray
console_kb-i18n-woof-ru-1.1|Переключение раскладки в консоли
PuppyPin_wary-1.0|PuppyPin для Wary
xinitrc_test_ru-0.1|xinitrc_test with gxmessage
i18n_precise571-130922|additional i18n for Precise-5.7.1
OpenWithTranslate-0.2|OpenWith translate ru
l10n_vkvkvk-131006|переведённые скрипты от vkvkvk
myRightClick-0.4|my right click for Puppy
xarchive-0.2.8-6-i18n-i486|Create, modify and browse an archive
gtk_youtube_viewer-3.0.2_precise|A Gtk2 application to search and play Youtube videos with MPlayer.
« Последнее редактирование: 21 Октябрь 2013, 19:37:52 от rodin.s »

Оффлайн sfs

  • Администратор
  • Ветеран
  • *****
  • Сообщений: 17779
  • Репутация: +137/-0
    • PuppyRus-A
Re:Русская версия Precise-5.7.1-retro
« Ответ #2 : 24 Сентябрь 2013, 15:48:48 »
В скрипте iconfinder забыт gettext у "Create new list" (что на кнопке)

Оффлайн rodin.s

  • Почетный участник
  • Ветеран
  • *
  • Сообщений: 1179
  • Репутация: +96/-0
Re:Русская версия Precise-5.7.1-retro
« Ответ #3 : 24 Сентябрь 2013, 19:42:37 »
Спасибо за информацию. Также видел несколько мест, где нет gettext, но пока, что не исправлял чужих ошибок и оставил скрипты из Woof без изменений.

Оффлайн imago31

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 2823
  • Репутация: +41/-0
  • горний арол
Re:Русская версия Precise-5.7.1-retro
« Ответ #4 : 24 Сентябрь 2013, 20:10:59 »
как я понял 01mikco сделал полную установвку на флешку и спользуя файловую систему f2fs, но у него не зараоботали точпад и клава, вроде как из за того что /proc не переместился в основную фс, и для загрузчика нужно использовать не имя устройсва, а UUID
Врач спасает человека, ветеринар - человечество
 все эксперименты на dual core 2x2.6 GHz /ram-2Gb  /ati hd 4670/ 3 флешки frugal multiboot with zoopark:
  основные(pr):   puppyrus 13.11, pra1312
  основные свои моды puppy: precise_5.4.3, slacko_5.4
  прочие: porteus 2.1
 игровые модули
 программные модули

Оффлайн valentin

  • Ветеран
  • *****
  • Сообщений: 562
  • Репутация: +20/-0
Re:Русская версия Precise-5.7.1-retro
« Ответ #5 : 28 Сентябрь 2013, 00:04:37 »
Спасибо за  текущую русификацию и вообще  за ваш труд  по продвижению Puppy. Получил большое удовольствие после загрузки с CD и даже установил Full  на "попробовать"
Есть небольшое предложение -  хотя- бы в русифицированную версию добавить  "из коробки", в контекстное меню, для .sfs файлов пункт "Распаковать.." , а для каталогов - пункт "создать архив, пакет , .sfs-модуль.."  - как это сделано в той-же Ivanna или PR2.  Поверьте, это очень поможет начинающим "линуксоидам" ступить на путь создания .sfs модулей для себя,  может потом и с другими пользователями поделятся  ;)
Система:  Athlon XP 2500+  512RAM  Radeon9600

Оффлайн rodin.s

  • Почетный участник
  • Ветеран
  • *
  • Сообщений: 1179
  • Репутация: +96/-0
Re:Русская версия Precise-5.7.1-retro
« Ответ #6 : 28 Сентябрь 2013, 21:19:22 »
Посмотрю, что можно сделать с правым кликом. Существующие готовые варианты мне не очень нравятся, слишком избыточны. Нужно делать что-то своё с каким-то минимальным набором функций.

Оффлайн valentin

  • Ветеран
  • *****
  • Сообщений: 562
  • Репутация: +20/-0
Re:Русская версия Precise-5.7.1-retro
« Ответ #7 : 28 Сентябрь 2013, 23:41:30 »
Посмотрите, может вам понравится :
Для распаковки по ПКМ для .sfs  и .pfs  модулей слегка доработанный пакет от RoDoN sfs-apps.pet
 Для запаковки по ПКМ каталогов в архив, .pet, .sfs  сильно "порезанный" Pup_targz2.pet - удалил все, что касалось .pfs и создания .iso образов.

З.Ы. в пакете sfs-apps.pet  для нормального отображения в меню значка .sfs , в каталог sfs-apps/usr/local/apps/Pfs2Dir пришлось положить иконку -  не получилось у меня через ссылку, не умею  :( Если переделать  ссылкой то можно сэкономить  1 КБ  :)
Система:  Athlon XP 2500+  512RAM  Radeon9600

Оффлайн valentin

  • Ветеран
  • *****
  • Сообщений: 562
  • Репутация: +20/-0
Re:Русская версия Precise-5.7.1-retro
« Ответ #8 : 29 Сентябрь 2013, 10:16:03 »
Извиняюсь, вчера уже было поздно, спешил, и прозевал, что в пакете Pup_targz2 , в каталоге /root/.config/rox.sourceforge.net/OpenWith/.inode_directory/  ссылка должна называться "создать архив, .pet,.sfs" вместо "Pup_targz"  - тогда в меню по ПКМ  понятно, что можно сделать  >:(
Система:  Athlon XP 2500+  512RAM  Radeon9600

Оффлайн rodin.s

  • Почетный участник
  • Ветеран
  • *
  • Сообщений: 1179
  • Репутация: +96/-0
Re:Русская версия Precise-5.7.1-retro
« Ответ #9 : 29 Сентябрь 2013, 21:18:30 »
Из этих двух пакетов сделал один, адаптировав его для Puppy.

Оффлайн RoDoN

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 4631
  • Репутация: +95/-0
    • RoDoN
Re:Русская версия Precise-5.7.1-retro
« Ответ #10 : 29 Сентябрь 2013, 22:58:24 »
langpack_ru-20130901|Russian language-pack for Puppy Linux, for any Puppy built from Woof later than Feb. 14, 2012
console_kb-i18n-woof-ru-1.1|Переключение раскладки в консоли
i18n_precise571-130922|additional i18n for Precise-5.7.1
OpenWithTranslate-0.1|OpenWith translate ru
А эти пакеты где-нить выкладывались? Если нет, выложите плиз.

Acer Aspire One AO751h (Atom Z520, Intel GMA500)
Acer Extensa 5620Z (T7500, Intel 965GM)
PuppyRus-JWM-13.12, PRA, Upup Precise, Tahr Puppy.

Оффлайн valentin

  • Ветеран
  • *****
  • Сообщений: 562
  • Репутация: +20/-0
Re:Русская версия Precise-5.7.1-retro
« Ответ #11 : 30 Сентябрь 2013, 09:16:09 »
Еще небольшое расширение функционала по ПКМ  распаковать .pet - иногда из готового чужого пакета нужно что-то убрать, добавить  ;)  Сам скрипт pet2tgz уже есть в системе, это просто способ "обратиться " к нему по ПКМ.

Система:  Athlon XP 2500+  512RAM  Radeon9600

Оффлайн china

  • Пользователь
  • **
  • Сообщений: 90
  • Репутация: +0/-0
Re:Русская версия Precise-5.7.1-retro
« Ответ #12 : 30 Сентябрь 2013, 17:20:45 »
Красава всё работает замечательно!
Автору большое человеческое спасибо!
« Последнее редактирование: 30 Сентябрь 2013, 17:34:58 от china »

Оффлайн rodin.s

  • Почетный участник
  • Ветеран
  • *
  • Сообщений: 1179
  • Репутация: +96/-0
Re:Русская версия Precise-5.7.1-retro
« Ответ #13 : 01 Октябрь 2013, 00:19:36 »
Добавил в пакет правого клика опцию распаковки pet, но пока не могу включить в сборку т.к. возникла небольшая проблема. Дело в том, скрипт для создания pet был написан для Puppy-4, а в Puppy-5 используется немного другой формат и хотя есть обратная совместимость, не хотелось бы, чтобы создавались пакеты для Puppy-4. Я попытался что-то исправить, но там используется какая-то излишне сложная логика, которую я так и не понял. Когда я создаю пакеты вручную, то если в каталоге для пакета нет pet.specs, я запускаю dir2pet, а если в каталоге уже есть pet.specs, я выполняю, например:
tar cf myRightClick-0.2.tar myRightClick-0.2/
gzip myRightClick-0.2.tar
tgz2pet myRightClick-0.2.tar.gz
Возможно, этот сложный алгоритм просто дублирует функционал dir2pet или он был актуален для Puppy-4, а теперь не нужен или он делает что-то важное и полезное, я так и не понял.

Оффлайн rodin.s

  • Почетный участник
  • Ветеран
  • *
  • Сообщений: 1179
  • Репутация: +96/-0
Re:Русская версия Precise-5.7.1-retro
« Ответ #14 : 01 Октябрь 2013, 00:30:34 »
Выкладываю три pet-пакета, которые использовались в Precise-5.7.1-ru. Пакет локализации выложу отдельно, наверное, завтра.
OpenWithTranslate всего лишь переводит то небольшое контекстное меню, которое есть в Puppy по умолчанию.