Сайт | Скачать | Видео | Wiki

Автор Тема: sfs-get - менеджер модулей.pfs .sfs  (Прочитано 40198 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн imago31

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 2839
  • Репутация: +41/-0
  • горний арол
Re:sfs-get, mnt_sfs доработанные для .pfs и оф. репозитория
« Ответ #75 : 05 Сентябрь 2014, 17:16:10 »
pfs-test можно было бы тоже выделить в отдельную тему
и параметр поиска optioanal почему то сделан в виде кнопики, при нажатии которй окно sfs-get закрывается, нельзя ли это исправить или так задумано для чего то?
Врач спасает человека, ветеринар - человечество
 все эксперименты на dual core 2x3.1 GHz/ram-3Gb/gt 440 1gb/WCD 80gb IDE/Samsung 80gb sata/3 флешки с зоопарком линуксов.
  Для работы и игр: Windows 10 снес, поставил 7
  Для души, для скорости и всего остального: Linux(pra, puppy, porteus, ubuntu-подобные)
 
 игровые модули
 программные модули

Онлайн sfs

  • Администратор
  • Ветеран
  • *****
  • Сообщений: 26190
  • Репутация: +178/-0
    • PuppyRus-A
Re:sfs-get, mnt_sfs доработанные для .pfs и оф. репозитория
« Ответ #76 : 08 Сентябрь 2014, 09:15:27 »
pfs-test можно было бы тоже выделить в отдельную тему
Можно. Только надо ли
Пусть будет как встроенная защита. Чтобы новички не сразу нашли
и параметр поиска optioanal почему то сделан в виде кнопики, при нажатии которй окно sfs-get закрывается, нельзя ли это исправить или так задумано для чего то?
У меня работает. Должно выходить меню с модулями из локального /optional

Оффлайн RoDoN

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 5713
  • Репутация: +126/-0
    • RoDoN
Запустил sfs-get v.141005, при обновлении URL репы получил то, что на первой картинке, но ведь ресурс http://cdn.2safe.com/ уже давно не работает, как же оттуда можно обновиться, а последующий результат просмотра URL репы на второй картинке.
« Последнее редактирование: 06 Октябрь 2014, 23:50:28 от RoDoN »

Acer Aspire One AO751h (Atom Z520, Intel GMA500)
Acer Extensa 5620Z (T7500, Intel 965GM)
PuppyRus-JWM-13.12, PRA, Upup Precise, Tahr Puppy, Runtu 16.04 XFCE.

Онлайн sfs

  • Администратор
  • Ветеран
  • *****
  • Сообщений: 26190
  • Репутация: +178/-0
    • PuppyRus-A
Url репа сейчас не используется , но работает ( кому надо для своих модулей )
Надо удалить /etc/sfs-get/links/_up-links.txt

Оффлайн Gerpes

  • Пользователь
  • **
  • Сообщений: 42
  • Репутация: +0/-0
Re:sfs-get, mnt_sfs доработанные для .pfs и оф. репозитория
« Ответ #79 : 09 Сентябрь 2015, 20:21:17 »
А нет ли sfs-get.sfs новой версии для подключения в LupurusBit? Чтобы подключать .pfs из новых репозиториев?

Онлайн sfs

  • Администратор
  • Ветеран
  • *****
  • Сообщений: 26190
  • Репутация: +178/-0
    • PuppyRus-A
Re:sfs-get, mnt_sfs доработанные для .pfs и оф. репозитория
« Ответ #80 : 10 Сентябрь 2015, 09:12:14 »
Последняя версия в PRA
Специально для LupurusBit ничего не затачивается
Должно работать в любом фругале
Из репы должен работать портированный софт (*-p-.pfs). Если не запускается - смотреть вывод консоли и добавлять из ПРА либы в /opt/прога/lib

Оффлайн Gerpes

  • Пользователь
  • **
  • Сообщений: 42
  • Репутация: +0/-0
Re:sfs-get, mnt_sfs доработанные для .pfs и оф. репозитория
« Ответ #81 : 10 Сентябрь 2015, 14:31:58 »
Когда пытался примонтировать .pfs в коробочном LupurusBit, выходила мессага о неправильном формате sfs. Вот я и хотел обновить, чтобы к LupurusBit можно было подключать пакеты из репозитория PRA.  Очень жаль, что прекращена поддержка.

Онлайн sfs

  • Администратор
  • Ветеран
  • *****
  • Сообщений: 26190
  • Репутация: +178/-0
    • PuppyRus-A
Re:sfs-get, mnt_sfs доработанные для .pfs и оф. репозитория
« Ответ #82 : 10 Сентябрь 2015, 15:05:38 »
Если я не путаю - LupurusBit поддерживает в ядре squashfs-xz
Соответственно можно переименовав .pfs -> .sfs подключать LupurusBit подключалкой
А не проще ли просто перейти на ПРА? Что в LupurusBit есть такого, чего нет в ПРА?

Оффлайн Gerpes

  • Пользователь
  • **
  • Сообщений: 42
  • Репутация: +0/-0
Re:sfs-get, mnt_sfs доработанные для .pfs и оф. репозитория
« Ответ #83 : 10 Сентябрь 2015, 19:50:09 »
Я пробовал подключать .pfs, в окне программы выбирая опцию "Все файлы". .pfs не подключает.
Не знаю, чего нет в PRA, мне как-то неуютно в ней, а настраивать окружение я не умею, меня жестко глючит, когда дело касается автозагрузки и редакции конфигов. :) В LupurusBit же я не помню, что настраивал, почти все пошло сразу и разные окружения есть, да и привычка- Jeans,SnowDog, потом вот LupuRus, осталась, а этот как-то на мой взгляд отличился.

Подскажите пожалуйста, как смотреть смотреть вывод консоли, а либы добавить уже проблемы не составит.
« Последнее редактирование: 10 Сентябрь 2015, 22:20:31 от Gerpes »

Онлайн sfs

  • Администратор
  • Ветеран
  • *****
  • Сообщений: 26190
  • Репутация: +178/-0
    • PuppyRus-A
Re:sfs-get, mnt_sfs доработанные для .pfs и оф. репозитория
« Ответ #84 : 11 Сентябрь 2015, 09:22:50 »
Не знаю, чего нет в PRA, мне как-то неуютно в ней
PRA в меньшей степени пупи, зато в большей стандартный линукс
Дело вкуса. Но если интересуют приложения PRA - боюсь проще их будет запустить в родной среде
Подскажите пожалуйста, как смотреть смотреть вывод консоли, а либы добавить уже проблемы не составит.
Запускаете urxvt (терминал). Пишете название проги + enter
Она запускается или пишет каких либ не хватает. Для автоматизации разрешения зависимостей в ПРА есть dep-find (должен работать в любом линуксе)
Держите в курсе - насколько получилось запустить портированный софт. Не зря ли я за это ломаюсь...

Оффлайн DdShurick

  • Это Риччи
  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 7123
  • Репутация: +167/-2
  • Старый чайник
Re:sfs-get, mnt_sfs доработанные для .pfs и оф. репозитория
« Ответ #85 : 11 Сентябрь 2015, 17:04:54 »
PRA в меньшей степени пупи
PRA это Arch и ни разу не Puppy.
зато в большей стандартный линукс
Как раз самый нестандартный. Был бы стандартный, я бы его поддерживал.
Моноблок Lenovo IdeaCentre c200 (Intel Atom D525, Intel GMA 3150)
Netbook Acer 722 c6ckk (AMD C-50 Ontario, Radeon HD 6250)
Nettop Asus Eee Box PC B202 (Intel Atom N270, intel GMA 950)
Nettop Asus Eee Box PC EB1007 (Intel Atom D425, Intel GMA 3150)
Вопросы: DdShurick@jabber.ru

Оффлайн Gerpes

  • Пользователь
  • **
  • Сообщений: 42
  • Репутация: +0/-0
Re:sfs-get, mnt_sfs доработанные для .pfs и оф. репозитория
« Ответ #86 : 12 Сентябрь 2015, 00:24:03 »
Я так понял, что ядро LupurusBit нужно обновить с 2.6.33.2 до >=2.6.38, тогда появится поддержка xz и возможно, все начнет работать и без либ. Курил тему -  [Пересборка ядра], не помогло, фигу вижу- я make в консоли ни разу не набирал, мне такого мана крайне мало, тем более для frugal установки. Вот так.

Оффлайн ansivar

  • Пользователь
  • **
  • Сообщений: 95
  • Репутация: +7/-0
Re:sfs-get, mnt_sfs доработанные для .pfs и оф. репозитория
« Ответ #87 : 12 Сентябрь 2015, 01:28:22 »
Я так понял, что ядро LupurusBit нужно обновить с 2.6.33.2 до >=2.6.38, тогда появится поддержка xz
Можно посмотреть здесь:
http://www.murga-linux.com/puppy/viewtopic.php?t=90461
на Lucid Puppy Revitalized as 5.2.8.7 - July, 2015.
Цитата
   - lupusuper (or "sulu") is/are based on kernels 3.x, to support newer hardware and xz compression:
      
        - lupusuper1
        http://www.mediafire.com/download/ubfqgu2qv9pypec/lupusuper1-5.2.8.7-k3.0.25-20150614.iso
        md5sum: d6c4955ad6721b26f6b4154274cb0991

        - lupusuper2 (kernel from precise 5.7.1-retro, which includes analog modem support)
        http://www.mediafire.com/download/trph1qoyx3v3d1a/lupusuper2-5.2.8.7-k3.2.48-20150702.iso
        md5sum: 3590372496004bdf78f535b53e624d1c

        - lupusuper3 (kernel from pemasu's dpup wheezy)
        http://www.mediafire.com/download/v6p0zen94eezr4e/lupusuper3-5.2.8.7-k3.5.2-20150614.iso
        md5sum: 53515a41bef6efa12aa8e17170a92d3c

        - lupusuper4 (kernel from pemasu's upup raring)
        http://www.mediafire.com/download/jgnlkacquj1fc9l/lupusuper4-5.2.8.7-k3.9.9-20150702.iso
         md5sum: 03a62dc67af7dc4a7c55e0837e53bce6
      
      
         - lupusuper with LibreOffice including Java Runtime Environment integrated or as added SFS files:

        - lupusuper2libre is lupusuper2 with LibreOffice and java/jre included in the large main file, to load into RAM if 1 GB of RAM is installed.
        http://www.mediafire.com/download/kyjmox9jr9bv1p5/lupusuper2libre-5.2.8.7-4.3.7-k3.2.48-20150614.iso
        md5sum: b6402ecc60bbf81ff7823a43edd6570f (final version of LO 4.3)

        - lupusuper2plus is lupusuper2 with added SFS files such as LibreOffice and java runtime (jre) to be copied to a frugal installation directory.
        http://www.mediafire.com/download/r4ud65kdbhs3813/lupusuper2plus-5.2.8.7-4.4.4-k3.2.48-20150702.iso
        md5sum: 3dbcf66d55e45dfbdb93fb272cd814c2 (stable June version of LO 4.4)

        - lupusuper4libre is lupusuper4 with LibreOffice and java/jre included in the large main file, to load into RAM if 1 GB of RAM is installed.
        http://www.mediafire.com/download/mbhamk22u55qqrc/lupusuper4libre-5.2.8.7-4.3.7-k3.9.9-20150614.iso
        md5sum: 297eb867b43795525776fd92c00718d3 (final version of LO 4.3)

        - lupusuper4plus is lupusuper4 with added SFS files such as LibreOffice and java runtime (jre) to be copied to a frugal installation directory.
        http://www.mediafire.com/download/04t9g379f6d3ood/lupusuper4plus-5.2.8.7-4.4.4-k3.9.9-20150702.iso
        md5sum: 429e218e6bd9f0ec47fc417007c67cb6 (stable June version of LO 4.4)

The ISO files will be updated together and will have the same date-tag in their names.
The "libre" and "plus" files may be updated with later versions of LibreOffice but the
date stamp may be unchanged because it relates only to the puppy version.
« Последнее редактирование: 12 Сентябрь 2015, 01:39:57 от ansivar »

Оффлайн Gerpes

  • Пользователь
  • **
  • Сообщений: 42
  • Репутация: +0/-0
Re:sfs-get, mnt_sfs доработанные для .pfs и оф. репозитория
« Ответ #88 : 12 Сентябрь 2015, 21:29:04 »

Можно посмотреть здесь:
http://www.murga-linux.com/puppy/viewtopic.php?t=90461
на Lucid Puppy Revitalized as 5.2.8.7 - July, 2015.


Посмотрел, немного поигрался с пакетами. Переименованные из .pfs в .sfs нормально ставятся, немного не хватает библиотек, но в целом работает. В результате для меня там русскую локаль накатывать и так же окружение крутить, В LupurusBit ядро обновлять, в PRA опять же под себя окружение переделывать (на виртуалке PRA огорчила глухими тормозами, почему-то остальные так себя не вели), одинаково непонятно, но только в таком случае будет какая-то универсаль..

Онлайн sfs

  • Администратор
  • Ветеран
  • *****
  • Сообщений: 26190
  • Репутация: +178/-0
    • PuppyRus-A
Re:sfs-get, mnt_sfs доработанные для .pfs и оф. репозитория
« Ответ #89 : 14 Сентябрь 2015, 10:01:37 »
PRA это Arch и ни разу не Puppy.
PRA - это PRA  :)
Был бы стандартный, я бы его поддерживал.
Приведите примеры "стандартных" в Вашем понимании
Что мешает сделать "стандартный" дистр и его поддерживать?

Я так понял, что ядро LupurusBit нужно обновить с 2.6.33.2 до >=2.6.38, тогда появится поддержка xz
Да. Или перепаковать в дистре поддерживающем xz в gz (mkpfs -g)
Думаю - самое простое - вкатить в ЛРБ ядро от ПРА (начать со старых)
Самостоятельная компиляция ядра - не для новичков
и возможно, все начнет работать и без либ.
Нет. Либы не связаны с ядром и xz.