Сайт | Скачать | Видео | Wiki

Автор Тема: новичок и компиляция  (Прочитано 36455 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн myname

  • Старожил
  • ****
  • Сообщений: 373
  • Репутация: +15/-1
Re: новичок и компиляция
« Ответ #45 : 24 Март 2010, 01:47:24 »
прилепил к паппи pacman из archlinux, вроде всё работает.....но когда пытаюсь скомпилить по PKGBUILD ,жалуется на неверную md5 сумму сорцов (нахрен они это придумали)... попробуйте кто нибудь,тока потом напишите
« Последнее редактирование: 29 Март 2016, 16:59:54 от sfs »

Оффлайн myname

  • Старожил
  • ****
  • Сообщений: 373
  • Репутация: +15/-1
Re: новичок и компиляция
« Ответ #46 : 24 Март 2010, 16:20:37 »
Вобщем не работает на паппи,сорцы не компилятся,выдаёт ошибку md5, abs тоже выдаёт ошибку,не скачивается по rsync  древо портов...Не знаю в чём причина,или чего то не хватает,или в паппи уж сильно всё перекаверкано....П.С. На слаксе проверял всё работает и md5 и abs,и проги компилятся...  

Оффлайн Fliker09

  • Почетный участник
  • Ветеран
  • *
  • Сообщений: 1624
  • Репутация: +120/-1
  • Puppy 4ever!
Re: новичок и компиляция
« Ответ #47 : 24 Март 2010, 21:55:53 »
Ок, отпишусь. Дам подсказку :). Думайте размеры паппика случайны? Пришлось вдоволь по облегчать. Чтоб решить проблему с базовыми утилитами линукса - установите соответствующий пакет из реп слаки и всё будет работать (сам встречался с подобными проблемами).
Я покинул проект так что прошу в случае чего писать мне на мыло!
Драйверы от разных систем НЕСОВМЕСТИМЫ!
http://wellminded.com/puppy/pupsearch.html -
 - поиск по http://www.murga-linux.com/puppy/
http://www.minus.com/ - для постоянного хранения файлов
http://rghost.ru/ - для временного хранения файлов
http://appdb.winehq.org/ - база данных WINE
http://jabberworld.info/ - всё о Jabber
http://convertfiles.com/ - конвертер файлов

Оффлайн myname

  • Старожил
  • ****
  • Сообщений: 373
  • Репутация: +15/-1
Re: новичок и компиляция
« Ответ #48 : 25 Март 2010, 01:18:05 »
Знаю что обрезано не случайно...И же Какой пакет доустановить?Подскажете, буду очень благодарен... Наскока вижу утилиты md5sum и rsync в паппи есть по умолчанию...Пробовал на 4.31 и 4.20,А в паппи 4.20 я ещё xz и glibc 2.9 доустанавливал...   

Оффлайн myname

  • Старожил
  • ****
  • Сообщений: 373
  • Репутация: +15/-1
Re: новичок и компиляция
« Ответ #49 : 25 Март 2010, 01:40:13 »
Предположительно думаю что причина неработы в паппи, в перекаверканой директории /etc ,чота тут как то много чего изменили....На слаксе работает на двух модулях core и base,надо в них искать (у меня слакс для уменьшения ресурсоёмкости загружается с двух модулей core и base (в них и гуй есть fluxbox) 3 модуля kde и devel подключаю потом, если нужно) когда нужно чота компилить подключаю devel (всё для компиляции и ядро)

Оффлайн myname

  • Старожил
  • ****
  • Сообщений: 373
  • Репутация: +15/-1
Re: новичок и компиляция
« Ответ #50 : 25 Март 2010, 02:02:51 »
Нащёт,доустановить базовые пакеты в паппи...Я доустанавливал с самого арч линукса...Coreutilits и т.Д ...Всё равно не работает....Надо ещё Попробовать с deli linux (он основан на слаке) выковырять pacman 2.X и к паппи прилепить....

Оффлайн myname

  • Старожил
  • ****
  • Сообщений: 373
  • Репутация: +15/-1
Re: новичок и компиляция
« Ответ #51 : 25 Март 2010, 02:19:25 »
А вобще...Предположительно уже догадываюсь,в чём причина...

Оффлайн Sender

  • Пользователь
  • **
  • Сообщений: 55
  • Репутация: +6/-0
Re: новичок и компиляция
« Ответ #52 : 07 Апрель 2010, 19:29:39 »
Толи никто не знал, толи не хотели отвечать:

Прочёл эту тему и http://forum.puppyrus.org/index.php/topic,722.0.html

На Windows часто пользовался программами отсюда http://aluigi.org/mytoolz.htm

Хочу скомпилировать под Паппи Джинс 1.3.0  udp port mapper  http://aluigi.org/mytoolz/sudppipe.zip

Распаковал содержимое в папку /usr/udp/ readme.txt нету. Общее ридми  http://aluigi.org/about.htm#compile

Набрал в консоли: gcc -o file.exe /usr/udp/sudppipe.c -lws2_32
Код
# gcc -o file.exe /usr/udp/sudppipe.c -lws2_32
/usr/lib/gcc/i486-slackware-linux/4.1.2/../../../../i486-slackware-linux/bin/ld: cannot find -lws2_32
collect2: ld returned 1 exit status
#

Я запутался и не понимаю, что делать дальше. Поможете ?




http://puppylinux.org/wikka/compiling ---- Вот полный мануал на инглише, как компилировать проги. Я учился по нему.

теперь отвечу на свой же вопрос - как скомпилировать UDP port mapper.

1) Чисто для себя создал папку /gcc/udp/ распаковал туда содержимое sudppipe.zip
2) Потом внутри папки /gcc/udp/ - нажимаю клавишу Ё ( чтобы вызвать консоль )
3) Если открылась консоль, то вводим команду gcc
Если devx подключен, то в консоли выдаст gcc: no input file - Это означает, что всё ОК, компилятор подключён и будет работать.
4) ( Собственно самое важное - компиляция)
Команда компиляции в данном случае для UDP port mapper
Код
gcc sudppipe.c -o sudppipe -ldl

Иногда компилятор выдаёт ошибки ( прога в случае ошибок не скомпилируется разумеется) Например ошибка,
Цитата
sudppipe.c:(.text+0x123a): undefined reference to `dlopen'
Это означает, что компилятору необходимы дополнительные параметры. Вбиваете в гугл ошибку, и если повезёт то найдёте решение.

Я под паппи уже скомпилировал

cmdsock - Telnet server ( телнет ) - требует доп. параметр -lpthread
proxymini  - мини прокси сервер- требует доп. параметр -lpthread
sudppipe - UDP Порт маппер форвардер - требует доп. параметр -ldl
stcppipe - TCP Порт маппер форвардер - требует доп. параметр -lpthread -lssl


ЗЫ, с компилированием я смог разобратся - только в оригинальном паппи 431. Теперь могу применять эти знания в Джинс 130
ЗЫЫ, извините но создаётся такое  впечатление будто из за http://forum.puppyrus.org/index.php/topic,3978.0.html  меня некоторые игнорируют :(
Меня это совсем не радует
« Последнее редактирование: 02 Июнь 2010, 14:34:07 от Sender »

Оффлайн Fliker09

  • Почетный участник
  • Ветеран
  • *
  • Сообщений: 1624
  • Репутация: +120/-1
  • Puppy 4ever!
Re: новичок и компиляция
« Ответ #53 : 07 Апрель 2010, 21:52:58 »
ЗЫЫ, извините но создаётся такое  впечатление будто из за http://forum.puppyrus.org/index.php/topic,3978.0.html  меня некоторые игнорируют Грустный
Меня это совсем не радует
- всё проще - времени или знаний у народа нету. Компиляция дело тёмное и без некоторого багажа и опыта советовать что либо непросто.
Я покинул проект так что прошу в случае чего писать мне на мыло!
Драйверы от разных систем НЕСОВМЕСТИМЫ!
http://wellminded.com/puppy/pupsearch.html -
 - поиск по http://www.murga-linux.com/puppy/
http://www.minus.com/ - для постоянного хранения файлов
http://rghost.ru/ - для временного хранения файлов
http://appdb.winehq.org/ - база данных WINE
http://jabberworld.info/ - всё о Jabber
http://convertfiles.com/ - конвертер файлов

Оффлайн knss

  • Пользователь
  • **
  • Сообщений: 28
  • Репутация: +0/-0
Re:новичок и компиляция
« Ответ #54 : 16 Январь 2013, 00:18:06 »
и подключить модуль devx_301.sfs

этот модуль универсальный, на Wary_5.1.2ru подойдет ?

И ещё, программу которую я хочу попробовать собрать из исходников, в требованиях для Linux :

-- Библиотека Qt версии 4.6 или новее. По всей видимости, MuseScore не соберется с более старыми версиями
 Собранные пакеты часто делятся на "runtime package" и "development package". Нужно установить оба эти пакета.
-- Свежая версия X11 с поддержкой freetype2 и расширением render (для сглаженных экранных шрифтов)
-- ALSA версии 1.0 или новее; только для ввода с MIDI-клавиатуры
-- CMake 2.4

Это реально сделать?? для OS Wary. Я полный, так сказать, ноль в линуксе. Прошу ваших подсказок  ::)
« Последнее редактирование: 16 Январь 2013, 00:20:24 от knss »

Оффлайн RoDoN

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 5766
  • Репутация: +126/-0
    • RoDoN X
Re:новичок и компиляция
« Ответ #55 : 16 Январь 2013, 00:35:12 »
этот модуль универсальный, на Wary_5.1.2ru подойдет ?
Нет. Для каждой версии паппи свой devx.
Для Вашей Wary нужен http://ftp.nluug.nl/pub/os/Linux/distr/quirky/wary-5.1.2/devx_wary_5.1.2.sfs

Зачем компилировать, если Вы же в др.теме уже нашли http://ftp.nluug.nl/pub/os/Linux/distr/puppylinux/pet-packages-lucid/Musescore-1.0-lucid525.sfs ?

Acer Aspire One AO751h (Atom Z520, Intel GMA500)
Acer Aspire E1-571G (i3-3120M, GF710M)
PuppyRus-JWM-13.12, PRA, Upup Precise, Tahr Puppy, Runtu 18.04 x64 MATE/XFCE.

Оффлайн knss

  • Пользователь
  • **
  • Сообщений: 28
  • Репутация: +0/-0
Re:новичок и компиляция
« Ответ #56 : 16 Январь 2013, 10:30:57 »
Зачем компилировать, если Вы же в др.теме уже нашли http://ftp.nluug.nl/pub/os/Linux/distr/puppylinux/pet-packages-lucid/Musescore-1.0-lucid525.sfs ?

Кто-нибудь знает, эта версия подойдёт для версии Паппи Wary 5.1.2ru ... или же нужно занового компилировать ? Спасибо за помощь  ::)
« Последнее редактирование: 16 Январь 2013, 10:34:43 от knss »

Онлайн Pro

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 10386
  • Репутация: +107/-2
Re:новичок и компиляция
« Ответ #57 : 16 Январь 2013, 10:38:11 »
Кто-нибудь знает, эта версия подойдёт для версии Паппи Wary 5.1.2ru ... или же нужно занового компилировать ? Спасибо за помощь  ::)
качните, правой кнопкой на пакете и пункт Подключить
чем спрашивать лучше самому проверить.
Я загружаю новые пакеты сюда: http://file.puppyrus.org/users/ а дальше можно найти самостоятельно.

Оффлайн knss

  • Пользователь
  • **
  • Сообщений: 28
  • Репутация: +0/-0
Re:новичок и компиляция
« Ответ #58 : 18 Январь 2013, 10:34:42 »
чем спрашивать лучше самому проверить.
Отвечаю на вопрос -нет не лучше. Самому не лучше во всем разобраться, особенно когда нет к-л опыта ползования в линуксе. Для этого есть форум и другие более опытные пользователи, которые подскажут что и как.

Musescore-1.0-lucid525.sfs если я не ошибаюсь, была скомпилированна для OS Ivanna.. У меня другая Ось, Wary . Поэтому я, прежде чем скачивать, и спросил - стоит ли её скачивать и подойдет ли эта программа для моей Оси.

Я скачал по ссылке выше Musescore-1.0-lucid525.sfs . Не запускается.
Выдает:
mscore: error while loading shared libraries: libjack.so.0: cannot open shared object file: No such file or directory

Установил пакет jack-audio-connection-kit-0.109.2.pet
Тоже не запускается, выдает другое
mscore:/usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by mscore)

mscore: /lib/libc.so.6: version `GLIBC_2.11' not found (required by /opt/qt-opensource-4.7.3/lib/libQtGui.so.4)

Мне нужны ещё какие-то библиотеки Qt устанавливать? Или что-то ещё, чтобы запустить MuseScore ?

Онлайн Pro

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 10386
  • Репутация: +107/-2
Re:новичок и компиляция
« Ответ #59 : 18 Январь 2013, 10:45:17 »
Цитата
Отвечаю на вопрос -нет не лучше. Самому не лучше во всем разобраться, особенно когда нет к-л опыта ползования в линуксе. Для этого есть форум и другие более опытные пользователи, которые подскажут что и как.
Ну раз вы так, тогда где я вам рекомендовал разбираться? Я вам рекомендовал скачать, подключить и проверить. Данные действия не требуют сложных навыков.

Цитата
mscore:/usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by mscore)

mscore: /lib/libc.so.6: version `GLIBC_2.11' not found (required by /opt/qt-opensource-4.7.3/lib/libQtGui.so.4)
в данном случае есть несостыковка по версиям libc. В вашей версии дистрибутива libc слишком старый для запуска этой программы. qt нужные библиотеки внутри модуля видимо есть, но также требуют libc версии 2.11 или выше.
« Последнее редактирование: 18 Январь 2013, 10:48:35 от Pro »
Я загружаю новые пакеты сюда: http://file.puppyrus.org/users/ а дальше можно найти самостоятельно.