Сайт | Скачать | Видео | Wiki

Автор Тема: Hamachi  (Прочитано 5416 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн puppy

  • Пользователь
  • **
  • Сообщений: 52
  • Репутация: +0/-0
Hamachi
« : 17 Август 2012, 02:47:12 »
Здравствуйте , уважаемые формучане ! Скажите пожалуйста есть готовый пакет с Хамачи для XlupuRus 5.20 ? Буду признателен за помощь  :)
« Последнее редактирование: 17 Август 2012, 02:52:35 от puppy »
Тернист путь к знаниям, преоделевающий познает истиное знание

Оффлайн shelezyaka

  • Ветеран
  • *****
  • Сообщений: 698
  • Репутация: +39/-0
Re:Hamachi
« Ответ #1 : 17 Август 2012, 11:38:27 »
Intel Core 2 E7600 ,GeForce 630   ,  3Gb DDR2 , 2 HDD - 160+80 gB

Оффлайн puppy

  • Пользователь
  • **
  • Сообщений: 52
  • Репутация: +0/-0
Re:Hamachi
« Ответ #2 : 17 Август 2012, 17:12:53 »
Спасибо за ответ, но это не то что надо , это графическая оболочка к Хамачи .
 Я пробовал установит более новую версию с https://secure.logmein.com/labs/#HamachiforLinux , logmein-hamachi-2.1.0.68-x86.tgz
При выполнении  команды ./install.sh выдает LogMeIn Hamachi needs lsb packageсюдя по всему нужен lsb-пакет .
Не подскажете где можно его взять ?
Тернист путь к знаниям, преоделевающий познает истиное знание

Оффлайн puppy

  • Пользователь
  • **
  • Сообщений: 52
  • Репутация: +0/-0
Re:Hamachi
« Ответ #3 : 19 Август 2012, 02:19:11 »
Неужели никто не подскажет  :(
Тернист путь к знаниям, преоделевающий познает истиное знание

Оффлайн shelezyaka

  • Ветеран
  • *****
  • Сообщений: 698
  • Репутация: +39/-0
Re:Hamachi
« Ответ #4 : 19 Август 2012, 10:46:12 »
Посмотри здесь.
http://forum.puppyrus.org/index.php/topic,5682.msg41035.html#msg41035
Неужели никто не подскажет  :(
Значит этим никто не пользуется.Смотри либы в Ubuntu,там же можешь взять и готовый deb пакет.
Intel Core 2 E7600 ,GeForce 630   ,  3Gb DDR2 , 2 HDD - 160+80 gB

Оффлайн vityk

  • Старожил
  • ****
  • Сообщений: 356
  • Репутация: +24/-0
Re:Hamachi
« Ответ #5 : 19 Август 2012, 16:48:31 »
Тестируем logmein-hamachi-2.1.0.68.pet.

Оффлайн imp

  • /dev/бубен
  • Ветеран
  • *****
  • Сообщений: 542
  • Репутация: +25/-1
  • Пусть воюют другие
Re:Hamachi
« Ответ #6 : 19 Август 2012, 17:21:42 »
Глупый вопрос: если 2 удаленных компа связать с помошью hamachi, то возможен ли доступ
к локальной сети каждого (той, что находится за ним)?
Компьютер имеет то преимущество перед мозгом, что им пользуются.

Оффлайн puppy

  • Пользователь
  • **
  • Сообщений: 52
  • Репутация: +0/-0
Re:Hamachi
« Ответ #7 : 20 Август 2012, 01:24:52 »
Посмотри здесь.
http://forum.puppyrus.org/index.php/topic,5682.msg41035.html#msg41035
Посмотрел я , пакет что-то не стал ставится , появлялось сообщение " не удалось установить пакет..." Ведать что не хватает в в системе или чем-то не понравилась она

Цитировать
Смотри либы в Ubuntu,там же можешь взять и готовый deb пакет.
Сколько похожих пакетов пришлось перебрать , чтоб найти нужный :police: Но нашел подходящий вроде , коль удалось завести хамачи  . Правда при создание отметки во время запуска в /lib/lsb , запрашивался путь к python , о котором сообщил как отсутствующим. Поточнее завтра приведу текст сообщения. Версия пакета с lsb я установил : lsb-core 3.2 . Возможно не ту версию выбрал .
Хотелось услышать ваше мнение и других по поводу этого пакета . Спасибо за подсказку :)
Тестируем logmein-hamachi-2.1.0.68.pet.
Спасибо большое за сборку :) Протестирую ее.
Глупый вопрос: если 2 удаленных компа связать с помошью hamachi, то возможен ли доступ
к локальной сети каждого (той, что находится за ним)?
Да возможен , главно соответствующим образом настроить сеть.

Как и обещал :
при инсталяции хамачи путем
./install.shвыводится :
Removing previous version ..
Stopping LogMeIn Hamachi engine ..
Stopping LogMeIn Hamachi VPN tunneling engine logmein-hamachikillall: hamachid: no process killed
Removing LogMeIn Hamachi service ..
/opt/logmein-hamachi/uninstall.sh: /usr/lib/lsb/remove_initd: /usr/bin/python: bad interpreter: No such file or directory
Removing LogMeIn Hamachi symlink ..
Removing files from /opt/logmein-hamachi ..
LogMeIn Hamachi is removed.
Copying files into /opt/logmein-hamachi ..
Creating LogMeIn Hamachi symlink ..
Installing LogMeIn Hamachi service ..
./install.sh: /usr/lib/lsb/install_initd: /usr/bin/python: bad interpreter: No such file or directory (кажется я ошибся , говоря об папке)
Starting LogMeIn Hamachi service ..
Starting LogMeIn Hamachi VPN tunneling engine logmein-hamachiLogMeIn Hamachi is installed. See README for what to do next.
Но установка проходит успешно . Что скажите по этому поводу, это нормально ?

Тестируем logmein-hamachi-2.1.0.68.pet.
Проверил , все отлично работает , даже удалил пакет с lsb-core 3.2 и все равно работает.  Интересно знать какую роль играет lsb при инсталяции ? Спасибо большое за сборку , vityk  :)
« Последнее редактирование: 21 Август 2012, 00:48:44 от puppy »
Тернист путь к знаниям, преоделевающий познает истиное знание

Оффлайн vityk

  • Старожил
  • ****
  • Сообщений: 356
  • Репутация: +24/-0
Re:Hamachi
« Ответ #8 : 21 Август 2012, 01:05:16 »
LSB  - стандарт для улучшения совместимости различных дистрибутивов, как следствие, для инсталляции потребовалось наличие Python-а и, возможно, другого ПО. Пришлось немного поработать напильником для приведения к стандарту Puppy Linux.  ;D

Оффлайн puppy

  • Пользователь
  • **
  • Сообщений: 52
  • Репутация: +0/-0
Re:Hamachi
« Ответ #9 : 21 Август 2012, 11:13:52 »
Понятно , спасибо за просвещение :)
« Последнее редактирование: 21 Август 2012, 11:17:17 от puppy »
Тернист путь к знаниям, преоделевающий познает истиное знание

Оффлайн andy_1c

  • Новичок
  • *
  • Сообщений: 15
  • Репутация: +0/-0
Re: Hamachi
« Ответ #10 : 22 Март 2017, 09:56:02 »
hamachi

Приветствую!
Программу не обновляли? Она не в репозитариях? Требуется установка logmein-hamachi-2.1.0.68.pet?

Оффлайн andy_1c

  • Новичок
  • *
  • Сообщений: 15
  • Репутация: +0/-0
Re: Hamachi
« Ответ #11 : 31 Март 2017, 13:43:22 »
Привет всем!
Просьба помочь советом, как установить Hamachi

Оффлайн Pro

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 9072
  • Репутация: +92/-0
Re: Hamachi
« Ответ #12 : 31 Март 2017, 14:35:39 »
Вам под x32 или х64?
Я загружаю новые пакеты сюда: http://file.puppyrus.ml/users/ а дальше можно найти самостоятельно.

Оффлайн andy_1c

  • Новичок
  • *
  • Сообщений: 15
  • Репутация: +0/-0
Re: Hamachi
« Ответ #13 : 03 Апрель 2017, 09:19:22 »
Вам под x32 или х64?
Приветсвую!
Под х32

Оффлайн Pro

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 9072
  • Репутация: +92/-0
Re: Hamachi
« Ответ #14 : 03 Апрель 2017, 17:17:45 »
ок выложил
Я загружаю новые пакеты сюда: http://file.puppyrus.ml/users/ а дальше можно найти самостоятельно.