Сайт | Скачать | Видео | Wiki

Автор Тема: На нВидиа по людски вообще не работает.......  (Прочитано 17505 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Gerasats

  • Ветеран
  • *****
  • Сообщений: 1051
  • Репутация: +32/-0
  • Короче, я полный оппортунист.....и по фиг!
Собссно сообщение в заглавии, тем паче и RoDoN это озвучил в АТИ, если есть желание чтобы данные карточки тестировались, надо возвернуть ксорг и весу, нет, тогда в заглавии дистра пишем что это ***ATI&old nVidia.iso Издеваться над собой и своей уже не новой GeForce 240 не вижу особого смысла  :(.
Desktop:  AMD Phenom II X4 965 Black Edition 3400MHz, HyperX Limited Editions - 8GB Module - DDR3 1600MHz, ASRock N68C-GS FX, GeForce GT240 PCIe, LG Electronics IPS277L-BN, SSD Kingston SSDNow V300 (А400) 60GB (250GB) 2.5" SATAIII MLC
Netbook: Lenovo-s-10.2
Tablet: Acer-210, Phone: Samsung A5(2018)
OS - Bionicpup64 7.9.8 kernel 5.07.RC7 full install, Linux Mint 19.1 Tessa Cinnamon, Windows 10 rel. 1809 Enterprise LTSC, OpenElec, Android- 6.0 - 9.0

Онлайн Pro

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 10242
  • Репутация: +103/-1
Издеваться над собой и своей уже не новой GeForce 240 не вижу особого смысла
ну так отдельного приглашения вам не было, двери не открывали и не закрывали их просто нет.
Я загружаю новые пакеты сюда: http://file.puppyrus.org/users/ а дальше можно найти самостоятельно.

Оффлайн RoDoN

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 5684
  • Репутация: +125/-0
    • RoDoN
Издеваться над собой и своей уже не новой GeForce 240 не вижу особого смысла
Вы тут и меня вспомнили, но посмотрите здесь внимательнее, карточки начиная с серии 6xxx и дальше работают на nouveau нормально, у меня только из серии FX 5xxx вылезли проблемы. Грустно, что вообще мало кто пишет на каком железе, что и как работает, кстати на мурге подобную информацию найти значительно легче.
И вопрос: а вы вообще-то Richy пробовали запускать на "своей уже не новой GeForce 240"

Acer Aspire One AO751h (Atom Z520, Intel GMA500)
Acer Extensa 5620Z (T7500, Intel 965GM)
PuppyRus-JWM-13.12, PRA, Upup Precise, Tahr Puppy, Runtu 16.04 XFCE.

Оффлайн Gerasats

  • Ветеран
  • *****
  • Сообщений: 1051
  • Репутация: +32/-0
  • Короче, я полный оппортунист.....и по фиг!
И вопрос: а вы вообще-то Richy пробовали запускать на "своей уже не новой GeForce 240"

Если бы не пробовал не писал бы. И так в режиме лайва почти все нормально, после сохранения сесии, Вы же и показали на картинке как работает нВидиа, в режиме фул, первые два перезагруза нормально, что потом происходит с ОС не знаю, но начинает сыпать.

Согласно вот этого сообщения http://forum.puppyrus.org/index.php/topic,11896.msg64664.html#msg64664 по идее должна была появиться какая-то вменяемость, но у нас проблемы только с АТИ, а то что нувелл - труп, (особо в Паппи, для всего, ну разве что поддержка экзальтированной публики, которая хочет ну чтобы всё в свободной ОС было свободно) мы не видим, мы его упорно будем реанимировать?
Извините, если что не так.... 
Desktop:  AMD Phenom II X4 965 Black Edition 3400MHz, HyperX Limited Editions - 8GB Module - DDR3 1600MHz, ASRock N68C-GS FX, GeForce GT240 PCIe, LG Electronics IPS277L-BN, SSD Kingston SSDNow V300 (А400) 60GB (250GB) 2.5" SATAIII MLC
Netbook: Lenovo-s-10.2
Tablet: Acer-210, Phone: Samsung A5(2018)
OS - Bionicpup64 7.9.8 kernel 5.07.RC7 full install, Linux Mint 19.1 Tessa Cinnamon, Windows 10 rel. 1809 Enterprise LTSC, OpenElec, Android- 6.0 - 9.0

Онлайн Pro

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 10242
  • Репутация: +103/-1
А кто сделает нам пакеты проприетарных дров? .... если не Gerasats то кто?


ps. проблема с подключением sfs поверх базового sfs решена, препятствий для включения в usoft модулей ядра нет.
Я загружаю новые пакеты сюда: http://file.puppyrus.org/users/ а дальше можно найти самостоятельно.

Оффлайн Gerasats

  • Ветеран
  • *****
  • Сообщений: 1051
  • Репутация: +32/-0
  • Короче, я полный оппортунист.....и по фиг!
А кто сделает нам пакеты проприетарных дров? .... если не Gerasats то кто?

Наверное с год как не пользуюсь пакетами для проприатарных драйверов, сколько раз уже об этом писал, все что нужно чтобы установить в Паппи полный комплект проприатарных дров:
0. выкачать из Интернета полный новейший и последний run файл проприатарных драйверов с сайта производителя
1. ОС
2. devx - файл ОС;
3. src - патч ядра действующего в системе;
4. из главной консоли исполнить команду: "sh ati-driver-installer-9-3-x86.x86_64.run" или "sh  NVIDIA-Linux-x86-295.53.run"
5. не выходя из консоли переконфигурировать xorg.

Отмечайте сами чего не хватает для полного щастия....
Desktop:  AMD Phenom II X4 965 Black Edition 3400MHz, HyperX Limited Editions - 8GB Module - DDR3 1600MHz, ASRock N68C-GS FX, GeForce GT240 PCIe, LG Electronics IPS277L-BN, SSD Kingston SSDNow V300 (А400) 60GB (250GB) 2.5" SATAIII MLC
Netbook: Lenovo-s-10.2
Tablet: Acer-210, Phone: Samsung A5(2018)
OS - Bionicpup64 7.9.8 kernel 5.07.RC7 full install, Linux Mint 19.1 Tessa Cinnamon, Windows 10 rel. 1809 Enterprise LTSC, OpenElec, Android- 6.0 - 9.0

Онлайн Pro

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 10242
  • Репутация: +103/-1
я хз как делать патч ядра, и зачем он установщику который run.
пакеты проприетарных дров нужны чтобы поместив их в usoft (в идеале сам юзер это сделает) решить проблему и с драйверами и с 3Д и с т.п.
Ну раз вы не делаете давно, nik у нас тоже в загуле, значит всем жевать nouveau и др. что удалось скомпилить.
Я загружаю новые пакеты сюда: http://file.puppyrus.org/users/ а дальше можно найти самостоятельно.

Оффлайн Gerasats

  • Ветеран
  • *****
  • Сообщений: 1051
  • Репутация: +32/-0
  • Короче, я полный оппортунист.....и по фиг!
я хз как делать патч ядра, и зачем он установщику который run.
А откуда вообще взято ядро?
Ведь при компиляции, ядра если все идет штатно, то и получается начинка всей директории - src (520 - 600 мБ) для usr, а без патча ядра по факту ничего больше и не скомпилируешь, в нем заложено все что нужно ядру по железу, дрова, то дровами, но еще есть и виртуальные машины, да и многий софт опирается на этот самый  src. Для фругалов он и делается как sfs, нужен то один раз что либо скомпилил и отложил в сторону (мне в фуле он жить ОС - не мешает).
Что еще в Richy (beta) отсутствие нормального (полного ксорга) делает компилирование драйверов, занятием для идиота, то ли получилось все, то ли нет, все равно ни одна команда нормально не сработает, да и еще имеется момент, любая попытка компиляции драйвера встречает яростный отпор со ОС по glibc+, то ли старый, то ли сильно новый, он система файла run его просто не понимает. Обычно если старый ОС дает возможность попытаться скомпилировать на старом, если новый то пишет что обновись и приходи еще, а когда пишет "Warning Error! Unknown version glibc+. Install the latest version and then do it again", то и не знаешь чего ОС надо :(..
« Последнее редактирование: 06 Июнь 2012, 17:59:28 от Gerasats »
Desktop:  AMD Phenom II X4 965 Black Edition 3400MHz, HyperX Limited Editions - 8GB Module - DDR3 1600MHz, ASRock N68C-GS FX, GeForce GT240 PCIe, LG Electronics IPS277L-BN, SSD Kingston SSDNow V300 (А400) 60GB (250GB) 2.5" SATAIII MLC
Netbook: Lenovo-s-10.2
Tablet: Acer-210, Phone: Samsung A5(2018)
OS - Bionicpup64 7.9.8 kernel 5.07.RC7 full install, Linux Mint 19.1 Tessa Cinnamon, Windows 10 rel. 1809 Enterprise LTSC, OpenElec, Android- 6.0 - 9.0

Онлайн Pro

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 10242
  • Репутация: +103/-1
сдается мне вы крупно не в теме насчет xorg - он у нас как раз таки максимальный, и практически все часто используемые драйвера я компилирую без проблем. То что попадает в систему это лиш малая часть, остальное в настоящий момент находится в каталоге packages-216
поповоду патча ядра я вас понял, оно называется пакет исходных кодов ядра, у меня нет информации выложен ли он на общедоступный ftp, но я sfs с исходниками ядра делаю и выкладываю по мере изменения.

Ничего я выкладывать на общедоступные сервера не полномочен.
xorg разбит на 2 части, DEV находится уже в devx, бинарники соответственно в пакете xorg-meta и включаются в дистрибутив целиком.
драйвера видеокарт и устройств ввода можно ставить отдельными пакетами, в xorg-meta их нет

эх, я то думал gerasats собаку на этих проприетарных дровах съел, а он даже не знает что внутри этого run пакета лежит :(
Я загружаю новые пакеты сюда: http://file.puppyrus.org/users/ а дальше можно найти самостоятельно.

Оффлайн Gerasats

  • Ветеран
  • *****
  • Сообщений: 1051
  • Репутация: +32/-0
  • Короче, я полный оппортунист.....и по фиг!
Ну вот и поговорили....
Опять весчь в себе....ну и бог с ним, останемся в более открытой западной системе координат, тем более они тоже скучать не дают и лечение головной боли, путем отсечения последней - не практикуют..... http://www.youtube.com/watch?v=Z0D9tLI03JY&feature=g-upl :(
« Последнее редактирование: 06 Июнь 2012, 22:37:53 от Gerasats »
Desktop:  AMD Phenom II X4 965 Black Edition 3400MHz, HyperX Limited Editions - 8GB Module - DDR3 1600MHz, ASRock N68C-GS FX, GeForce GT240 PCIe, LG Electronics IPS277L-BN, SSD Kingston SSDNow V300 (А400) 60GB (250GB) 2.5" SATAIII MLC
Netbook: Lenovo-s-10.2
Tablet: Acer-210, Phone: Samsung A5(2018)
OS - Bionicpup64 7.9.8 kernel 5.07.RC7 full install, Linux Mint 19.1 Tessa Cinnamon, Windows 10 rel. 1809 Enterprise LTSC, OpenElec, Android- 6.0 - 9.0

Онлайн Pro

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 10242
  • Репутация: +103/-1
Опять весчь в себе....ну и бог с ним
ну так нытье о том что все плохо и невнятные рассуждения про какой то патч ядра конечно телегу с места не сдвинут.

Вы выложили по пунктам чего надо для создания драйверов, я вам расписал что все имеется и проблем быть не должно, что Вам еще надо?

ps. в репозитарии есть уже пакет xorg-meta-05.12 который содержит обновленный xorg-server но под него надо пересобирать драйвера видекарт т.к. изменился ABI
Я загружаю новые пакеты сюда: http://file.puppyrus.org/users/ а дальше можно найти самостоятельно.

Онлайн Pro

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 10242
  • Репутация: +103/-1
нехватает желания и интереса, ни того ни другого мне своего не хватает, поделиться не могу.
Я загружаю новые пакеты сюда: http://file.puppyrus.org/users/ а дальше можно найти самостоятельно.

Оффлайн Gerasats

  • Ветеран
  • *****
  • Сообщений: 1051
  • Репутация: +32/-0
  • Короче, я полный оппортунист.....и по фиг!
Pro посмотрите сюда   http://murga-linux.com/puppy/viewtopic.php?t=72405 должно ведь работать ядро нашего дистрибутива должно поддерживаться, при условии если есть ксорг.
Я ведь не думаю, что должен быть именно наш велосипед....
Для всех их сборок и дистров подходит.



Цитата
Для Slacko 5.3.x с ядрами 2.6.37.6  2.6.39.4, 3.1.10-slacko_4gA или 3.1.10-slacko_paeA. . (Содержит GLX, OpenGL и SDL) NVIDIA-GLX-SDL-295,49-slacko.sfs (Последнее обновление: 2012-05-07) загрузка отсюда http://shino.pos.to/party/bridge.cgi?puppy/opt/pup5/, но не запускать сразу NVidia Настройки, просто зайти в sfs_load и запустить xorgwizard перезагрузку компьютера произвести после  сообщения. Для Slacko 5.3.1, возможно, не потребуется перезагрузка компьютера , сразу заходите в xorgwizard для выбора драйвера. Slacko 5.3. 3, может потребоваться перезагрузка компьютера в вашей сессии для использования  ранее сохраненного xorgwizard.

и

Для Slacko 5.3.3 с ядром 3.1.10-slacko_4gA или 3.1.10-slacko_paeA. . (Содержит GLX, OpenGL и SDL) NVIDIA-GLX-SDL-295,53-slacko.sfs (Последнее обновление: 2012-05-28) http://shino.pos.to/party/bridge.cgi?puppy/opt/pup5/ 
« Последнее редактирование: 07 Июнь 2012, 12:14:38 от Gerasats »
Desktop:  AMD Phenom II X4 965 Black Edition 3400MHz, HyperX Limited Editions - 8GB Module - DDR3 1600MHz, ASRock N68C-GS FX, GeForce GT240 PCIe, LG Electronics IPS277L-BN, SSD Kingston SSDNow V300 (А400) 60GB (250GB) 2.5" SATAIII MLC
Netbook: Lenovo-s-10.2
Tablet: Acer-210, Phone: Samsung A5(2018)
OS - Bionicpup64 7.9.8 kernel 5.07.RC7 full install, Linux Mint 19.1 Tessa Cinnamon, Windows 10 rel. 1809 Enterprise LTSC, OpenElec, Android- 6.0 - 9.0

Онлайн Pro

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 10242
  • Репутация: +103/-1
нет не подойдет. Модули ядра даже для одной и той же версии несовместимы, отпечаток накладывает и glibc и gcc и параметры ядра, несмотря на то что наше ядро максимально было приближено к ядру барри, часть параметров я подсмотрел в убунту.
При запуске run файла происходит компиляция модуля ядра для видеокарты - естественно что оно хочет исходники ядра и devx.
из sfs наших иностранных коллег можно бы взять процедуру подключения этих драйверов, т.к. у нас данный вопрос еще не разработан.
Я загружаю новые пакеты сюда: http://file.puppyrus.org/users/ а дальше можно найти самостоятельно.

Оффлайн Gerasats

  • Ветеран
  • *****
  • Сообщений: 1051
  • Репутация: +32/-0
  • Короче, я полный оппортунист.....и по фиг!
Вот уж вроде все и есть чтобы скомпилировать драйвер, однако дырку от бублика  показывает вшитый нувел, нету возможности выпрыгнуть из него, в пристежке ругань инсталлера, и так с каждым шагом.

Это лог где я ответил нет, по отвечаешь да, а он тупит и ничего не делает.

« Последнее редактирование: 07 Июнь 2012, 19:07:46 от Gerasats »
Desktop:  AMD Phenom II X4 965 Black Edition 3400MHz, HyperX Limited Editions - 8GB Module - DDR3 1600MHz, ASRock N68C-GS FX, GeForce GT240 PCIe, LG Electronics IPS277L-BN, SSD Kingston SSDNow V300 (А400) 60GB (250GB) 2.5" SATAIII MLC
Netbook: Lenovo-s-10.2
Tablet: Acer-210, Phone: Samsung A5(2018)
OS - Bionicpup64 7.9.8 kernel 5.07.RC7 full install, Linux Mint 19.1 Tessa Cinnamon, Windows 10 rel. 1809 Enterprise LTSC, OpenElec, Android- 6.0 - 9.0