Форум проекта PuppyRus Linux

Дистрибутивы проекта PuppyRus Linux => PuppyRus-A [PRA] => PRA09. i386 сборка на репозитории Hyperbola => Тема начата: sfs от 05 Август 2019, 18:18:21

Название: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: sfs от 05 Август 2019, 18:18:21
Зарождение идеи. Подробности о Hyperbola (http://forum.puppyrus.org/index.php?topic=21949.msg160224#msg160224)

Hyperbola - GNU/Linux-libre LTS. Т.е. полностью свободный. Я этим не заморачивался. Пакеты , скомпиленные мной могут не подходить под эти стандарты. В оригинальном Hyperbola список плохих пакетов в пакете my-freedom
LTS (https://wiki.hyperbola.info/doku.php?id=en:main:releases) : поддержка (http://forum.puppyrus.org/index.php?topic=21949.msg160245#msg160245) до 2022г. Я тоже планирую поддерживать PRA09 не меньше

По ставнению с test*.iso модули могли быть переименованы. Проверяйте списки (http://file.puppyrus.org/users/pra/iso/pra09-1909b-i686.iso.md5.txt) или переустановите
Темы оформления - те же , что для пра6408 и ддр01
Впервые у нас - браузер iceweasel-uxp. Это gtk3 аналог palemoon
Облегченный Network Manager. gtk2 в исо. gtk3 в репе. Подойдет и к ДДР01

Поддержку PRA03 прекращаю.  Финальные iso : retro (https://sourceforge.net/projects/puppyrusa/files/_iso/pra03-1808retro.iso/download) ; fat (https://sourceforge.net/projects/puppyrusa/files/_iso/pra03-1808fat.iso/download)
Совместимость с ним репы ftp://mirror.yandex.ru/puppyrus/puppyrus-a/pra03/pfs-portable/ не гарантирую
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: krasnyh от 05 Август 2019, 18:47:31
Черновичок
Нормально вроде.
Смутил поначалу menu.lst от ddr. ) Логинится пришлось при запуске системы (live; woofwoof).

4.4.1-pf3 - ok
5.1.4-pf - error (из консоли так и не вышел; виртуалка)
4.20.15-pf7 - ok (вставил для проверки запуска со свежими ядрами)


p.s. OpenRC  :)
Скрин.
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: erasy от 06 Август 2019, 06:58:11
pra09-1908-i686-test1.iso
Грузится до запроса логина, после ввода (live/woofwoof, root/woofwoof) замирает на несколько секунд - и опять запрос.
На реальном железе.
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: sfs от 06 Август 2019, 09:43:47
4.4.1-pf3 - ok
5.1.4-pf - error (из консоли так и не вышел; виртуалка)
4.20.15-pf7 - ok (вставил для проверки запуска со свежими ядрами)
Грузится до запроса логина, после ввода (live/woofwoof, root/woofwoof) замирает на несколько секунд - и опять запрос.
На реальном железе.
Вылечил запуском Х от рута (как в minirc) /etc/X11/Xwrapper.config
Заработало со всеми ядрами
Нужно ли 2 ядра (http://forum.puppyrus.org/index.php?topic=21559.0)... Прошу проверить на разном железе. Ждущий режим пока не сделал
Смутил поначалу menu.lst от ddr.
Делал "на скорость" :) Пока в меню работает только 1й пункт
OpenRC  :)
mimirc c ходу не взлетел. Не копал
Вообще не особо охота изучить все init. Надо потестить по скорости - тогда решать
Логинится пришлось при запуске системы
Сделал автологин

Наладил автообновление через http (http://forum.puppyrus.org/index.php?topic=21953.msg160250#msg160250)
089-pra09-sf03.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/089-pra09-sf03.pfs) - это первый раз надо обновить руками
pkg-pra09-sf01.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/pkg-pra09-sf01.pfs)
072-pra09-sf02.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/072-pra09-sf02.pfs)
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: sfs от 06 Август 2019, 10:15:30
Проверил пра09 с palemoon (эффекта паразитной загрузки проца нет) chromium ffmpeg из pra03+ddr01 - все работает с видео и пр.
Модули из pfs-portable тоже подходят без напильника
Надо доделывать и по итогу сливать ПРА03. А по итогу эксплуатации и ПРА64 на Hyperbola перевести (уже, наверное, со следующего LTS)

Гиперболовцы жгут (https://www.hyperbola.info/news/end-of-xorg-support/)
Цитата
Поскольку Xenocara преследует те же цели, что и наши рекомендации по упаковке в вопросах стабильности и безопасности, мы решили удалить X.Org и использовать Xenocara в качестве поставщика по умолчанию для сервера отображения для системы X Window.  Решение означает, что Milky Way v0.2 будет последней версией, поддерживающей X.Org.
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: krasnyh от 06 Август 2019, 11:45:25
mimirc c ходу не взлетел. Не копал
Вообще не особо охота изучить все init. Надо потестить по скорости - тогда решать
Я за Openrc (https://wiki.archlinux.org/index.php/OpenRC), он более распространен и найти инфу по возможным проблемам проще. В отличие от minirc, который для меня так и остался 'черным ящиком'.
Тем более что запускается pra09 достаточно резво.


p.s. Скрин рабочего стола.

Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: sfs от 07 Август 2019, 16:59:00
mesa icu и пр. пока не вырезал из 001, т.к. это надо делать "хирургическим" способом
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: sfs от 08 Август 2019, 11:49:59
035-pra09-gtk2-02.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/035-pra09-gtk2-02.pfs)
070-pra09-sf03.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/070-pra09-sf03.pfs)
072-pra09-sf03.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/072-pra09-sf03.pfs)
089-pra09-sf04.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/089-pra09-sf04.pfs)
DEVX-pra09-sf01.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/DEVX-pra09-sf01.pfs)
python-3.6.8-pra09-sf01.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/python-3.6.8-pra09-sf01.pfs)
xf86-video-intel-pra09-sf01.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/xf86-video-intel-pra09-sf01.pfs)
добавил pm-suspend - проверяйте
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: sfs от 08 Август 2019, 14:51:30
001-pra09-sf05.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/001-pra09-sf05.pfs)
072-pra09-sf05.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/072-pra09-sf05.pfs)
mesa-17.0.5-pra09-sf01.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/mesa-17.0.5-pra09-sf01.pfs)
nss-3.30.2-pra09-sf01.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/nss-3.30.2-pra09-sf01.pfs)
Разделил. Тестируем и отделяю dev, пережимаю xz
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: krasnyh от 08 Август 2019, 15:11:40
Наглядно как непросто скачиваются пакеты с mirror.yandex.ru  --> wget; попытка: 7.
Лог.
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: krasnyh от 08 Август 2019, 15:16:58
Чтобы не искать репозитарий pra09 https://mirror.yandex.ru/puppyrus/puppyrus-a/pra09/
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: RoDoN от 08 Август 2019, 15:20:45
Наверно это проблемы из-за провайдера, т.к. сейчас без проблем скачал и через http, и через https, и через ftp
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: krasnyh от 08 Август 2019, 15:43:54
т.к. сейчас без проблем скачал и через http, и через https, и через ftp
Перезагрузился, стало все ok.


Разделил. Тестируем
Запускается.
Скрин (вирт., vesa).
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: sfs от 08 Август 2019, 17:58:04
089-de-tint2g-gtk2-pra09-sf02.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/089-de-tint2g-gtk2-pra09-sf02.pfs)
089-pra09-sf06.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/089-pra09-sf06.pfs)
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: sfs от 09 Август 2019, 12:20:49
dunst-git-1.4.1-1-i686.pkg.tar.xz (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra03/pra03-extra/dunst-git-1.4.1-1-i686.pkg.tar.xz)
engrampa-thunar-gtk2-1.12.1-3-i686.pkg.tar.xz (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra03/pra03-extra/engrampa-thunar-gtk2-1.12.1-3-i686.pkg.tar.xz)
imlib2-opt-1.4.9-4-i686.pkg.tar.xz (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra03/pra03-extra/imlib2-opt-1.4.9-4-i686.pkg.tar.xz)
072-pra09-sf06.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/072-pra09-sf06.pfs)
089-de-lxde-gtk2-pra09-02.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/089-de-lxde-gtk2-pra09-02.pfs)
089-de-tint2g-gtk2-pra09-sf03.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/089-de-tint2g-gtk2-pra09-sf03.pfs)
089-pra09-sf07.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/089-pra09-sf07.pfs)
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: sfs от 09 Август 2019, 17:47:10
Gtk3-pra09-sf01.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/Gtk3-pra09-sf01.pfs)
gnome-mpv-gtk3-0.16-pra09-sf01.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/gnome-mpv-gtk3-0.16-pra09-sf01.pfs)
mpv-light-0.22.0-pra09-sf01.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/mpv-light-0.22.0-pra09-sf01.pfs)
python-3.6.8-pra09-sf02.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/python-3.6.8-pra09-sf02.pfs)
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: betcher от 10 Август 2019, 07:19:33
Последние три темы не на месте. Здесь про разработку pfs и инитрд. Перенесем?
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: Acerman от 11 Август 2019, 23:23:44
Ух ты! Как ни зайду - новая сборка.  :)
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: sfs от 12 Август 2019, 17:39:56
030-qt5-pra09-sf02.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/030-qt5-pra09-sf02.pfs)
flameshot-qt5-p-r542-sf01.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/flameshot-qt5-p-r542-sf01.pfs)
icu-59.1-pra09-sf01.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/icu-59.1-pra09-sf01.pfs)

glibc-2.29-4.0-pra09-sf01.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/glibc-2.29-4.0-pra09-sf01.pfs)
gthumb-gtk3-p-3.8.0-sf03.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/gthumb-gtk3-p-3.8.0-sf03.pfs) - будет работать только с glibc-2.29
Надо решить какой glibc в 001... Родной или свежий

Прланирую сделать OVS и lxqt. На макете уже работают
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: sfs от 13 Август 2019, 18:36:59
035-pra09-gtk2-03.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/035-pra09-gtk2-03.pfs) переименовал в 035-gtk2-pra09-sf03.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/035-gtk2-pra09-sf03.pfs)
072-pra09-sf07.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/072-pra09-sf07.pfs)
089-de-lxqt-pra09-sf01.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/089-de-lxqt-pra09-sf01.pfs)
089-de-tint2g_gtk2-pra09-sf05.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/089-de-tint2g_gtk2-pra09-sf05.pfs)
Gtk3-pra09-sf02.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/Gtk3-pra09-sf02.pfs)
connman-cmst-qt5-2019.01.13.1-pra09-sf01.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/connman-cmst-qt5-2019.01.13.1-pra09-sf01.pfs)
connman-p-1.35-pra09-sf01.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/connman-p-1.35-pra09-sf01.pfs)
evince-no-gnome-gtk3-3.26.0-pra09-sf01.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/evince-no-gnome-gtk3-3.26.0-pra09-sf01.pfs)
geany-gtk3-p-1.35.0-sf01.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/geany-gtk3-p-1.35.0-sf01.pfs)
gparted-gtk3-1.0.0-pra09-sf01.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/gparted-gtk3-1.0.0-pra09-sf01.pfs)
gthumb-light-gtk3-3.6-pra09-sf01.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/gthumb-light-gtk3-3.6-pra09-sf01.pfs)
lxqt-connman_applet-qt5-p-201805-sf01.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/lxqt-connman_applet-qt5-p-201805-sf01.pfs)
photoflare-qt5-1.6.0-pra09-sf01.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/photoflare-qt5-1.6.0-pra09-sf01.pfs)
qmplay2-qt5-18.12.26-pra09-sf01.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/qmplay2-qt5-18.12.26-pra09-sf01.pfs)
smplayer-qt5-17.4.2-pra09-sf01.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/smplayer-qt5-17.4.2-pra09-sf01.pfs)
spacefm-gtk3-p-1.0.6-sf01.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/spacefm-gtk3-p-1.0.6-sf01.pfs)
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: sfs от 14 Август 2019, 16:19:13
Чистовик :
001-pra09-sf06.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/001-pra09-sf06.pfs)
030-qt5-pra09-sf03.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/030-qt5-pra09-sf03.pfs)
035-gtk2-pra09-sf05.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/035-gtk2-pra09-sf05.pfs)
Gtk3-pra09-sf03.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/Gtk3-pra09-sf03.pfs)
icu-59.1-pra09-sf02.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/icu-59.1-pra09-sf02.pfs)
mesa-17.0.5-pra09-sf02.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/mesa-17.0.5-pra09-sf02.pfs)
nss-3.30.2-pra09-sf02.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/nss-3.30.2-pra09-sf02.pfs)
DEV части модулей выше перенесены в
DEVX-pra09-sf02.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/DEVX-pra09-sf02.pfs)

Это пустышки:
070-pra09-sf05.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/070-pra09-sf05.pfs)
072-pra09-sf10.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/072-pra09-sf10.pfs)
Они перенесены в 001. Т.е. просто удалите 070 072
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: sfs от 16 Август 2019, 14:35:32
089-pra09-sf08.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/089-pra09-sf08.pfs)
089-de-ovs-1801-sf29.pfs (ftp://ftp.yandex.ru/puppyrus/roll/180101/089-de-ovs-1801-sf29.pfs)
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: sfs от 16 Август 2019, 16:50:54
http://file.puppyrus.org/users/pra/iso/pra09-1908-i686-test2.iso
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: krasnyh от 16 Август 2019, 17:36:37
http://file.puppyrus.org/users/pra/iso/pra09-1908-i686-test2.iso
В "title PRA09 LXQT-gtk2" все DE загружаются одновременно из /optional. Смотрю на командную строку, вроде все правильно написано, тогда как!!!??  :) И только потом увидел ошибку:
Цитата
kernel /%d%/vmlinuz-%k% dir=%d% quiet %h% load=030-qt5-;icu;python2;yout;palemoon;Pulse;de-lxqt;lxqt_gtk2;-qt5-;gvfs;;inks;-gtk2- noload=de-lxde

Оказывается есть простой способ грузить все скопом. )
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: sfs от 16 Август 2019, 20:19:19
gvfs;;inks;
да. мой косяк

089-pra09-sf10.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/089-pra09-sf10.pfs)
С ним работает
Gnome-keyring-3.14.0-sf01.pfs
Modemmanager-1.2.0-5-sf01.pfs
Networkmanager-gtk2-0.9.8.10-sf01.pfs
polkit-0.112-2.pfs
из pra03
+ надо nss-3.30.2-pra09-sf02.pfs
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: sfs от 19 Август 2019, 11:01:40
pulseaudio-10.0-gtk2-pra09-sf01.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/pulseaudio-10.0-gtk2-pra09-sf01.pfs)
pulseaudio-10.0-gtk3-pra09-sf01.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/pulseaudio-10.0-gtk3-pra09-sf01.pfs)
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: sfs от 19 Август 2019, 12:32:05
usb_modeswitch-static-2.5.2-2-i686.pkg.tar.xz (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra03/pra03-extra/usb_modeswitch-static-2.5.2-2-i686.pkg.tar.xz)
скомпилил свежий

gnome-ppp-pr-0.3.23-1-i686.pkg.tar.xz (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra03/pra03-extra/gnome-ppp-pr-0.3.23-1-i686.pkg.tar.xz)
gnome-ppp-gtk2-p-0.3.23-sf01.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/gnome-ppp-gtk2-p-0.3.23-sf01.pfs)
modem-pra09-sf01.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/modem-pra09-sf01.pfs)
проверить не на чем
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: sfs от 19 Август 2019, 17:55:11
sweep-audio-editor-gtk2-p-0.9.3-sf01.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra03/pfs-portable/sweep-audio-editor-gtk2-p-0.9.3-sf01.pfs)
mtpaint-gtk2-p-3.49.12-pr01.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra03/pfs/mtpaint-gtk2-p-3.49.12-pr01.pfs)
avidemux-qt5-2.6.19-pra09-sf01.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/avidemux-qt5-2.6.19-pra09-sf01.pfs)
connman-gtk3-1.1.1-pra09-sf05.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/connman-gtk3-1.1.1-pra09-sf05.pfs)
epdfview-gtk2-p-0.1.8-sf01.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/epdfview-gtk2-p-0.1.8-sf01.pfs)
gmtp-gtk3-1.3.10-pra09-sf01.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/gmtp-gtk3-1.3.10-pra09-sf01.pfs)
gnome-ppp-gtk2-p-0.3.23-sf02.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/gnome-ppp-gtk2-p-0.3.23-sf02.pfs)
netsurf-gtk2-3.10-3.dev-pra09-sf01.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/netsurf-gtk2-3.10-3.dev-pra09-sf01.pfs)
netsurf-gtk3-3.9-pra09-sf01.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/netsurf-gtk3-3.9-pra09-sf01.pfs)
vlc-qt5-3.0.4-pra09-sf01.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/vlc-qt5-3.0.4-pra09-sf01.pfs)
epdfview-gtk3-p-0.2.0-sf01.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/epdfview-gtk3-p-0.2.0-sf01.pfs)
transmission-gtk3-p-2.92-5-sf01.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/transmission-gtk3-p-2.92-5-sf01.pfs)

connman-qt4-pra09-sf03.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/connman-qt4-pra09-sf03.pfs)
Остальные проги qt4 подходят от DDR01
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: sfs от 22 Август 2019, 10:12:26
075-minirc-pra09-sf03.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/075-minirc-pra09-sf03.pfs) нерабочий
075-minirc-pra09-sf05.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/075-minirc-pra09-sf05.pfs)
И netctl там же
Осталось удалить из 001 eudev (больше в разы строго udev)
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: sfs от 22 Август 2019, 17:40:09
Осталось удалить из 001 eudev (больше в разы строго udev)
001-pra09-sf07.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/001-pra09-sf07.pfs) уже содержит minirc и netctl
075-orc-pra09-sf05.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/075-orc-pra09-sf05.pfs) пустышка. Можно удалить. Кому надо openrtc :075-orc-pra09-sf04 (я не планирую поддерживать)
089-pra09-sf11.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/089-pra09-sf11.pfs)
qt4-4.8.7-19-pra09-sf01.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/qt4-4.8.7-19-pra09-sf01.pfs)
Все что хотел по базе сделал . Осталось протестировать
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: krasnyh от 22 Август 2019, 18:20:49
001-pra09-sf07.pfs уже содержит minirc и netctl
Проверил, работает с minirc.


p.s. Также в pra09 присутствует vi (скрин). В ddr тоже есть, а в pra64 - нет.

Считаю, умение пользоваться этим минималистичным редактором очень полезно. Хотя его использование может показаться 'запутанным квестом',  :) но vi часто можно увидеть в разных небольших устройствах по умолчанию.
Например у себя в роутере, я раньше пересобирал прошивку ради nano (mc туда точно не влез бы :)), но все же решил не заморачиваться в очередной раз и слегка поднял навыки владения vi. )
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: arcad от 22 Август 2019, 19:09:22
Проверил, работает с minirc.
чета инет не работает, даже ping .
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: krasnyh от 22 Август 2019, 21:19:01
чета инет не работает, даже ping .
Да, что-то поломалось. Если сделать sudo dhcpcd, то сеть поднимается.
А команде ping ya.ru не хватает прав, через sudo запускается.
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: sfs от 23 Август 2019, 09:49:13
ping поправлю
Запускается net-auto из /etc/xdg/autostart
Он не поднимает сеть? может из-за ping
выложите sh -vx net-auto
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: krasnyh от 23 Август 2019, 10:40:02
выложите sh -vx net-auto
Скрин1.


Net-auto ведь сначала 'дергает' netctl? Если да, то там какая-то проблема с поднятием сети командами netctl (скрин2).
Если же запустить netctl.sh и поставить галочку на профиле ethernet-dhcp, то все ok.
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: sfs от 23 Август 2019, 10:59:30
netctl без systemd работает только list
Если есть профиль netctl, но он выкл. в /etc/rc.d сеть не должна подняться , т.к. вы ее выкл
Удалите профиль - net-auto попробует поднять проводной dhcp
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: krasnyh от 23 Август 2019, 11:14:50
Удалите профиль - net-auto попробует поднять проводной dhcp
Да, сеть поднялась.
В 001-pra09-sf07 лежит /etc/netctl/ethernet-dhcp. Получается он там лишний.
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: krasnyh от 23 Август 2019, 11:24:11
Возник вопрос.
Я когда удалил ethernet-dhcp, создал 090-save и перезагрузился, то в системе отсутствовал этот профиль. Здесь непонятно, в 090-save нет теней и информация о файлах вроде нигде не пишется?
Просто у меня сохранение в модуль и я в таких случаях кладу нужный файл в сохраненку и убираю у него все права. При перезагрузке он не читается или не выполняется.

upd. Есть тени, сразу не заметил. А можно тени вручную создать? Не знаю зачем, но интересно.  :)
Код
live@prar-1811 ..e+090-save-190823-pra09.pfs/etc/netctl % ls -la
итого 0
drwxr-xr-x 2 root root 40 авг 23 11:04 .
drwxr-xr-x 3 root root 61 авг 23 11:04 ..
-r--r--r-- 1 root root  0 авг 23  2019 .wh.ethernet-dhcp
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: sfs от 23 Август 2019, 11:40:58
в 090-save нет теней
Вроде в porteus-initrd я с подачи Дяди Шурика добавлял поддержку теней (т.е. можно удалить через 090)
кладу нужный файл в сохраненку и убираю у него все права
С исполняемыми так прокатит . С конфигами прог от рута - нет
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: sfs от 23 Август 2019, 11:41:34
можно тени вручную создать?
да. это обычный файл
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: sfs от 23 Август 2019, 11:56:35
089-de-lxqt-pra09-sf02.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/089-de-lxqt-pra09-sf02.pfs)
modem-pra09-sf02.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/modem-pra09-sf02.pfs)
smtube-qt5-19.6.0-pra09-sf01.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/smtube-qt5-19.6.0-pra09-sf01.pfs)
youtube-dl_any-sf05.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a64/pfs-portable/youtube-dl_any-sf05.pfs)
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: arcad от 23 Август 2019, 16:05:56
Если же запустить netctl.sh и поставить галочку на профиле ethernet-dhcp, то все ok.
Да, так заработала, только у меня уже в профиле галочка стоит, снят - поставил, служба заработала и ping  тоже
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: sfs от 23 Август 2019, 17:18:45
001-pra09-sf08.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/001-pra09-sf08.pfs)
089-pra09-sf12.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/089-pra09-sf12.pfs)
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: sfs от 23 Август 2019, 17:43:18
http://file.puppyrus.org/users/pra/iso/pra09-1908-i686-test3.iso
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: arcad от 24 Август 2019, 13:23:31
при загрузке после автологина вылетает сообщение
(http://)
надо от rootа наверное hwclock
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: krasnyh от 24 Август 2019, 13:55:52
надо от root а наверное hwclock
Да, сообщение об этом и говорит.

sudo hwclock --show   ###показать аппаратное время (в биосе)
date   ###показать системное время
Если выставлено локальное время, то вышеуказанное совпадает, если UTC - будет отличие на несколько часов.
В pra09 по умолчанию локальное.


при загрузке после автологина вылетает сообщение
Рабочий стол не грузится? У меня все ok c pra09-1908-i686-test3.iso, но я проверяю в вирте.
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: arcad от 24 Август 2019, 14:07:30
Рабочий стол не грузится?
грузится
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: krasnyh от 24 Август 2019, 15:16:31
У меня все ok c pra09-1908-i686-test3.iso, но я проверяю в вирте.
На реал. железе проверил, тоже нет никаких видимых :) проблем (PRA09 LXDE-gtk2.).
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: sfs от 27 Август 2019, 18:10:34
Gtk3-pra09-sf04.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/Gtk3-pra09-sf04.pfs)
001-pra09-sf09.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/001-pra09-sf09.pfs)
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: sfs от 28 Август 2019, 09:47:21
Никто не тестировал пра09 или все настолько хорошо?
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: sfs от 29 Август 2019, 09:51:34
надо от rootа наверное hwclock
Нет. Нужна задержка. Починил 089-pra09-sf14.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/089-pra09-sf14.pfs)

001-pra09-sf10.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/001-pra09-sf10.pfs)
удалил нерус. локали (http://forum.puppyrus.org/index.php?topic=19919.msg160860#msg160860)
Вот они :
glibc-locale-pra09-sf01.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/glibc-locale-pra09-sf01.pfs)
Перенес openssl-1.0 в
modem-pra09-sf03.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/modem-pra09-sf03.pfs)
Нужен только для wvdial

Вроде, все что хотел сделал. По ДЕ - по 1 шт. на каждый ТК есть. Остальные - в процессе
Надо еще какие-то?
По итогу планирую слить PRA03 и переделать по мелочи DDR01 (nm mpv локали)
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: sfs от 30 Август 2019, 09:05:28
Не прописан терминал в ФМ, по f4.
Какая ДЕ?
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: krasnyh от 30 Август 2019, 10:08:29
Какая ДЕ?
Всегда тестирую с первой строчкой menu.lst, но сейчас проверил все. Не прописан терминал в LXDE-gtk2 и LXDE-gtk2 + QT4, в ФМ.
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: Демьян от 30 Август 2019, 12:05:44
Код
live@pra09:~$ openoffice
bash: openoffice: команда не найдена
live@pra09:~$
inxi (https://yadi.sk/d/c11x1Jjrz4Re6g)
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: sfs от 30 Август 2019, 12:11:37
openoffice-p-4.1.2_64-ij01.pfs
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: krasnyh от 30 Август 2019, 13:11:25
bash: openoffice: команда не найдена
Поэтому лучше устанавливать через sfs-get (sfs-get openoffice), он скачает приложение именно для этой системы. Другое дело если для pra09 нет openoffice.


upd. Для sfs. посмотрел в https://mirror.yandex.ru/puppyrus/puppyrus-a/pra03/pfs/, там полно модулей с -p- (портированные). Наверно их надо перенести в /pra03/pfs-portable, тогда их будет показывать sfs-get из ddr и pra09? Или туда переносятся только проверенные универсальные модули, гарантированно работающие на разных системах?


Openoffice, заработает ли pra09, не знаю
https://mirror.yandex.ru/puppyrus/puppyrus-a/pra03/pfs/openoffice-p-4.1.3-ij01.pfs
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: sfs от 30 Август 2019, 13:49:13
туда переносятся только проверенные универсальные модули, гарантированно работающие на разных системах?
да. На ddr01 и пра09. пра03 сливаю
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: Демьян от 30 Август 2019, 14:57:16
Работающие в PRA09. i386:
doublecmd-gtk2-0.7.2-pr01.pfs (https://yadi.sk/d/dVg3n2BO7NxiEQ) файловый проводник по типу TotalComander в Wind.
firefox-bin-gtk3-p-69.0-pr01.pfs (https://yadi.sk/d/stkizRmfLLFpqw) с  10-mesa-libgl-10.6.4-1-i686.pfs (https://yadi.sk/d/F8pMdKx0_R-2tw), flashplugin-32.0.0.171.pfs (https://yadi.sk/d/MYrNTGaFqO_o8w), gtk3 в сборке (все в каталог optional). Запуск Firefox в терминале: sfs-get firefox)
seamonkey-2.49.3-sf01.pfs (https://yadi.sk/d/lUl-hvnTEkHYZQ) (показывает ютуб)
palemoon-bin-p-28.6.0-sf01.pfs (https://yadi.sk/d/emPcRrDf1gGkXQ) не русифицирован
geany-gtk2-1.30.1-pra09-sf01.pf (https://yadi.sk/d/_vx5CEE2eeJbeg) простой текстовый редактор с подсветкой кода
openoffice-p-4.1.2-ij01x32.pfs (https://yadi.sk/d/HT7u9qJiFuH6ww) работа с документами, таблицами
teamviewer-10.0.37742-s02.pfs (https://yadi.sk/d/344IIPiZpjGVdw) удаленный доступ, помощ
thunderbird-31.5.0.pfs (https://yadi.sk/d/w0yZ6V2zipdyLw) почтовый клиент с встроеными модулями icq, jabber, прочих
transmission-gtk2-ddr01-sf02.pfs (https://yadi.sk/d/5m9CfITDms0KHA) торент-закачка
deadbeef-p-0.7.0-2-sf07.pfs (https://yadi.sk/d/rxxWi4rXXjVvgA) музыка
mplayer-light-ext-p-37998-sf02.pfs (https://yadi.sk/d/z0vIehmkFepD7g) прстой видеопроигрывтель, запуск в терминале: sfs-get mplayer

djview-qt4-p-4.9-sf01.pfs (https://yadi.sk/d/ajTxHEczEsHo5A) чтение документов в формате djvu, вместе с зависимостью qt4-lib-4.8.6-3-i686-s01.pfs (https://yadi.sk/d/ZW0DEhdEtUL7SA) - в каталог optional, запуск в терминале: sfs-get djview
       


gparted-gtk2-0.28.1-pra09-sf01.pfs (https://yadi.sk/d/m4GdCu4MkLDCMw) (gtk2) редактор разделов на дисках
gparted-gtk3-1.0.0-pra09-sf01.pfs (https://yadi.sk/d/Y01sIF5q2Oh1xg) (этот, в отличии от gtk2, потребует подключать gtk3, который без автоподключения находится в optional)

gnome-ppp-gtk2-p-0.3.23-sf02.pfs (https://yadi.sk/d/sEkcxTnTOprKPQ) подключение юсб-модемов


нет filezilla

пример запуска программ из optional (или www-репозитария):
Код
sfs-get gnome-ppp
также для установки по с отслеживанием и докачкой зависимостей используется
Код
pacman2pfs.sh
pra09-1909-i686 + по, по списку выше.iso скачать (https://yadi.sk/d/BzWRTWFmetW2mg)
с ПО в /optional - запуск - щелчком по модулю, Подключить, - и все зависимости, если нужно, Подключить
или из терминала пример:
sfs-get gnome-ppp
Название: багрепорты
Отправлено: ШАМАНЯ от 30 Август 2019, 15:39:12
qmplay 18.12 qt5  не запускается в test2  и test3.  в терминале видно, что он требует  libass.so
в test1  работал
firefox 44 при запуске ютуба или повисает или начинает показывает и  крашится.
firefox 68.0.2  с офсайта работает , но ютуб без звука, надо будет попробовать с  apulse.

smplayer 19.5-qt4  работает и в mimi и  pra09, но только с  mpv+youtube-dl.
с mplayer ютуб не показывает пишет ошибка и там и там.
так и должно быть
нет, должно показывать!
из smtube если открывать видео в  mplayer - то показывает всегда , в  smplayer  через mplayer  не показывает или показывает только первый раз, после перемотки пишет ошибка. если их потом закрыть, потом  smtube  запустить и несколько раз пробовать те же видео, то иногда начинает показывать, и опять при перемотке останавливается с ошибкой.
smtube не показывает видео юс ютуба в своём окне! а в  убунту показывает!
надо разбираться с  smtube!
slimjet 19.1 запустился после добавления  nss-3.30, но ютуб не показывает, кнопка красная в центре и за ней крутится белая полоска. Ругается что недоверенное соединение и нужно нажимать - дополнительно и  тогда уже переходить на ютуб.
Но после этого перестаёт работать  питон 2.7, и далее по цепочке не работает  youtube-dl, mpv  и  smplayer через mpv.
для  vlc 2.х  qt4 нужно  gnutls-3.5,после его установки через pacman, уже по другому. после этого он не может открыть  страницу -  в терминале пишет http access error ,  если подключить  firefox 44, уже может подключиться, но теперь пишет  не могу открыть
кодек  h264 part 10   ,    подключение ffmpeg 2.8 не помогает.
Это же способ в  pra 1808-fat - временно помог  и  vlc 2.2.6-5 показывал ютуб, собранный из реп. в  /etc/pacman.d/mirrorlist:
Server=http://archive.archlinux.org/repos/2017/11/14/$repo/os/$arch
но после перезагрузки, собранный модуль опять в пра1808 не работает, а в пра9 - сказано выше.
FBReader 0.12.200  из ubuntu, который в mimi,  не запускается, требует  curl.so.4
CoolReader3 из ubuntu, который в mimi, работает.
wine Kron4ek не запускается, в терминале говорит про GLIB-2.27
работает wine-2.19-staging ,  собранный в  pra1808fat
tor-browser-8 не  запускается, а  7.5  из  puppy presice работает, но в ней  noscript устарел и он отключен, и если не отключить обновление, он обновится до 8-й версии и перестаёт работает.
test 3  после распаковки на две разные флешки не запускается, ждёт 5 секунд а потом голубыми буквами сообщение, Что файлы не удалось найти, и если на диск  sda1  распаковать из iso - точно также.
А  test1 работал!
флешка  с test3, записанная через dd загрузилась на 64-х битном пк, а на 32-х битном зависает в самом начале после надписи  syslinux.
Такая же ошибка наблюдается при  записи флешек новым  unetbootin 6.61 - на старых 32-х битных  компах не грузятся разные линуксы, не только пра , а и убунту и др. Старый  unetbootin 6.08 записывал флешки по другому, и они грузились.
Из-за этого  не получается обновить pra.
Буду пробоват новую пра.

Upd.
VirtualBox 5.0 - 4.4.1 из  pra1808fat при загрузке с ядром  4.4.1 работает.
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: sfs от 30 Август 2019, 15:47:17
pra09-1909-i686.iso
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: sfs от 30 Август 2019, 16:21:38
Не прописан терминал в ФМ, по f4.
089-de-lxde_gtk2-pra09-sf03.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/089-de-lxde_gtk2-pra09-sf03.pfs)
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: sfs от 02 Сентябрь 2019, 10:24:03
В самой свежей пра09  qmplay 18.12-qt5 не запускается!
Там с ssl проблемы. Я ssl1.0 вынес в modem*.pfs , а оказывается ffmpeg он нужен. По идее все плееры должны не работать
Подумаю как решить
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: sfs от 02 Сентябрь 2019, 17:37:35
Я ssl1.0 вынес в modem*.pfs , а оказывается ffmpeg он нужен
И qt5 тоже
В итоге
030-qt5-pra09-sf04.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/030-qt5-pra09-sf04.pfs)
добавил. С ssl1.1 только qt5.10

Закомпилил
ffmpeg-light-p-3.1-sf05.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/ffmpeg-light-p-3.1-sf05.pfs) на самом деле там 3.4.6 . DEV часть добавил в DEVX
gnome-mpv-gtk3-0.16-pra09-sf02.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/gnome-mpv-gtk3-0.16-pra09-sf02.pfs)
mpv-light-ext-p-0.27.0-sf01.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/mpv-light-ext-p-0.27.0-sf01.pfs)
qmplay2-qt5-19.08.27-pra09-sf01.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/qmplay2-qt5-19.08.27-pra09-sf01.pfs)
smplayer-qt5-19.5.0-pra09-sf01.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/smplayer-qt5-19.5.0-pra09-sf01.pfs)
Все должно само автообновиться
Прошу протестировать. По итогу перезалью iso

В DDR01 тоже работает (кроме qt5). Есть мысли поколдовать там с 001. Поэтому модули в pra09 , а не в portable
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: ШАМАНЯ от 03 Сентябрь 2019, 12:47:03
И снова ЛЭВЭЛАП!
Новая пра09 с флешки запускается без  дд, простой распаковкой исо!

qmplay 18.12  и 19.08.27 запускаются!
ютуб показывают, НО нужно  создать ссылку с именем
python  на файл python 2.7 в папке /usr/bin
Если подключить youtube-dl, то там скрипт python длиной 165 мешает!
 и qmplay перестаёт работать. После отключения снова работает!
надо переделывать модуль youtube-dl!

А gnome-mpv крашится при запуске видеофайлов или ютуба.

остальные программы из пред.сообщения работают!
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: sfs от 03 Сентябрь 2019, 13:08:37
Новая пра09 с флешки запускается без  дд, простой распаковкой исо!
Если UEFI - то это уже несколько лет так и никаких изменений
Если подключить youtube-dl, то там скрипт python длиной 165 мешает!
Он как раз и подставляет python  на файл python 2.7
Т.е. с mpv так работает, а с qmplay нет?
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: ШАМАНЯ от 03 Сентябрь 2019, 13:21:03
да, при поключении  youtube-dl  - плэйеры qmplay 18 и 19 перестают работать, окно появляется и ищет на ютубе, но не показывает,  но начинает работать   mpv с ютубом в терминале!
Зато ютуб в  smplayer сейчас можно смотреть  с mpv и без  youtube-dl!
Но будет ограничение на качество видео(до 720-1080p), а потом, когда гугл поменяет формат доступа к ютуба, опять перестанет, и тогда можно будет смотреть только с  youtube-dl.
VLC 2..х по прежнему не работает! - и  он не использует  youtube-dl.
VLC 3   ютуб  показывает!   
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: sfs от 03 Сентябрь 2019, 13:28:19
Зато ютуб в  smplayer сейчас можно смотреть  с mpv и без  youtube-dl!
да ладно... и без smtube?
VLC 2..х по прежнему не работает! - и  он не использует  youtube-dl.
В отдельной теме про это решения не нашел
А надо ли так много youtube плееров...
при поключении  youtube-dl  - плэйеры qmplay 18 и 19 перестают работать,
Вероятно они юзают /usr/bin/python
Можно попробовать перенести скрипт из /usr/bin/local
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: sfs от 03 Сентябрь 2019, 18:24:43
youtube-dl_any-sf07.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra03/pfs-portable/youtube-dl_any-sf07.pfs)
В скрипте мешали &. Теперь норм с qmplay
python2-d8-ssl10-p-2.7-sf02.pfs (ftp://ftp.yandex.ru/puppyrus/ddr/ddr01/pfs-test/python2-d8-ssl10-p-2.7-sf02.pfs)
Из deb8 поменьше - прошу протестировать этот
Для pra09 заменить либу _ssl.i386-linux-gnu.so под ssl11
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: ШАМАНЯ от 03 Сентябрь 2019, 21:17:44
да, теперь  qmplay и  youtube-dl  подружились :)
надо в исо в  /EFI/BOOT/grub.cfg исправить, там от ддр остались строки, вместо них хотя-бы один пункт для загрузки пра:
Код
menuentry "PRA-09  без загрузки в RAM и сохранения. Рекомендуется при < 512Mb RAM." {
linux /pra09/vmlinuz-4.4.1-pf3 quiet dir=pra09
initrd /pra09/initrd.xz
}

 ещё в убунту встречался  minimal-python, может подойдёт. размер надо смотреть.

Получилось установить графический редактор  Krita 3.1.4  - аналог  Photoshop, на первый взгляд работает!
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: sfs от 04 Сентябрь 2019, 09:11:37
в  /EFI/BOOT/grub.cfg исправить
ок
в убунту встречался  minimal-python, может подойдёт
его и использую
спасибо за тесты +
Получилось установить графический редактор  Krita 3.1.4 
выложите модуль
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: sfs от 04 Сентябрь 2019, 10:33:35
Для pra09 заменить либу _ssl.i386-linux-gnu.so под ssl11
Не прокатило. Остаемся на питоне от деб9
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: sfs от 04 Сентябрь 2019, 11:08:19
pra09-1909b-i686.iso
Перезалил с обновлением модулей ffmpeg и зависимых
Кто ставил pra09-1909 - достаточно автообновиться
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: ШАМАНЯ от 04 Сентябрь 2019, 21:14:06

Получилось установить графический редактор  Krita 3.1.4 
выложите модуль
мне неудобно, он здоровый - 92 Мб, его легко сделают без всяких хитростей, кому будет нужен.
Рецепт для новичков:
В меню - программирование - поиск софта и создание модуля, набрать  krita потом название krita
 появится выбрать его,
выбрать - создать модуль, потом черное окно, нажать enter и ждать.
потом в мелком окне будет вопрос - сжать в модуль, - да и ждать, потом из домашней папки перенести в  modules. ВСЁ!   И перезагрузить.
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: sfs от 09 Сентябрь 2019, 09:57:05
Работающие в PRA09. i386:
Зачем перезаливали на яндекс? Что-то изменяли?
palemoon-bin-p-28.6.0-sf01.pfs не русифицирован
В репе есть свежее
Русификация в профиле (083*.pfs)
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: Демьян от 10 Сентябрь 2019, 16:44:17
Зачем перезаливали на яндекс? Что-то изменяли?
нет, скачивал с репозитория puppy, пробовал на производительность, какой файл с какого каталога скачал найти сложно. pra09....iso отредактировал ISOMaster - добавил работающие pfs и в таком виде залил на яндекс. Ссылки на ПО лучше указать на первоисточники, но я не ориентируюсь в каталогах
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: sfs от 30 Сентябрь 2019, 09:39:40
Если переносите тему, так и напишите!
Что за привычка пошла переносить тему никого не уведомляя!?
Я про обсуждение оперы, еле нашёл после ваших телодвижений тему!
Жмите всегда "Новые сообщения с последнего визита." Ничего не пропустите
Кроме того можно найти через свои сообщения  (в своем профиле)
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: sfs от 08 Октябрь 2019, 17:39:26
pra09-1910-i686.iso (http://file.puppyrus.org/users/pra/iso/pra09-1910-i686.iso)
Исправлена проблема с wpa_supplicant (wi-fi) в модуле 001
Добавлены переработанные и обновленные модули DE-openbox+tint2
Изменены браузеры : palemoon (gtk2) ; chromium (gtk3)
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: Демьян от 11 Октябрь 2019, 18:45:14
работает, нравится (https://yadi.sk/d/dP3CbbDqLNqk-w)
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: yxma от 05 Ноябрь 2019, 16:25:01
1910 попробовал на старом ядре. Система работает весело, но либру не то что установить, но и подключить не удалось - вспыхивает заставка, на этом удовольствие заканчивается. Ругается на отсутствие модуля libavahi. Обычно чего не хватает сразу предлагается загрузить, но тут даже название скопировать из сообщения невозможно. Задумался над тем, чтобы вернуться к 6408-01. Новое - злейший враг хорошего )
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: krasnyh от 05 Ноябрь 2019, 16:46:15
Еще бы.
Запускал на первом DE. Скрин.


Задумался над тем, чтобы вернуться к 6408-01. Новое - злейший враг хорошего.
Не надо торопиться с выводами. Pra09 свежая система, толком необкатанная. Наоборот, надо ее больше юзать и выкладывать сюда выявленные баги.


p.s. Если что-то не копируется, то всегда можно сделать скриншот и прикрепить к сообщению. Меню - Графика -Сделать снимок, выбрав в проге - "выделить область экрана". Или нажав Print на клавиатуре.
Скрин2.

Для sfs, отсутствует хоткей 'Print' в openbox/rc.xml (первый DE, на других не проверял).
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: sfs от 06 Ноябрь 2019, 13:00:51
либру не то что установить, но и подключить не удалось
добавил
отсутствует хоткей 'Print' в openbox/rc.xml
поправил
089-pra09-sf18.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a/pra09/pfs/089-pra09-sf18.pfs)
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: krasnyh от 06 Ноябрь 2019, 15:06:59
добавил
Т.е. достаточно было положить две libavahi в 089-pra09-sf18, чтобы все заработало? Не смотря на то, что dep-find показал кучу недостающих либ?
Как так-то?  :)
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: sfs от 06 Ноябрь 2019, 15:32:33
достаточно было положить две libavahi в 089-pra09-sf18, чтобы все заработало
Проверял только на старт
dep-find показал кучу недостающих либ?
запустите dep-find -f - покажет, каким файлам они были нужны. Возможно, это что-то неиспользуемое
Название: Re: PRA09. i386 сборка на репозитории Hyperbola
Отправлено: krasnyh от 06 Ноябрь 2019, 16:51:48
dep-find -f - покажет, каким файлам они были нужны.
Понятно почему можно не удовлетворять зависимости для libvclplug_kde4lo.so, libvclplug_kde4lo.so. На работу libreoffice в данном DE это не скажется.

Менее понятно как будет работать без удовлетворения зависимостей для libavmediagst.so, libavmediagst_0_10.so. Но на запуск это не влияет.

И очень многое из python-core-3.5.7/lib/lib-dynload/ требует libpython3.5m.so.1.0.
Но, повторюсь, на запуск это не влияет.

Итог.
Получается, по факту, чтобы запустился libreoffice достаточно двух либ libavahi из множества отсутствующих.
(Прикрепил вывод команды dep-find -f, если кому будет интересно.)