Форум проекта PuppyRus Linux

Дистрибутивы проекта PuppyRus Linux => PuppyRus-A [PRA] => Тема начата: sfs от 28 Декабрь 2018, 18:00:13

Название: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 28 Декабрь 2018, 18:00:13
PRAR1801 переименовываю в PRA64 и позиционирую как фругал с длительной поддержкой
7 тем оформления и 11 DE в любых комбинациях

XFCE (http://forum.puppyrus.org/index.php?topic=20047.0)
LXQT (http://forum.puppyrus.org/index.php?topic=20136.msg136086#msg136086)
OLS (openbox lxpanel spacefm) (http://forum.puppyrus.org/index.php?topic=20176.msg136504#msg136504)
LXDE-gtk2 (http://forum.puppyrus.org/index.php?topic=18458.msg116647#msg116647)
tint2-graph (http://forum.puppyrus.org/index.php?topic=20442.0)
Mate (http://forum.puppyrus.org/index.php?topic=17167.msg146312#msg146312)
OVS (http://forum.puppyrus.org/index.php?topic=21025.0)(Openbox Vala-panel Spacefm)
IceWm (http://forum.puppyrus.org/index.php?topic=22055.msg161231#msg161231)
JWM (http://forum.puppyrus.org/index.php?topic=17646.msg110032#msg110032)
KDE3 (http://forum.puppyrus.org/index.php?topic=21803.msg158207#msg158207)
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: ramd от 29 Декабрь 2018, 00:33:38
Железо другое.
Уточню: сам тачпад работает, не работают тапы на нём, что ОЧЕНЬ неудобно. Приходится 2й рукой по кнопкам давить.
В 180101 тапы работают, но там другие косяки...(
Инкси в терминале выдало ошибку перл. Устал разбираться.

Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: arcad от 29 Декабрь 2018, 01:13:25
где multiload ? графики ресурсов -проца и памяти добавить можно, а вот мониторинга сети нет
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 29 Декабрь 2018, 09:52:58
Инкси в терминале выдало ошибку
089-prar-upd-180101-sf42.pfs (ftp://ftp.yandex.ru/puppyrus/roll/180101/089-prar-upd-180101-sf42.pfs)
Устал разбираться.
Отдохните. Сообщество разберется и Вам доложет , когда можно подтянуться на готовенькое

В исо pulseaudio-11.1-1-180101-sf01.pfs надо переименовать в
 pulseaudio-gtk2-11.1-1801-sf02.pfs (ftp://ftp.yandex.ru/puppyrus/roll/180101/pulseaudio-gtk2-11.1-1801-sf02.pfs)
и pidgin-light-gtk2-2.12.0-2-1801-sf02.pfs (ftp://ftp.yandex.ru/puppyrus/roll/180101/pidgin-light-gtk2-2.12.0-2-1801-sf02.pfs)

Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: ramd от 29 Декабрь 2018, 13:24:59
Вчера правда устал, ночью уже писал...
Насчет тачпада - у меня не заработали тапы на OLS (на 180101 работают), а по ссылке - под XFCE
Может потому, что запускаю по старинке - переписываю с исо на хард папку pra64 и правлю menu.lst, который теперь стал очень запутаным и сложным для чтения. Как правильно делать?
Сижу пока на пра64-1709, там всё как-то постабильнее...
Там работает САС-Планета под старым 1.9 вайном - а в ролле - не работает
В 1709 работает AppImage, в ролле - нет
Отсюда вот и некоторая печаль...)

PS
Небольшой отчётик - палемун 28.2.2 стал нормально работать с кнопками в яндекс-деньгах и других сервисах (в ранних версиях кнопки не нажимались, теперь работают)

PSS
Сейчас ещё заметил, что не работает ждущ режим при закрытии крышки ноута.
Во всех ролл-дистрах, драйвера везде linux-firmware-light-171204_any-sf01.pfs
Если через меню выключения - то срабатывает.

Сделал вывод инкси
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 30 Декабрь 2018, 11:44:22
тачпад работает, не работают тапы на нём
не работает ждущ режим при закрытии крышки ноута.
089-prar-upd-180101-sf45.pfs (ftp://ftp.yandex.ru/puppyrus/roll/180101/089-prar-upd-180101-sf45.pfs)
И для прар1811
089-prar-upd-1811-sf06.pfs (ftp://ftp.yandex.ru/puppyrus/roll/1811/089-prar-upd-1811-sf06.pfs)
Забыл /etc/X11/xorg.conf.d/50-synaptics.conf

Модули вроде 1801, почему система 1811, и заморозка 1811? будут нестыковочки? 
мой косяк. фикс:
089-prar-upd-180101-sf45.pfs (ftp://ftp.yandex.ru/puppyrus/roll/180101/089-prar-upd-180101-sf45.pfs)

где multiload ?
040-de-ols-gtk2-180101-sf15.pfs (ftp://ftp.yandex.ru/puppyrus/roll/180101/040-de-ols-gtk2-180101-sf15.pfs)
arcad - спасибо за отчеты +

переписываю с исо на хард папку pra64 и правлю menu.lst, который теперь стал очень запутаным и сложным для чтения. Как правильно делать?
Так правильно. По дефолту загрузится самая маленькая DE (замените в /base *-de-*.pfs и 03*.pfs на нужные) с самым маленьким оформлением (замените в /base 084*pfs)

В 1709 работает AppImage, в ролле - нет
Можно подробнее?
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: RoDoN от 30 Декабрь 2018, 15:32:20
тачпад работает, не работают тапы на нём
089-prar-upd-180101-sf45.pfs (ftp://ftp.yandex.ru/puppyrus/roll/180101/089-prar-upd-180101-sf45.pfs)
В XFCE тап заработал, а в MATE - нет.
В LXQT почему-то очень долго тупит запуск mc, долго висит черное окно терминала, хоть из меню, хоть в терминале :( Да вообще все в LXQT у меня почему-то жутко тупит по сравнению с XFCE или MATE.
Не понятно зачем в LXQT PCManFM и SpaceFM одновременно?
Почему-то в этой сборке в ФМ (Тунар, PCManFM) огромные значки - зачем? Раньше такого не было.
Не понятно почему в хомяке есть каталоги рута? Вроде-бы в /home/live все файлы и каталоги должны быть с правами live (или users) или я чего-то не понимаю?

Очередной раз выскажу мнение, что большой выбор не настроенных DE не есть хорошо, имхо, но лучше меньше, да лучше. 
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: ramd от 30 Декабрь 2018, 15:56:30
в OLS тап заработал, спасибо.
Ждущий режим при закрытии крышки всё равно не работает. Помню в 64-1709 тоже такое было, лечил где-то р районе etc/acpi/handler.sh но как именно - не помню уже.
А общее впечатление от дистра пока положительное.
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 30 Декабрь 2018, 16:03:33
В XFCE тап заработал, а в MATE - нет.
Знаешь как починить?

В LXQT почему-то очень долго тупит запуск mc
Бывает когда сеть не настроена. Настроена?
XQT у меня почему-то жутко тупит по сравнению с XFCE или MATE.
У всех так?

Не понятно зачем в LXQT PCManFM и SpaceFM одновременно?
SpaceFM-gtk3 нужен только в OVS. Отдельно - чтобы можно было заменить на другой
Прописывать noload= не хотелось бы. Объединить с OVS?

Почему-то в этой сборке в ФМ (Тунар, PCManFM) огромные значки - зачем?
Специально не делал. Почему так не знаю. Помогайте разобраться

Не понятно почему в хомяке есть каталоги рута?
Какие?

Вроде-бы в /home/live все файлы и каталоги должны быть с правами live
Да. За исключением nobody - это отдельная костыльная история

Очередной раз выскажу мнение, что большой выбор не настроенных DE не есть хорошо, имхо, но лучше меньше, да лучше. 
Ну так удалить просто
Может кто доведет. Или что ты предлагаешь?
Этот дистр планирую долгоиграющим - как пра03

Ждущий режим при закрытии крышки всё равно не работает
089 обновление стоит? Галка в power.sh (пуск - настр. - упр. пит) стоит?
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: RoDoN от 30 Декабрь 2018, 17:03:17
Знаешь как починить?
http://forum.puppyrus.org/index.php?topic=21225.msg151478#msg151478
Бывает когда сеть не настроена. Настроена?
Странно, а в чем связь старта mc и настройки сети?
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: ramd от 30 Декабрь 2018, 17:04:14
Галки в настройках стоят. 089 есть.
После входа в настройки питания и нажатия ОК ждущ. режим начинает работать.
При нажатии на больш кнопку "Кнопки питания, сна, крышка" появляется уведомление
"Вы используете acpid а не systemd" -- ?
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: krasnyh от 30 Декабрь 2018, 18:17:40
Цитата
xsri: error while loading shared libraries: libpopt.so.0
Если конечно кто-то еще, кроме меня :), использует обои без 20-desktop.desktop.
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 30 Декабрь 2018, 19:14:45
http://forum.puppyrus.org/index.php?topic=21225.msg151478#msg151478
торможу
При нажатии на больш кнопку "Кнопки питания, сна, крышка" появляется уведомление
"Вы используете acpid а не systemd" -- ?
Ну так ведь именно так у Вас и есть
20-desktop.desktop.
Вроде везде переделано на icewm обои, т.е. xsri больше не используется
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: krasnyh от 30 Декабрь 2018, 19:19:32
т.е. xsri больше не используется
Странно, что у меня обои появились после установки libpopt.so.0 в систему. :)
040-de-ols
Код
cat ~/.config/autostart/wallpaper.desktop
Exec=sleep.sh 8 wallpaper
Соответственно в /usr/local/bin/wallpaper только xsri.
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 30 Декабрь 2018, 19:36:12
у меня обои появились после установки popt в систему
089-prar-upd-180101-sf46.pfs (ftp://ftp.yandex.ru/puppyrus/roll/180101/089-prar-upd-180101-sf46.pfs)
убрал xsri (не универсально - gtk2)
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: krasnyh от 30 Декабрь 2018, 19:39:19
089-prar-upd-180101-sf46.pfs
А можно сразу перезаливать iso? Так удобней проверять в виртуалке уже с исправлениями.
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 30 Декабрь 2018, 19:44:56
Думаю - часто плохая идея. После более тщательного тестирования
Распакуйте у себя исо и пересоберите с обновлениями
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: krasnyh от 30 Декабрь 2018, 23:10:30
убрал xsri (не универсально - gtk2)
В универсальность это хорошо, но это теория. На практике эта новинка у меня нигде не заработала. Ни на pra-roll-1806-gtk3-02, и ни на pra6408-01.
Код
live@pra-roll ..089-prar-upd-180101-sf46.pfs/home/live/.config/autostart % cat wallpaper.desktop
[Desktop Entry]
Type=Application
Icon=desktop
Name=Обои
Comment=Обои (когда не используется раб.стол файл-менеджера или WM)
Exec=sleep.sh 4 icewmbg.sh "/usr/share/backgrounds/default.svg" "#202427"
Увеличение задержки (sleep.sh 10) не именило ничего.
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: krasnyh от 31 Декабрь 2018, 01:27:15
icewmbg: not found
Положил icewmbg в /usr/bin, перезагрузил иксы. Работает, обои есть.
(pra6408)

upd. Взял icewmbg.sh из pra6408 в 1806-gtk3, с заменой. Вроде и там обои заработали. )
Цитата
/usr/local/bin/icewmbg.sh
#!/bin/ash
#181202 sfs
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 31 Декабрь 2018, 08:10:37
icewmbg: not found
Добавлю в 089
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: RoDoN от 01 Январь 2019, 16:29:24
В tint-gtk2 есть в меню SpaceFM-root, но ничего не открывается, т.к. реально SpaceFM нет, в связи с этим в меню не работают Дом->...->Открыть в ФМ... и зачем они тогда в меню ;)
В tint-gtk3 есть в меню SpaceFM-root, который опять же ничего не открывает, но по др. причине:
Код
live@pra6408:~$ spacefm
spacefm: error while loading shared libraries: libstartup-notification-1.so.0: cannot open shared object file: No such file or directory
Но, что странно из меню SpaceFM запускается, а из терминала - нет, мистика какая-то ???

И опять хочу спросить почему жутко тормозит запуск mc, если не настроена сеть? В чем связь???
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: krasnyh от 01 Январь 2019, 16:41:12
spacefm: error while loading shared libraries: libstartup-notification-1.so.0
В 1806-gtk3 (089-de-tint2g-gtk3) самостоятельно доустанавливал startup-notification-0.12-5, тоже что-то не запускалось.
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 01 Январь 2019, 19:05:47
В tint-gtk2 есть в меню SpaceFM-root, но ничего не открывается, т.к. реально SpaceFM нет,
У меня нет
в меню не работают Дом->...->Открыть в ФМ...
Там есть самодельный filestarter -  псевдо ФМ (скрипт на yad)
startup-notification
089-prar-upd-180101-sf47.pfs (ftp://ftp.yandex.ru/puppyrus/roll/180101/089-prar-upd-180101-sf47.pfs)

089-de-tint2g_gtk2-p_64-sf08.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a64/pfs-portable/089-de-tint2g_gtk2-p_64-sf08.pfs)
089-de-tint2g_gtk3-p_64-sf17.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a64/pfs-portable/089-de-tint2g_gtk3-p_64-sf17.pfs)

почему жутко тормозит запуск mc, если не настроена сеть? В чем связь???
Я не уверен, что эта связь есть. Если есть - вероятно из-за недоступности днс
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: krasnyh от 01 Январь 2019, 19:25:48
089-de-tint2g_gtk3-p_64-sf17.pfs
Spacefm запускается, sudo spacefm - ошибка:
Код
% sudo spacefm
spacefm: error while loading shared libraries: libstartup-notification-1.so.0: cannot open shared object file: No such file or directory
Менял только de-tint2g_gtk3-p_64-sf17 (prar1806).

доустанавливал startup-notification-0.12-5
Убрал.
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 01 Январь 2019, 19:28:13
    startup-notification
089-prar-upd-180101-sf47.pfs
prar1806 больше не поддерживается
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: krasnyh от 01 Январь 2019, 19:31:41
prar1806 больше не поддерживается
Я это прекрасно знаю. Думал фиксы были внесены в de-tint2g_gtk3-p_64-sf17, все таки это портированный модуль и не зависит от версии PRA.

upd. Верну тогда startup-notification-.
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: RoDoN от 01 Январь 2019, 20:17:51
У меня нет
Согласен, это не SpaceFM, в меню есть пункт "Просмотр файловой системы", который был с красным значком, поэтому ошибочно принял за SpaceMF-root, так вот этот пункт ничего не запускает, а создает его файл /usr/local/share/applications/defaultfilemanager.desktop
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: krasnyh от 01 Январь 2019, 20:31:37
089-de-tint2g_gtk3-p_64-sf17.pfs
Еще немного замечаний. :) 
Надо ли делать отдельные настройки в /root? Вроде раньше просто делались ссылки на конфиги в /home/live.

 Пример --> 089-de-tint2g-gtk3-p_64-sf07 (prar1806) и 089-de-tint2g_gtk3-p_64-sf17 (pra6408):
Код
live@pra-roll ..+089-de-tint2g-gtk3-p_64-sf07.pfs/root % sudo ls -l **/*
lrwxrwxrwx 1 root root 26 апр  5  2018 ./.config/dunstrc -> /home/live/.config/dunstrc

./.config:
итого 0
lrwxrwxrwx 1 root root 26 апр  5  2018 dunstrc -> /home/live/.config/dunstrc
drwx------ 2 root root 38 ноя 28 21:05 lxterminal

./.config/lxterminal:
итого 0
lrwxrwxrwx 1 root root 45 апр  5  2018 lxterminal.conf -> /home/live/.config/lxterminal/lxterminal.conf
Код
live@pra-roll ../089-de-tint2g_gtk3-p_64-sf17.pfs/root % sudo ls -l **/*           :(
-rw-r--r-- 1 live root  10974 дек 26 16:49 ./.config/dunstrc
-rw-r--r-- 1 live live    401 дек 27 13:32 ./.config/gtk-3.0/settings.ini
-rw-r--r-- 1 live live    566 дек 26 13:16 ./.gtkrc-2.0

./.config:
итого 11
-rw-r--r-- 1 live root  10974 дек 26 16:49 dunstrc
drwxr-xr-x 2 live users    35 янв  1 11:23 gtk-3.0
drwx------ 2 root root     38 янв  1 11:24 lxterminal

./.config/gtk-3.0:
итого 1
-rw-r--r-- 1 live live 401 дек 27 13:32 settings.ini

./.config/lxterminal:
итого 2
-rw------- 1 live live 1359 ноя 13  2017 lxterminal.conf
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 02 Январь 2019, 07:22:39
Надо ли делать отдельные настройки в /root?
С точки зрения удобства - удобнее ссылки
С точки зрения безопасности - это дыра

Думал фиксы были внесены в de-tint2g_gtk3-p_64-sf17, все таки это портированный модуль и не зависит от версии PRA.
Ну так spacefm в этих модулях нет

в меню есть пункт "Просмотр файловой системы", который был с красным значком, поэтому ошибочно принял за SpaceMF-root, так вот этот пункт ничего не запускает, а создает его файл /usr/local/share/applications/defaultfilemanager.desktop
У меня в нем Hidden=true
Это была попытка универсализировать через defaultfilemanager
Сейчас, наверное, не актуально
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 02 Январь 2019, 11:32:00
089-prar-upd-180101-sf48.pfs (ftp://ftp.yandex.ru/puppyrus/roll/180101/089-prar-upd-180101-sf48.pfs)
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 06 Январь 2019, 11:22:28
lxqt_gtk2-p_64-sf03.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a64/pfs-portable/lxqt_gtk2-p_64-sf03.pfs)
lxqt_gtk3-p_64-sf03.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a64/pfs-portable/lxqt_gtk3-p_64-sf03.pfs)
Забыл положить в исо

Поправил автомонтирование флэщек
089-prar-upd-180101-sf49.pfs (ftp://ftp.yandex.ru/puppyrus/roll/180101/089-prar-upd-180101-sf49.pfs)
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: nik152 от 12 Январь 2019, 17:41:39
LXDE - не работает клавиатурное переключение раскадки. В строке файла
/.config/lxpanel/LXDE/pannels/panel
добавил grp: - ToggleOpt=grp:alt_shift_toggle - теперь переключается.
С другими DE ещё не проверял
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: nik152 от 18 Январь 2019, 10:41:40
Mate - не регулируются яркость и громкость. Не активны кнопки Выключения и Блокировки экрана. Перезагружался из комстроки.
OVS - нет русской раскладки клавиатуры. FileStarter - это что-то...
А мой выбор - LXDE с PCManFM.
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 18 Январь 2019, 11:04:33
FileStarter - это что-то...
Он только для тех , кто юзает mc  :D
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: betcher от 20 Январь 2019, 20:41:37
Подскажите, какие нужно подключить модули и что написать в cmdline ядра, чтоб pra с системд загрузился?
ДЕ не принципиально. А то что не пробую системд нету, а мне надо :)
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: krasnyh от 20 Январь 2019, 20:51:19
ДЕ не принципиально. А то что не пробую системд нету, а мне надо
Обязательно именно PRA6408-01? Просто он построен с minirc.
С systemd --  roll-1811-lx-02; roll-1811-gtk3-01 (в шапке форума).
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: betcher от 20 Январь 2019, 20:54:38
Ах вот в чем дело :)))
Стоп, а где тогда хук с шатдауном работает? Тоже в ролл?
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: krasnyh от 20 Январь 2019, 20:55:56
Просто он построен с minirc
Код
% pfspkg 001-prar-c-180101-sf14.pfs |grep minirc
minirc-git
minirc-pra
Раньше minirc и systemd были в виде отдельных модулей, их можно было легко менять местами. Сейчас не знаю.
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: DdShurick от 20 Январь 2019, 20:56:44
что написать в cmdline ядра
Ничего, сам найдёт. linuxrc строка 647:
Код
cp -f /union/lib/systemd/systemd /bin/init 2>/dev/null && echo $i"обнаружен systemd" || cp -f /bin/busybox /bin/init 
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: krasnyh от 20 Январь 2019, 20:57:40
Стоп, а где тогда хук с шатдауном работает? Тоже в ролл?
Не знаю что это :), но скорее всего да. Если речь идет о хуках - это roll. )
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 21 Январь 2019, 10:45:56
где тогда хук с шатдауном работает?
В прар1811-gtk3 (в исо)
Если речь идет о хуках - это roll
Этот (как и любой другой инитрд можно прикрутить к любому линуксу

075-systemd можно подключать к любому пра
Если даже minirc в 001 - он не помешает.

Ничего, сам найдёт. linuxrc строка 647:
Это из другого инитрд - портеус
init= нигде не указываю
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: knn от 22 Февраль 2019, 16:20:23
вроде во всех 089-upd....sfs  почему-то есть /home/live/.gtkrc-2.0 - с прописанной в нём темой-ГТК.
 Т.к. номера модулей тем - 084-.... => другие Темы "со старта не подхватываются."
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: krasnyh от 22 Февраль 2019, 18:14:34
Т.к. номера модулей тем - 084-.... => другие Темы "со старта не подхватываются."
Но в модулях 084- отсутствует /home/live/.gtkrc-2.0, так что проблема наверно не в этом?
Какая-то своя тема?
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: knn от 22 Февраль 2019, 18:49:43
/home/live/.gtkrc-2.0 присутствует навскидку в : 084-theme-vertex_any-ij01, 084-theme-ivy_any-sf08, 084-Theme-faenza-j01, 084-Theme-almost-160425-ij20.
  Может сейчас что и по-новому, но тогда как по-задумке применять недефолтные Темы "на старте"/при первоначальной загрузке? (конечно можно перенумеровать ~в 090-..., или как-ещё.)
---------
  Также "недосчитался"(относительно Ретро) в пра-6408-1 дефолт-архиватора и дефолт-муз-плеера.  (в частности в Rox  "пользую": "отправить в..." -> а там "коллекция исторических скриптов-дефолт-программ" [например для альтернативы])
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: krasnyh от 22 Февраль 2019, 19:01:47
/home/live/.gtkrc-2.0 присутствует навскидку в : 084-theme-vertex_any-ij01, 084-theme-ivy_any-sf08, 084-Theme-faenza-j01, 084-Theme-almost-160425-ij20
Это темы от форумчан --> 084-theme-vertex_any-ij01, 084-Theme-faenza-j01, 084-Theme-almost-160425-ij20
http://forum.puppyrus.org/index.php?topic=15151.msg117420#msg117420
И sfs как бы не несет ответственности, если там что-то не работает. )

 А тема 084-theme-ivy_any-sf08 находится в репозитарии устаревших модулей и юзать ее наверно не рекомендуется https://mirror.yandex.ru/puppyrus/puppyrus-a64/pfs-portable-old/
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: knn от 22 Февраль 2019, 19:11:01
Это темы от форумчан --> 084-theme-vertex_any-ij01, 084-Theme-faenza-j01, 084-Theme-almost-160425-ij20
- да - 3 Темы участников Форума/Проекта, ну и 4-я  "sfs-lable".
И sfs как бы не несет ответственности, если там что-то не работает. )
- я вроде и не пытаюсь никого привлекать к ответственности  :police: ;D.
  Просто
но тогда как по-задумке применять недефолтные Темы "на старте"/при первоначальной загрузке?
( нумерацию тематических модулей "как-то" "когда-то" "ранжировали" - как сейчас делать?)
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: krasnyh от 22 Февраль 2019, 19:37:16
Также "недосчитался"(относительно Ретро) в пра-6408-1 дефолт-архиватора и дефолт-муз-плеера.
Меню - Аудио и видео - DeadBeef
Меню - Стандартные - Менеджер архивов Engrampa
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: knn от 22 Февраль 2019, 19:42:49
Цитата: knn от Сегодня в 18:49:43

    Также "недосчитался"(относительно Ретро) в пра-6408-1 дефолт-архиватора и дефолт-муз-плеера.

Меню - Аудио и видео - DeadBeef
Меню - Стандартные - Менеджер архивов Engrampa
  Спасибо. Но "отталкивался" от универсальности.
( да и скрипты /usr/local/bin/default....any-function не зря же писали - в Ретро около 11 шт.)
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: knn от 22 Февраль 2019, 19:45:15
Какая-то своя тема?
применение различных тем GTK-2 для Рута и Лайва - для одного Чёрная тема, для другого - Зеленая (фон окон) - удобно.
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: knn от 22 Февраль 2019, 21:34:41
тогда как по-задумке применять недефолтные Темы "на старте"/при первоначальной загрузке?
- как понял - сейчас в пра6408-1 , в  089-upd...pfs в /home/live/.gtkrc-2.0  везде прописано "gtk-theme-name="PRA", а уже в 084-Темах.pfs - /usr/share/themes/PRA=sln->/usr/share/themes/some-target-theme
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 26 Февраль 2019, 12:55:11
LXDE - не работает клавиатурное переключение раскадки. В строке файла
/.config/lxpanel/LXDE/pannels/panel
добавил grp: - ToggleOpt=grp:alt_shift_toggle - теперь переключается.

OVS - нет русской раскладки клавиатуры
089-prar-upd-180101-sf50.pfs (ftp://ftp.yandex.ru/puppyrus/roll/180101/089-prar-upd-180101-sf50.pfs)
спасибо+
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: knn от 27 Февраль 2019, 19:53:00
решил "подосвоить" ПРА6408-01 - подзапутался по вопросу "где брать модули".

  Если правильно понял, что брать здесь:
ftp://ftp.mirror.yandex.ru/puppyrus/roll/180101/ , то получается смутило :
 "roll/180101" - в пути.
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: krasnyh от 27 Февраль 2019, 20:30:23
смутило :
 "roll/180101"
  Да, это переименованный 180101. Название сборки изменили на ПРА6408-01, а модули так и продолжили именоваться по старому --> 040-de-ols-gtk2-180101-*

В sfs-get прописано два репозитария:
mirror.yandex.ru/puppyrus/roll/180101/
mirror.yandex.ru/puppyrus/puppyrus-a64/pfs-portable/
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: knn от 27 Февраль 2019, 22:26:54
В sfs-get прописано два репозитария:
mirror.yandex.ru/puppyrus/roll/180101/
mirror.yandex.ru/puppyrus/puppyrus-a64/pfs-portable/
вроде в сборках 180101 и 6408-01 разница в датах Арч-среза ~10 мес  - ни на что сильно не повлияет?
p.s.
 loloswitcher_0.28-e1-as_64-kn01.pfs из ftp://ftp.mirror.yandex.ru/puppyrus/puppyrus-a64/pra64-07/pfs-test/ работает
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: krasnyh от 27 Февраль 2019, 22:49:08
вроде в сборках 180101 и 6408-01 разница в датах Арч-среза ~10 мес  - ни на что сильно не повлияет?
  У меня уже нет сборки 180101, поэтому не сравнить с 6408-01. Но если именно в 6408-01 срез на 10 месяцев позже, то значит sfs не просто переименовал сборку, но и чуть обновил модули.

А репа тоже думаю оптимизирована под новую сборку. Там что не вошло наверно находится в 1801-old/ https://mirror.yandex.ru/puppyrus/roll/.

Как то так.)

то значит sfs не просто переименовал сборку, но и чуть обновил модули.
Обновил glib2. Перекроил 001
7 тем оформления и 10 DE в любых комбинациях
Много переделок профилей и переименований модулей.
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 28 Февраль 2019, 09:46:10
брать здесь:
ftp://ftp.mirror.yandex.ru/puppyrus/roll/180101
да
в сборках 180101 и 6408-01 разница в датах Арч-среза ~10 мес
Правильная дата среза для бывшего ролл1801 и теперешнего пра6408 : 180101 - в 089 она и стоит
чуть обновил модули
По опыту пра03 glibc и glib2 обновлять безопасно (в плане совместимости) и практически полезно - дает совместимость со свежим срезом арчрепы
Прочих обновлений в стиле "обновление ради обновления" не  планирую в пра64
Всю репу mirror.yandex.ru/puppyrus/puppyrus-a64/pfs-portable/ не перепроверял. Если что не работает - пишите - починю
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: knn от 28 Февраль 2019, 10:13:44
 на пра03 в rox пользую настройку "Ввести-чем-открыть" - из http://forum.puppyrus.org/index.php?topic=106.msg2538#msg2538 .
 
 Чем можно заменить gxmessage на ПРА6408-1 ?

p.s.   также на 6408-1 "перестал работать"(частично) метод перехода из root-rox -> live-rox .И на  антиКСе такое "проходило").
В chroot теперь выкидывает.   :o :)
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 28 Февраль 2019, 10:15:46
Чем можно заменить gxmessage на ПРА6408-1 ?
https://www.archlinux.org/packages/community/x86_64/gxmessage/ или yad или gtkdialog
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: knn от 28 Февраль 2019, 12:33:41
 ;) ols - ...тоже ракета  (  нефэншуйный  http://forum.puppyrus.org/index.php?topic=20953.msg154265#msg154265 gtkperf-64.pfs прикрепил )
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: krasnyh от 01 Март 2019, 17:19:25
В de-ols отсутствует легкий редактор - leafpad (l3afpad).
В других DE не проверял, возможно это глобально.
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 02 Март 2019, 09:29:15
В de-ols отсутствует легкий редактор - leafpad (l3afpad).
В других DE не проверял, возможно это глобально.
Да - в ols добавлю. В прочих гтк2 есть
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: knn от 27 Март 2019, 18:41:45
Но суть - открытие гиперссылок ссылок сторонними программами (в браузере, и именно здесь получается в Паленум-Ноубади).
всё так попробуйте - откройте какую-нибудь гиперссылку из какого-нибудь документа (т.е. из документа из-под "офисной программы")...
  И наверное  даже просто any-file.html

p.s. если есть какой-089-update - , то не нашел/не увидел
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 10 Апрель 2019, 11:53:23
Обновление OpenSSL с устранением уязвимости в реализации TLS  (http://www.opennet.ru/opennews/art.shtml?num=50213)
openssl-201903_64-sf01.pfs (ftp://ftp.yandex.ru/puppyrus/roll/180101/openssl-201903_64-sf01.pfs)
Положить в /base и перезагрузиться.
У меня - нор.
Как обновится glibc - перенесу в 001*.pfs

openssl-201903_64-sf02.pfs (ftp://ftp.yandex.ru/puppyrus/roll/180101/openssl-201903_64-sf02.pfs)
Добавил pacman (http://www.opennet.ru/opennews/art.shtml?num=50311)

Добавил wget
http://www.opennet.ru/opennews/art.shtml?num=50466
openssl-201903_64-sf04.pfs (ftp://ftp.yandex.ru/puppyrus/roll/180101/openssl-201903_64-sf04.pfs)
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 22 Апрель 2019, 12:32:31
wget-1.20.3-2-x86_64.pkg.tar.xz (ftp://ftp.yandex.ru/puppyrus/puppyrus-a64/pra64-07/pkg/pra6407extra/wget-1.20.3-2-x86_64.pkg.tar.xz) перекомпилил без pcre2
001-prar-c-180101-sf15.pfs (ftp://ftp.yandex.ru/puppyrus/roll/180101/001-prar-c-180101-sf15.pfs)
089-prar-upd-180101-sf53.pfs (ftp://ftp.yandex.ru/puppyrus/roll/180101/089-prar-upd-180101-sf53.pfs)
DEVX-prar-180101-sf15.pfs (ftp://ftp.yandex.ru/puppyrus/roll/180101/DEVX-prar-180101-sf15.pfs)
Обновил
glibc-2.29-1-x86_64.pkg.tar.xz           pacman-5.1.3-1-x86_64.pkg.tar.xz
openssl-1.0-1.0.2.r-1-x86_64.pkg.tar.xz  wget-1.20.3-2-x86_64.pkg.tar.xz
openssl-1.1.1.b-1-x86_64.pkg.tar.xz

openssl-201903_64-sf04.pfs
- можно удалить
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 23 Апрель 2019, 09:27:09
Планирую перевыпустить исо. Есть пожелания?
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 23 Апрель 2019, 15:05:22
pra6408-1904.iso (http://file.puppyrus.org/users/pra64/iso/pra6408-1904.iso)
Обновил
glibc-2.29-1-x86_64.pkg.tar.xz           pacman-5.1.3-1-x86_64.pkg.tar.xz
openssl-1.0-1.0.2.r-1-x86_64.pkg.tar.xz  wget-1.20.3-2-x86_64.pkg.tar.xz
openssl-1.1.1.b-1-x86_64.pkg.tar.xz
, браузеры, DE, DEVX
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: loop223 от 24 Апрель 2019, 19:18:58
Скачал последний Iso.Xfce 4.13 gtk3 -не поднимается wifi через Настройка Сети 180109. В OVS(Настройка Сети 180123) тоже. Через  Connman все поднимается, но после перезагрузки-нет)
в GTK2 Настройка Сети 180109 отрабатывает с какой то ошибкой, но сеть поднимается.  В GTK3, даже в консоле wifi-menu просто вылетает после ввода пароля и запроса на добавление профиля.
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: loop223 от 25 Апрель 2019, 09:41:36
Дополню наблюдения. В GTK2 OLS создаю сохраненку(091) с настройками сети(сеть поднимается) и после перезагрузки в любое GTK2 DE(XFCE,LXDE),сеть стартует автоматом.LXQT GTK2- не стартует, только через connman aplet. В GTK3(любой DE)- сеть поднимается только ручками через connman.Скрипт настройки сети там бесполезен, т,к он конфликтует с connman.
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 25 Апрель 2019, 10:08:22
не поднимается wifi через Настройка Сети 180109
При этом прочие настройщики сети (nm connman) отключены? Вместе не надо
Через  Connman все поднимается, но после перезагрузки-нет)
В сохраненку попали настройки connman (они гле-то в /var/lib/connman)? Чем ее делали? В create-save-pfs про него есть
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 25 Апрель 2019, 10:37:34
прочие настройщики сети (nm connman) отключены? Вместе не надо
connman-p-1.36_64-sf02.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a64/pfs-portable/connman-p-1.36_64-sf02.pfs)
Убрал ярлык "Настройка Сети"
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: loop223 от 25 Апрель 2019, 13:35:37
Я говорю к тому, что если используется connman, то зачем использовать дефолтный мастер настройки сети? Он ведь не работает!
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: loop223 от 25 Апрель 2019, 15:08:19
Представьте юзера-новичка, кто хочет попробовать дистр. Вот он увидел заветные Xfce+GTK3, загрузился и ему в лицо аплет "настройки сети(wifi)", который не работает, т.к присутствуют модуль connman.Вы уж если добавляете connman, то уберите из автозагрузки мастера настройки сети и добавьте connman в  трей, т.к его там нет.Пол вечера выяснял почему мастер не работает.
После того, как настроил connman (приконнектился к точке, поставил галку автозапуска,поставил галку значка в трее) Сделал полную сохраненку(убрал галку "только настройки") туда попали настройки connman.После перезагрузки сеть взлетела автоматом,появился значок в трее и стало все по человечески.
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 28 Апрель 2019, 08:52:35
если добавляете connman, то уберите из автозагрузки мастера настройки сети
Убрал ярлык "Настройка Сети"
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: loop223 от 28 Апрель 2019, 14:04:12
Автообновил модуль connman, загрузился без сохраненки и все равно вылетает написаный вами скрипт подключения к сети.
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: loop223 от 28 Апрель 2019, 14:26:05
В целом, связка XFCE-GTK3 для меня самая красивая(elementary) и удобная.

Gparted не робит, либы не хватает.Не работает клавиша принтскриню.И обоина синяя т.к папки по умолчанию разные.
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 29 Апрель 2019, 10:22:16
все равно вылетает написаный вами скрипт подключения к сети.
Что значит "вылетает" ?
добавьте connman в  трей
connman_gtk3-p-1.1.1_64-sf02.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a64/pfs-portable/connman_gtk3-p-1.1.1_64-sf02.pfs)
089-de-xfce_gtk3-1801-sf07.pfs (ftp://ftp.yandex.ru/puppyrus/roll/180101/089-de-xfce_gtk3-1801-sf07.pfs)
и скриншот здесь поправил

Gparted не робит, либы не хватае
gparted-gtk3-p-0.33.0.r60_64-sf02.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a64/pfs-portable/gparted-gtk3-p-0.33.0.r60_64-sf02.pfs)

И обоина синяя т.к папки по умолчанию разные.
У меня норм
xfce413 собрана давно из девел. компонентов
Там все ок (стабильно?) по сравнению с 412gtk2?

Спасибо + за багрепорты
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: loop223 от 30 Апрель 2019, 20:45:06
Что значит "вылетает" ?
Появляется.
Некий скрипт детектит,скорее всего настройка сети, что нет интернета и всплывает аплет подключения к сети.( с конманом он конфликтует)Но, если есть конман, то нужно спраку в окошке по настройке сети и все.
p/s хромиум после обновления сломался. После запуска, крашатся расширения и окно браузера горит серым.
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 01 Май 2019, 09:53:55
Появляется. Некий скрипт детектит
Да. Поправил - в аттаче
если есть конман, то нужно спраку в окошке по настройке сети и все.
Лучше если инета нет - гуй connman - подумаю позже
p/s хромиум после обновления сломался
Да. Возможно nss надо обновить... Позже
Спасибо+
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: knn от 01 Май 2019, 20:48:48
  Поставил "начисто" 6408-1904 (без сохраненок, без доп.модулей, без доп-фирмваре - только переход в iso-menu.lst и подправки путей в оном).
W-баг-треккер: дубль - http://forum.puppyrus.org/index.php?topic=21342.msg155082#msg155082
(т.е. [LXQT-gtk2 Palemoon] открыть any-file.pdf --> открыть ссылку из документа = Х )
-----------------
в usr/local/bin/palemoon-n
вместо
Код
run-as-nobody /usr/bin/palemoon "http://wiki.puppyrus.org/puppyrus/pra-roll?&#run-as-nobody_-_запуск_приложения_от_пользователя_без_прав" &
нужно
Код
run-as-nobody /usr/bin/palemoon "$@" &
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 03 Май 2019, 15:14:25
Тогда уж лучше скрипт сделать
Код
if [ ! "$1" ];then
run-as-nobody /usr/bin/palemoon "http://wiki.puppyrus.org/puppyrus/pra-roll?&#run-as-nobody_-_запуск_приложения_от_пользователя_без_прав" &
else
run-as-nobody /usr/bin/palemoon "$@" &
fi
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: loop223 от 22 Май 2019, 19:13:18
PRA6408-1904 с последним XFCE без сохраненок, не работает htop.
UPD.прилетел последний апдэйт и заработал htop, может и не в нем дело, но сечас все норм.
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 23 Май 2019, 09:47:23
может и не в нем дело
точно не в нем
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: Neyel от 25 Май 2019, 10:58:56
Заметил на играх. Если в игре щёлкнуть регистрация - то открывается палемон с вики папируса, а не со ссылкой на регистрацию-  и так во всех играх. Приходилось искать в яндексе регистрацию в игре  >:(
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 25 Май 2019, 12:16:00
открывается палемон с вики папируса
Это (http://forum.puppyrus.org/index.php?topic=21342.msg156564#msg156564) пробовали?
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: Coalxe от 04 Июнь 2019, 22:42:50
XFCE_GTK3 -> меню -> система -> установка PRA - не одна справка не открывается.
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: Coalxe от 04 Июнь 2019, 23:01:28
Одно радует обновление пакетов стало работать удобно. Спасибо.
Подумал: как перетащить в PRA6407 ?
Вспомнил: обновлений не будет, не спасёт. ;D
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: knn от 02 Июль 2019, 21:43:34
вроде даже defaulttexteditor~a нет( применяю в конфигах De-ice-rox)  - или не увидел/не обновлялся

 upd: - запутался, пока прикручивал различные MIME-types роксу
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 15 Июль 2019, 18:01:27
089-prar-upd-180101-sf61.pfs (ftp://ftp.yandex.ru/puppyrus/roll/180101/089-prar-upd-180101-sf61.pfs)
поправил rdate.sh - не работал при старте системы
Починил и проверил easydd
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 25 Июль 2019, 11:18:33
В репу pra6408 случайно попал 035-gtk2-1811-sf04.pfs и мог автообновиться
Правильный 035-gtk2-2.24.31-1-180101-sf07.pfs
Вроде, ничего не ломается, но лучше замените
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 06 Сентябрь 2019, 16:21:49
wpa_supplicant-2:2.9-1-x86_64.pfs (ftp://ftp.yandex.ru/puppyrus/roll/180101/wpa_supplicant-2:2.9-1-x86_64.pfs)
скомпилил свежий под openssl1.1. Позволит вынести из базы 001 openssl1.0. Планирую сделать , как в арче появится glibc2.30
Прошу проверить : положить в /base , перезагроузиться и законнектиться по вифи
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: yxma от 27 Сентябрь 2019, 10:00:50
просто хочу похвалить ОС. Последний вариант. Вы просто не представите, как 6408-1904 летает на Делл7577.  Загрузка картинки без таймаута. Офис (презентация) работает - сказка. Хромиум - тоже.
Это праздник, а не ОС
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 27 Сентябрь 2019, 10:42:49
Делл7577
а есть какие-то линуксы, которые на Процессор: Core i5 / Core i7 Объем оперативной памяти: 4...16 ГБ  тормозят?
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: yxma от 01 Октябрь 2019, 09:38:36
не думаю, что есть - ПРА везде быстро работает, но все равно от процессора зависит. Линуксы конечно, хорошо работают, но все равно отзывчивость по сравнению с ПРА - не та. Особенно сейчас, когда я запуск с ссд организовал. Ярче всего на офисе проявляется.
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: 7240 от 05 Октябрь 2019, 18:17:15
просто хочу похвалить ОС. Последний вариант. Вы просто не представите, как 6408-1904 летает на Делл7577.  Загрузка картинки без таймаута. Офис (презентация) работает - сказка. Хромиум - тоже.
Это праздник, а не ОС

А где сам дистрибутив-то?
Ссылку киньте!

В начале темы нет, и в сообщениях тоже не заметил.
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: krasnyh от 05 Октябрь 2019, 18:23:08
В шапке темы форума.
Скрин.
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 10 Октябрь 2019, 11:40:09
В арчрепе обновился glibc
Планирую обновить 001
Пока тестируем модулем. glibc-2.30-1.pfs (ftp://ftp.yandex.ru/puppyrus/roll/180101/glibc-2.30-1.pfs)
Положить в /base
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 21 Октябрь 2019, 18:28:58
http://file.puppyrus.org/users/pra64/iso/Hybrid_bootable_Grub2-EFI_and_MBR-demo.iso
Прошу проверить grub2 конфиги с pra6408-1904.iso (http://file.puppyrus.org/users/pra64/iso/pra6408-1904.iso). Следующие мои исо будут в таком варианте. Скоро обновлю PRA64-08
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 22 Октябрь 2019, 10:21:31
089-prar-upd-180101-sf71.pfs (ftp://ftp.yandex.ru/puppyrus/roll/180101/089-prar-upd-180101-sf71.pfs)
Прошу протестировать. По итогу будет перенесено в 001
glibc-2.30-1.pfs
mc-p-4.8.23_64-sf05.pfs
pacman-nogpg-5.2.0-2-x86_64.pfs - свежий (https://www.opennet.ru/opennews/art.shtml?num=51722). Перекомпилил без gpg
wpa_supplicant-2:2.9-1-x86_64.pfs gthtrjvgbkty gjl openssl1.1. openssl1.0 будет перенесен вместе с в модуль modem.pfs
xorg-xhost-1.0.7-1.pfs
zstd-1.4.3-1-x86_64.pfs
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 22 Октябрь 2019, 10:41:13
035-gtk2-2.24.31-1-180101-sf09.pfs (ftp://ftp.yandex.ru/puppyrus/roll/180101/035-gtk2-2.24.31-1-180101-sf09.pfs)
обновил yad , перекомпилил gtkdialog без glade
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: knn от 22 Октябрь 2019, 12:38:04
035-gtk2-2.24.31-1-180101-sf09.pfs
089-prar-upd-180101-sf71.pfs
- скачал, подключил на горячую верхними слоями. Рестарт Х ( сборка "своя" - ПРА64-08-ice-rox-gtk2_64 ).
- вроде работает;
- высоковероятно, что из-за "верхнего слоя", сломался defaultfilemanager для rox~a (сейчас точно не помню - может "это" только для сочетания rox+icewm ) [ наверно просто перекрыло "патч"].

upd:
 после перезагрузки комп-ра (с новыми модулями) - всё "штатное" вроде работает ( про "нештатное" - выше).
 --конечно проверял не совсем все утилиты, программы...
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 06 Ноябрь 2019, 15:49:49
Обновил
001-prar-c-180101-sf17.pfs (ftp://ftp.yandex.ru/puppyrus/roll/180101/001-prar-c-180101-sf17.pfs)
Удалил
lzo - редко используется
xf86-video-intel-2.99.917-1801-sf01.pfs (ftp://ftp.yandex.ru/puppyrus/roll/180101/xf86-video-intel-2.99.917-1801-sf01.pfs)  - вроде modesetting лучше (https://archlinux.org.ru/forum/topic/19550/?page=2#post-222513)
openssl-1.0 перенес в modem-p-sf03.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a64/pfs-portable/modem-p-sf03.pfs)
Добавил (обновил)
fribidi-0.19.7-1-x86_64.pkg.tar.xz
glibc-2.30-2-x86_64.pkg.tar.xz
mc-4.8.23-2-x86_64.pkg.tar.xz
pacman-nogpg-5.2.0-2-x86_64.pkg.tar.xz
squashfs-tools-4.4-1-x86_64.pkg.tar.xz - c zstd
wget-1.20.3-2-x86_64.pkg.tar.xz
wpa_supplicant-2:2.9-1-x86_64.pkg.tar.xz под ssl1.1
xdotool-3.20160805.1-1-x86_64.pkg.tar.xz
xorg-xhost-1.0.7-1-x86_64.pkg.tar.xz
zstd-1.4.3-1-x86_64.pkg.tar.xz
Прошу протестировать и перевыпускаю исо
089-prar-upd-180101-sf75.pfs (ftp://ftp.yandex.ru/puppyrus/roll/180101/089-prar-upd-180101-sf75.pfs)
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 06 Ноябрь 2019, 16:55:44
Сеть не стартует
089-prar-upd-180101-sf75.pfs (ftp://ftp.yandex.ru/puppyrus/roll/180101/089-prar-upd-180101-sf75.pfs)
Поменялся фон рабочего стола
040-de-ols-gtk2_64-sf19.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a64/pfs-portable/040-de-ols-gtk2_64-sf19.pfs)
Спасибо и + за оперативность
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: krasnyh от 06 Ноябрь 2019, 17:50:28
Стартует по кругу - появился, упал, опять появился, опять упал...

В PRA автологин, поэтому такая карусель иногда получается..

Может сделать как в IceArch - небольшая пауза (2 сек.) перед загрузкой раб. стола, чтобы можно было или выйти в консоль, или продолжать загрузку? Для диагностики.
В richy такую же фишку видел.
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 06 Ноябрь 2019, 18:01:10
Если нажать и держать ctrl+c и так попадаем в консоль
Сделайте так и xinit startxfce4
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: krasnyh от 06 Ноябрь 2019, 18:07:25
нажать и держать ctrl+c
Не знал, а в вики есть? Считаю это очень важной информацией.
Скрин.

p.s. Или может это обычное дело в линукс, нажать и держать, чтобы прервать процесс. А я и не знал, обычно нажимал и отпускал.  :)

upd. Посмотрел, в предыдущем 001-prar-c-180101 присутствовал libpolkit-gobject-1.so.0.
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: Coalxe от 06 Ноябрь 2019, 23:16:01
"PRA64 Mate"
Обновление прошло в два этапа.
001-prar-c-180101-sf17, 089-prar-upd-180101-sf73 - нормально.
030-gtk3-1811-sf05, transmission-gtk3-2.94-1811-sf01 - что-то сломалось.
Пишет - "чего-то не узнаёт".
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: krasnyh от 06 Ноябрь 2019, 23:20:49
Путаница в модулях, 180101 и 1811 это разные сборки. К PRA64 относятся только 180101/1801/_64 модули.
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 07 Ноябрь 2019, 09:28:56
может это обычное дело в линукс, нажать и держать, чтобы прервать процесс
Нажать - обычное. Нажать и держать нужно, т.к. перезапуск без пауз - не всегда успевает
Попробуйте добавить паузу после Х. До -не хотелось бы
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 11 Ноябрь 2019, 15:38:11
DEVX-prar-180101-sf18.pfs (ftp://ftp.yandex.ru/puppyrus/roll/180101/DEVX-prar-180101-sf18.pfs)
под новый qt5.13
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 11 Ноябрь 2019, 16:02:02
pra6408-1911-x86_64.iso (http://file.puppyrus.org/users/pra64/iso/pra6408-1911-x86_64.iso)
Изменений много. Почти все модули переименованы - автообновление не сработает. Переустанавливайте
Обновил : 001
DEVX ; 030-qt5 (http://forum.puppyrus.org/index.php?topic=22174.0) ; почти все DE ; облегчен NM
Добавлен qt4 софт ; переход в grub2 ; автоконвертация меню grub2
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: RoDoN от 11 Ноябрь 2019, 22:12:25
Установил pra6408-1911 - совсем не в восторге, с дровами nVidia загрузиться не смог никак, хотя в LFD10 340-е у меня заработали, казалось бы ладно, можно и на свободных работать. Но без Wi-Fi совсем грустно, если нет подключения, а оно то есть, то нет, а именно у меня на ноуте броадком:
Цитата
Network:   Card-1: Broadcom Limited NetLink BCM57785 Gigabit Ethernet PCIe driver: tg3
           Card-2: Broadcom Limited BCM4313 802.11bgn Wireless Network Adapter
           driver: bcma-pci-bridge
и когда дрова bcma-pci-bridge, то все работает, как сейчас, но при попытках подключить дрова nVidia почему-то драйвер wl и интернета уже ни фига нет.
Вообще не понимаю зачем такой огород гибридных WM и DE, напр., XFCE-light, где от крысы только панель и меню, Mate, где основной ФМ - SpaceFM, а не Caja, которая есть, в IceWM почему-то грузится lxpanel и за ней прячется панель самого  ледяного ??? Еще в меню IceWM почему-то нет переключения пунктов вслед за движением курсора, а только по щелчку, что имхо не удобно. И вообще непонятно зачем в JWM и IceWM какой-то не функциональный обрубок в виде какого-то StarterFM вместо нормального GUI-шного ФМ, неужели чтобы отбить у пользователей желание пользоваться JWM и IceWM, а?
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 12 Ноябрь 2019, 10:25:58
с дровами nVidia загрузиться не смог никак
Это багрепорт от ветерана  :'(
С твоим опытом надо вообще сразу багфикс выкладывать  ;)
не понимаю зачем такой огород гибридных WM и DE
Результаты моих экспериментов. Не все считаю удачными. Подробнее здесь (http://forum.puppyrus.org/index.php?topic=20203.msg161618#msg161618)
Поэтому доводить планирую не все. Из самодельных ДЕ - только тинт2. В исо добавил в надежде пристроить в хорошие руки. Не юзая постоянно хорошо не сделать. Самодельные ДЕ - вещь очень индивидуальная
Ну а что с ними делать? В репе не найдут. Сами не сделают

Mate, где основной ФМ - SpaceFM
Это не mate. Это mate-light. Был и полный мате. Тяжеловат. Можно и его возрадить. Старые модули вроде, не удалял
FM сюда можно любой - в репе и caja и pcmanfm есть. Это касается всех ДЕ без ФМ.  Делать отдельное меню выбора ФМ не хотелось.

в IceWM почему-то грузится lxpanel и за ней прячется панель самого  ледяного
Проверил все 3 пункта загрузки ice из iso - у меня такого нет

в меню IceWM почему-то нет переключения пунктов вслед за движением курсора, а только по щелчку, что имхо не удобно.
Я не знаток ice. Как такое включить?

зачем в JWM и IceWM какой-то не функциональный обрубок в виде какого-то StarterFM
Это мой скрипт starter.  Это не ФМ. По замыслу поможет юзеру mc запустить что-то типа документа или фильма или перетащить , например фильм из окна starter в окно mpv
Кому не нравится - просто подключить модуль ФМ, который нравится. Считаю, что в модульном дистре так правильнее

чтобы отбить у пользователей желание пользоваться JWM и IceWM, а?
Нет. Чтобы взбодрить их на доработку этих модулей  ;)
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: ramd от 12 Ноябрь 2019, 15:50:18
По итогу проверок и экспериментов с 1911 для работы моего набора софта
(который кстати на 1904 работал без проблем) пришлось добавить пакеты:

lcms2
libglade-2.6.4
libdb-5.3
sqlite-3.30

брал на арчлинукс.орг
пакеты нужны для midori, gimp, gnumeric, atril, audacity и может еще не помню уже чего.
продолжаю тестировать

есть ещё пара замечаний:
в контекстное меню ФМ нужно бы добавить "упаковку пфс-модуля \ слить модули" с папки, как раньше было - удобно.
скринграббер и фф-мпег-гуи не находят кодек H264 и не работают нормально, хотя в системе он видимо есть
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 13 Ноябрь 2019, 09:57:40
нужны для midori, gimp
Эти уже починил (http://forum.puppyrus.org/index.php?topic=16345.msg162788#msg162788)
gnumeric, atril, audacity и может еще не помню уже чего
Эта инфа нужна точно. т.к. в базу эти либы добавлять не планирую
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 13 Ноябрь 2019, 10:37:20
atril-gtk3-p-1.16.1_64-sf03.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a64/pfs-portable/atril-gtk3-p-1.16.1_64-sf03.pfs) прописал зависимость
audacious-gtk2-3.10.1_64-sf02.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a64/pfs-portable/audacious-gtk2-3.10.1_64-sf02.pfs) оптимизировал размер - проверял только на запуск
gnumeric - у меня норм
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 13 Ноябрь 2019, 10:50:46
в контекстное меню ФМ нужно бы добавить "упаковку пфс-модуля \ слить модули" с папки, как раньше было - удобно.
Если повесить это на объект "папка" - при открытии папки из других прог - вместо ФМ открывается создание модуля. Юзайте через гуй или mc
скринграббер и фф-мпег-гуи не находят кодек H264 и не работают нормально, хотя в системе он видимо есть
У меня через меню - audio - ffmpeg видеозахват - экран записался
Название: pra6408-1904
Отправлено: Azazello от 13 Ноябрь 2019, 12:45:35
Крайнее обновление 11-Nov-2019 для pra6408-1904 не дают запуститься XFCE 4.13 gtk3.

Только экран периодически моргает.
Другие gtk3 запускаются и работают.
Последнее обновление на котором всё работало от 06-Nov-2019.
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 13 Ноябрь 2019, 13:00:33
не дают запуститься XFCE 4.13 gtk3.
pra6408-1911-x86_64.iso
Изменений много. Почти все модули переименованы - автообновление не сработает. Переустанавливайте
В вашем inxi старые модули
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: Azazello от 13 Ноябрь 2019, 13:41:56
Переустанавливайте
Забыл указать - запускаю с USB Flash.
Т.е. закачать заново .iso и записать на флэшку?
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 13 Ноябрь 2019, 14:04:30
закачать заново .iso и записать на флэшку?
да
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: Azazello от 13 Ноябрь 2019, 14:13:03
Закачал.
Записал.
Теперь загрузка только UEFI.
И субъективно - медленнее.
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 13 Ноябрь 2019, 14:31:05
Теперь загрузка только UEFI.
BIOS загрузка как была так и осталась
Как писали на флэшку? Ставьте инсталлятором
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 13 Ноябрь 2019, 16:46:03
Mate, где основной ФМ - SpaceFM, а не Caja
Посмотрел. caja в модуле де. spacefm прилетел по маске -gtk3-
Сделал отдельным модулем для других ДЕ
089-fm-caja-p-1.22.0_64-sf01.pfs (ftp://ftp.yandex.ru/puppyrus/puppyrus-a64/pfs-portable/089-fm-caja-p-1.22.0_64-sf01.pfs)
Вместо pup-volume сделал правку fstab - как в pra-roll
Обои менять заменой /usr/share/background/default.jpg

Посмотрел - в  PRA6408-1911.iso и в 1904 тоже забыл gvfs. Кому нужна корзина в thunar pcmanfm caja - положите модуль gvfs в /modules
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: krasnyh от 13 Ноябрь 2019, 21:59:08
Теперь загрузка только UEFI.
Как будто это что-то плохое. Наоборот плюс, что завелось без всякого 'шаманства'.
Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: krasnyh от 14 Ноябрь 2019, 02:09:20
    в контекстное меню ФМ нужно бы добавить "упаковку пфс-модуля \ слить модули" с папки, как раньше было - удобно.

Если повесить это на объект "папка" - при открытии папки из других прог - вместо ФМ открывается создание модуля. Юзайте через гуй или mc
Долгое время "Упаковка PFS-пакета" была в контекстном меню ФМ, многие привыкли к такому удобству, причем все работало без помех для других прог. Теперь эта функция стала неправильной. С чего вдруг?

Добавить эту строчку несложно так, чтобы она была в подменю. Для spacefm "Режим дизайна" (http://ignorantguru.github.io/spacefm/spacefm-manual-en.html#designmode) в помощь.
Скрин.

Название: Re: PRA64-08. x86_64 (64бит). Frugal
Отправлено: sfs от 14 Ноябрь 2019, 09:04:34
"Упаковка PFS-пакета" была в контекстном меню ФМ, многие привыкли к такому удобству
Ну и где модули от юзеров?
Более менее сложный модуль все равно придется делать в консоле
Для простых pacman2pfs.sh - надо сделать аналог для дебиана
У меня было сделано через ярлык (т.е. через mime) и он постоянно вылезал вместо фм