Форум проекта PuppyRus Linux

Дистрибутивы проекта PuppyRus Linux => PuppyRus-A [PRA] => Тема начата: qwert от 17 Март 2016, 18:56:49

Название: LXDE
Отправлено: qwert от 17 Март 2016, 18:56:49
Наблюдаю ошибку при загрузке в Lxde (каждый раз разный процесс). Подскажите, как определить в чем причина. При загрузке в Xfce ошибок нет.
Название: Re: PRA64. 040-Lxde
Отправлено: sfs от 18 Март 2016, 10:32:57
Наблюдаю ошибку при загрузке в Lxde
Не планирую дальнейшую поддержку 040-Lxde-pra6406c.pfs - переходите на 045-Lxpanel-0.6.2-s07_64.pfs 050-Pcmanfm-p-1.2.3_64-s06.pfs. Или полный LXDE чем-то лучше?
Название: Re: PRA64. 040-Lxde
Отправлено: qwert от 18 Март 2016, 14:27:55
Не планирую дальнейшую поддержку 040-Lxde-pra6406c.pfs - переходите на 045-Lxpanel-0.6.2-s07_64.pfs 050-Pcmanfm-p-1.2.3_64-s06.pfs. Или полный LXDE чем-то лучше?
Модуль 045-Lxpanel-0.6.2-s07_64.pfs запускать с окружением 040-Xfce-4.12_64-s02.pfs? Но тогда в нижней панели двоиться.. Или я не то делаю?
Название: Re: PRA64. 040-Lxde
Отправлено: RoDoN от 18 Март 2016, 14:40:12
045-Lxpanel-0.6.2-s07_64.pfs + 050-Pcmanfm-p-1.2.3_64-s06.pfs нужно запускать не с XFCE, а с Openbox.
Название: Re: PRA64. 040-Lxde
Отправлено: qwert от 18 Март 2016, 17:03:39
045-Lxpanel-0.6.2-s07_64.pfs + 050-Pcmanfm-p-1.2.3_64-s06.pfs нужно запускать не с XFCE, а с Openbox.
Запустил в этои связке, в результате серыи экран вместо обоев и не возможно сменить обои, также PcMan в меню есть но не активен-похоже чего то не хватает. В папке base лежат (000-kernel-4.4.1-pf3_64.pfs, 001-Pra06arch_64-sf05.pfs, 005-xorg-1.18.0-3_64-s02.pfs, 040-Openbox-3.6.1-s07_64.pfs, 045-Lxpanel-0.6.2-s07_64.pfs, 050-Pcmanfm-p-1.2.3_64-s06.pfs, 070-Pra64-160216.pfs, 075-Minirc-120.2915396-s22_64.pfs, 084-Theme-almost-ij16_any.pfs, 089-pra6406-update-160309.pfs, 083-chrome-profile-s07.pfs). Что делаю не так?
Название: Re: PRA64. 040-Lxde
Отправлено: I-Jurij от 18 Март 2016, 19:09:08
pcmanfm --desktop в атозагрузке не хватает.
Добавьте в ~/.config/autostart файл pcmanfm-desktop.desktop  с содержимым:
Код
[Desktop Entry]
Name=pcmanfm-desktop
Exec=pcmafm --desktop
Terminal=false
Type=Application
NoDisplay=true
и сохраненку сделайте, или добавьте в модуль 050-pcmanfm, если уже знаете как.

ЗЫ: а что значит "pcmanfm в меню неактивен" - не запускается что-ли?
Название: Re: PRA64. 040-Lxde
Отправлено: qwert от 18 Март 2016, 20:18:33
pcmanfm --desktop в атозагрузке не хватает.
Добавьте в ~/.config/autostart файл pcmanfm-desktop.desktop  с содержимым:
В autostart отсутствует фаил pcmanfm-desktop.desktop. Значки pcmanfm в меню не активны, не открываются.
Название: Re: PRA64. 040-Lxde
Отправлено: sfs от 19 Март 2016, 07:45:05
Наблюдаю ошибку при загрузке в Lxde (каждый раз разный процесс). Подскажите, как определить в чем причина.
при замене 075-Minirc на 075-Systemd проходит или добавить polkit

Есть мысли про pra6406-middle
Название: Re: PRA64. 040-Lxde
Отправлено: qwert от 19 Март 2016, 08:22:10
Вроде при замене 075-Minirc на 075-Systemd проходило

Есть мысли про pra6406-middle
1. Замена 075-Minirc на 075-Systemd помогла, вопрос решен.

2. Pra6406-middle думаю лишняя трата времени, все таки машины с х64 на борту имеют достаточное кол-во ресурсов для Puppyrus.

3. Если поддержка 040-Lxde-pra6406c.pfs не планируется, как решить проблему запуска (045-Lxpanel-0.6.2-s07_64.pfs + 050-Pcmanfm-p-1.2.3_64-s06.pfs) - в связке с Openbox отказывается работать Pacman и рабочего стола как такового нет.
Название: Re: PRA64. 040-Lxde
Отправлено: sfs от 19 Март 2016, 08:40:20
как решить проблему запуска (045-Lxpanel-0.6.2-s07_64.pfs + 050-Pcmanfm-p-1.2.3_64-s06.pfs)
http://mirror.yandex.ru/puppyrus/puppyrus-a64/pfs-portable/050-Spacefm-gtk2-p-1.0.3-s24_64.pfs ,т.е. делать pra6406-middle и отлаживать
Название: Re: PRA64. 040-Lxde
Отправлено: qwert от 19 Март 2016, 08:58:10
Проблема решена в связке 040-Openbox-3.6.1-s07_64.pfs + 045-Lxpanel-0.6.2-s07_64.pfs + 050-Spacefm-gtk2-p-1.0.3-s24_64.pfs + 075-Minirc-120.2915396-s22_64.pfs
Работает как нужно, к сожалению от Pcman пока пришлось отказаться.
Название: Re: PRA64. LXDE
Отправлено: sfs от 21 Июль 2017, 16:54:02
Наблюдаю ошибку при загрузке в Lxde (каждый раз разный процесс). Подскажите, как определить в чем причина.
no session for pid лечится удалением /usr/bin/lxpolkit
Название: Re: PRA64. LXDE
Отправлено: sfs от 16 Январь 2018, 12:44:10
roll/180101/040-prar-de-lxde-gtk2-180101-sf01.pfs
roll/180101/089-de-lxde-gtk2-profile-ater-180101-sf01.pfs
По прежнему не смог запустить lxpolkit с minirc. Наверное для открытого sudo и не актуально заморачиваться polkit
В остальном отличия от OLS:
1. pcmanfm
puppyrus-a64/pra64-07/pkg/pra6407extra/gvfs-micro-1.22.0-1-x86_64.pkg.tar.xz
roll/180101/gvfs-micro-p-1.22.0_64-sf06.pfs - корзина ssh ftp webdav для pcmanfm и thunar
Для монтирования - pup-volume-monitor
2. В ~/.xinitrd startlxde.
Плюс: в lxrandr можно корректировать гамму Gtk темы
Минус : жрет +10mb RAM
Если это не надо - можно заменить на openbox-session

В итоге ничем особо  не лучше OLS. Добавил голосование. Будет мало голосов - больше собирать lxde не буду
Название: Re: LXDE
Отправлено: sfs от 22 Январь 2018, 10:56:30
Подразочаровавшись в "солянка DE", попробовал собрать lxde-gtk3 для PRA-roll
trayinfo и т.п. - расплывчатые цифры. В gtk2 этой проблемы нет. И вообще в gtk3 есть ощущение сыроватости
Можно переделать trayinfo на разноцветные кружки
Или прикрутить эту статистику к multiload-ng
Или юзать вместе с plank (выводить эту инфу через него) - как-то избыточно
Модули выложу по запросу

В итоге нет пока хорошего gtk3 DE для пра-ролл. XFCE-gtk3 еще бета. Может mate попробовать...