Сайт | Скачать | Видео | Wiki

Автор Тема: Компиляция Emacs и как создать PET (emacs-24.5-i486.pet)  (Прочитано 5176 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн qrkx

  • Пользователь
  • **
  • Сообщений: 60
  • Репутация: +1/-0
Если компилировать, то Emacs успешно устанавливается в Wary, Racy и записывает информацию о себе в меню JWM.
Достаточно набрать:
#./configure
#make install clean
Команда
#make uninstall
работает также успешно.

Поэтому задача - это создать пакет PEТ (emacs-xxxx.pet), чтобы один раз скомпилировать
по инструкции Барри (http://barryk.org/blog/?viewDetailed=00703) и устанавливать такой
пакет на совместимые системы Puppy.

Есть Wary-5.5 + devx_wary_5.5.sfs     (http://distro.ibiblio.org/quirky/wary-5.5/)   
Есть Emacs-24.5                                 (http://ftp.gnu.org/pub/gnu/emacs/)   

Исходные файлы установлены в /usr/local/src
#cd /usr/local/src/emacs-24.5

********************************************************************************************
Инструкция Барри "Howto create a PET package":

# ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu
# make
# new2dir make install

We then have 'dir2pet' which will convert a directory into a PET package, for example:

# dir2pet abiword-1.2.3

This will create a PET package, file "abiword-2.5.6-i486.pet". That's it, all done.

*********************************************************************************************
При установки пакета emacs-24.5-i486.pet, получаю сообщение:

"The following package has been successfully installed:
PACKAGE: emacs-24.5-i686 CATEGORY: none
...note, this package does not have a menu entry."

Emacs пишет: "This is GNU Emacs 24.5.1 (i486-pc-linux-gnu, GTK+ Version 2.24.11)
of 2016-01-11 on puppypc29461", a Puppy Package Manager "PACKAGE:emacs-24.5-i686..."

Одно утешение, что пакет устанавливается и его можно запустить не только из
консоли, но и кликнув на иконку.
Иконку на рабочий стол emacs.desktop можно забрать в папке /usr/share/applications/

Пакет emacs-24.5-i486.pet установился в Racy-5.5, но иконку пришлось доставать,
а /usr/sbin/fixmenus, так и не сработал.

Со всеми плюшками пакет emacs-24.5-i486.pet устновился в Tahr-6.0-CE_no_PAE
« Последнее редактирование: 10 Февраль 2016, 20:03:56 от simplex_man »

Оффлайн qrkx

  • Пользователь
  • **
  • Сообщений: 60
  • Репутация: +1/-0
Re:Компиляция Emacs и как создать PET (emacs-24.5-i486.pet)
« Ответ #1 : 10 Февраль 2016, 20:39:30 »
Попробовал еще раз всё сделать по инструкции - получилось :)

При выполнение dir2pet  выбрал категорию "Document".
JWM успешно записал в своё меню, но без иконки
Пропала картинка для emacs.desktop.
Видимо, это особенность Wary, т.к. картинки "отвалились" у многих других иконок.

Как поставить картинку в меню и иконку?

В папке с исходными файлами emacs есть картинки.
Для emacs.desktop я беру картинку 48х48,
а для иконки в меню JWM я беру картинку 24x24
Чтобы не перепутать картинки, я их копирую с новыми именами в папку
 /usr/local/lib/X11/pixmaps/

# cp /usr/local/src/emacs-24.5/etc/images/icons/hicolor/48x48/apps/emacs.png /usr/local/lib/X11/pixmaps/emacs48.png
# cp /usr/local/src/emacs-24.5/etc/images/icons/hicolor/24x24/apps/emacs.png /usr/local/lib/X11/pixmaps/emacs24.png

Открываю файл /usr/share/applications/emacs.desktop (правый клик на иконке-> file 'emacs' -> open as text)
Пишу путь к картинке:
...
Icon=/usr/local/lib/X11/pixmaps/emacs48.png
...

Открываю файлы /root/.jwmrc, нажимаю C-f, набираю "Document", нахожу строку
<Program label="Emacs" icon="emaс.png">emacs %F</Program> и переписываю на
<Program label="Emacs" icon="/usr/local/lib/X11/pixmaps/emacs24.png">emacs %F</Program>

Menu -> Shutdown -> Restart JWM



« Последнее редактирование: 12 Февраль 2016, 09:33:20 от simplex_man »

Оффлайн qrkx

  • Пользователь
  • **
  • Сообщений: 60
  • Репутация: +1/-0
Re: Компиляция Emacs и как создать PET (emacs-24.5-i486.pet)
« Ответ #2 : 12 Август 2017, 09:19:29 »
Я решил добавить информацию о зависимостях.
Может возникнуть необходимость собрать emacs на другой системе, например Ubuntu 16.04,
тогда понадобиться установить пакеты:
sudo apt-get install build-essential texinfo libx11-dev libxpm-dev libjpeg-dev libpng-dev libgif-dev libtiff-dev libgtk2.0-dev libncurses-dev libxpm-dev automake autoconf -y