Сайт | Скачать | Видео | Wiki

Автор Тема: Игра "world of tanks" в PRA  (Прочитано 17024 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Neyel

  • Старожил
  • ****
  • Сообщений: 241
  • Репутация: +5/-0
Re: Игра "world of tanks" в PRA
« Ответ #240 : 01 Июнь 2018, 17:52:31 »
Взял гл либы отсюда - ./4.15.13-pf6/nvidia-glx-340.106-k4.15.13-pf6.pfs - не работает. Вернул
https://pkgs.org/download/nvidia_glx_340.106
- работает  ??? Странно чего ему в дровах из репы не нравится  :-[

Оффлайн Neyel

  • Старожил
  • ****
  • Сообщений: 241
  • Репутация: +5/-0
Re: Игра "world of tanks" в PRA
« Ответ #241 : 02 Июнь 2018, 08:26:29 »
На nvidia-390 тоже танки запустились, взял гл либы отсюда - http://rpmfind.net/linux/RPM/mageia/6/i586/media/nonfree/updates/x11-driver-video-nvidia-current-390.42-1.mga6.nonfree.i586.html  8)
« Последнее редактирование: 02 Июнь 2018, 09:15:57 от Neyel »

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 23467
  • Репутация: +172/-0
    • PuppyRus-A
Re: Игра "world of tanks" в PRA
« Ответ #242 : 04 Июнь 2018, 09:45:21 »
чего ему в дровах из репы не нравится
проверьте зависимости (ldd)

Оффлайн Neyel

  • Старожил
  • ****
  • Сообщений: 241
  • Репутация: +5/-0
Re: Игра "world of tanks" в PRA
« Ответ #243 : 06 Сентябрь 2018, 20:40:14 »
pra-roll-180101-gtk3-03
Две флешки, два компьютера:
На одной танки запустились только на нвидиа-304
На другой запускается на всех видеодрайверах
Как я смотрю вышел roll-1806, буду тестить  :)

Оффлайн Neyel

  • Старожил
  • ****
  • Сообщений: 241
  • Репутация: +5/-0
Re: Игра "world of tanks" в PRA
« Ответ #244 : 12 Сентябрь 2018, 16:49:16 »
Есть идея сделать готовый модуль wot. Со всеми либами, с драйверами от нвидиа (304 340 390). Так чтобы после подключения модуля можно было сразу играть в танчики без лишних телодвижений  :) Есть у кого-нибудь интерес к этому модулю? Если есть то буду делать  :)

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 23467
  • Репутация: +172/-0
    • PuppyRus-A
Re: Игра "world of tanks" в PRA
« Ответ #245 : 12 Сентябрь 2018, 16:53:09 »
с драйверами от нвидиа (304 340 390)
В один модуль 304 340 390 запихать не получится. Да и смысла нет. В исо все в наличие

Оффлайн Neyel

  • Старожил
  • ****
  • Сообщений: 241
  • Репутация: +5/-0
Re: Игра "world of tanks" в PRA
« Ответ #246 : 12 Сентябрь 2018, 17:15:42 »
В один модуль 304 340 390 запихать не получится. Да и смысла нет. В исо все в наличие
Я имею ввиду 32-битные гл либы, без которых игра не запустится. В исо пра-ролл в ниличиии только 64-битные. То есть в модуль запихать 304 340 и 390, и в скрипте сделать выбор какие именно 32-битные гл либы нужны. Или сделать отедльный скрипт по установке 32-битных гл либ, который определит какой видеодрайвер загружен и установит соответствующие 32-битные гл либы. Вообщем всё упирается в 32-битные OpenGL библиотеки, остальное можно сделать просто :)

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 23467
  • Репутация: +172/-0
    • PuppyRus-A
Re: Игра "world of tanks" в PRA
« Ответ #247 : 12 Сентябрь 2018, 17:44:46 »

Оффлайн Neyel

  • Старожил
  • ****
  • Сообщений: 241
  • Репутация: +5/-0
Re: Игра "world of tanks" в PRA
« Ответ #248 : 12 Сентябрь 2018, 17:54:38 »
Multilib
Для nvidia-340 версия не совпадает. Для nvidia-390 вообще ничего нет. nvidia-304 (lib32-nvidia-304xx-utils) работает - версия та же что и в дистрибутиве (для pra-roll-180101-gtk3-03)
https://www.archlinux.org/packages/multilib/x86_64/lib32-mesa/
На mesa все работает. Как я писал ранее минус меза - фпс вдвое ниже и артефакты
PS Если загрузить nvidia и установить lib32-mesa то танки не запустятся
А что не устраивает в pra03?
Сорри не понял вопроса.pra03 - это 32-битная ОС? Не запускал её никогда :) Также если впоследствии захочется установить 64-битные игры (например WarThunder) то пра03 как я понял не подойдёт
« Последнее редактирование: 12 Сентябрь 2018, 18:18:29 от Neyel »

Оффлайн sfs

  • Администратор
  • Ветеран
  • ****
  • Сообщений: 23467
  • Репутация: +172/-0
    • PuppyRus-A
Re: Игра "world of tanks" в PRA
« Ответ #249 : 13 Сентябрь 2018, 09:06:20 »
Для nvidia-340 версия не совпадает.
Вероятно     lib32-nvidia-340xx-utils можно получить перепаковкой 32 бит модуля с другими путями
Сорри не понял вопроса.pra03 - это 32-битная ОС?
Да. И это будет проще заморочек с мультилиб
если впоследствии захочется установить 64-битные игры (например WarThunder) то пра03 как я понял не подойдёт
Да. Но размер пра настолько мал по сравнению с этими играми, что можно прямо дистр-игра.iso делать.

Оффлайн Neyel

  • Старожил
  • ****
  • Сообщений: 241
  • Репутация: +5/-0
Re: Игра "world of tanks" в PRA
« Ответ #250 : 16 Сентябрь 2018, 14:28:07 »
pra03-fat. Вот с чем столкнулся:
live@pra:~$ sudo pacman -Sy zenity --force
:: Обновление баз данных пакетов...
 core не устарел
 extra не устарел
 community не устарел
 pra-extra не устарел
 pra02-extra не устарел
 pra03-extra не устарел
разрешение зависимостей...
проверка конфликтов...

Пакеты (22) adwaita-icon-theme-3.14.1-1  at-spi2-atk-2.14.1-1  at-spi2-core-2.14.1-1  avahi-0.6.31-14
            colord-1.2.5-1  gdbm-1.11-1  glib-networking-2.42.0-1  gnutls-3.3.11-1
            gsettings-desktop-schemas-3.14.1-1  gtk3-3.14.5-1  json-glib-1.0.2-1  lcms2-2.6-1  libcups-2.0.1-1
            libdaemon-0.14-3  libgusb-0.1.6-1  libproxy-0.4.11-4  libsoup-2.48.0-1  libxkbcommon-0.5.0-1
            nettle-2.7.1-1  rest-0.7.92-1  wayland-1.6.0-1  zenity-3.14.0-1

Будет загружено:    0,02 MiB
Будет установлено:  110,83 MiB

:: Приступить к установке? [Y/n] Y
:: Получение пакетов...
ошибка: не удалось получить файл 'libdaemon-0.14-3-i686.pkg.tar.xz' из archive.archlinux.org : The requested URL returned error: 404
предупреждение: не удалось получить некоторые файлы
ошибка: не удалось завершить транзакцию (непредвиденная ошибка)
Обнаружены ошибки, пакеты не обновлены.
Кто-нибудь, помогите  :)

Оффлайн krasnyh

  • Ветеран
  • *****
  • Сообщений: 707
  • Репутация: +38/-0
Re: Игра "world of tanks" в PRA
« Ответ #251 : 16 Сентябрь 2018, 14:38:25 »
$ sudo pacman -Sy zenity --force
Нужен именно zenity? Просто в PRA используется его форк - yad.
A fork of zenity - display graphical dialogs from shell scripts or command line.
$ yad --version
0.40.90 (GTK+ 2.24.32)

YAD - создание графических интерфейсов (GUI)
http://wiki.puppyrus.org/programming/yad
« Последнее редактирование: 16 Сентябрь 2018, 14:42:28 от krasnyh »

Оффлайн Neyel

  • Старожил
  • ****
  • Сообщений: 241
  • Репутация: +5/-0
Re: Игра "world of tanks" в PRA
« Ответ #252 : 16 Сентябрь 2018, 14:45:20 »
Нет на yad неккоректно работает. В этом форуме поднималась уже эта тема. Ну что ж попробую ещё раз  :)
ЗЫ Попробовал, скрипт установки танков не работает (а ему нужен zenity)

Оффлайн krasnyh

  • Ветеран
  • *****
  • Сообщений: 707
  • Репутация: +38/-0
Re: Игра "world of tanks" в PRA
« Ответ #253 : 16 Сентябрь 2018, 15:07:50 »
Нет на yad неккоректно работает.
А gtkdialog? Он тоже присутствует в PRA.
Gtkdialog — маленькая утилита на основе библиотеки GTK+, предназначенная для разработки GUI для скриптов оболочки.
$ gtkdialog --version
gtkdialog version 0.8.4 release (C) 2003-2007 Laszlo Pere, 2011-2012 Thunor
Built with support for: GTK+ 2, Glade.
http://wiki.puppyrus.org/programming/gtkdialog2

UPD. Просто устанавливать ради маленькой программы пакетов на 100 mb, не самая лучшая идея.
Будет установлено:  110,83 MiB
« Последнее редактирование: 16 Сентябрь 2018, 15:15:46 от krasnyh »

Оффлайн Neyel

  • Старожил
  • ****
  • Сообщений: 241
  • Репутация: +5/-0
Re: Игра "world of tanks" в PRA
« Ответ #254 : 16 Сентябрь 2018, 15:57:27 »
libdaemon установил (взял отсюда - https://archive.archlinux32.org/packages/l/libdaemon/ после сделал sudo pacman -U).
Для корректной работы zenity потребовалось выполнить следующие действия - http://forum.puppyrus.org/index.php?topic=20268.0
PortWoT установился. Сейчас буду тестить на запуск  :)