Сайт | Скачать | Видео | Wiki

Автор Тема: PRA-GAME 1509 . Помогите установить Sikuli  (Прочитано 1694 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Neyel

  • Старожил
  • ****
  • Сообщений: 201
  • Репутация: +5/-0
Всем привет. Столкнулся  с проблемой при установке Sikuli.  Sikuli - это инструмент, который позволяет автоматизировать то, что вы видите на экране с помощью визуального распознавания (картинок). Написан на  Java. Скачать можно здесь - http://nightly.sikuli.de/.
Для запуска установщика нужно поставить  opencv и tesseract (я ставил через менеджер пакетов). При установке крешится с таким логом:# JRE version: OpenJDK Runtime Environment (7.0_71-b14) (build 1.7.0_71-b14)
# Java VM: OpenJDK Server VM (24.65-b04 mixed mode linux-x86 )
# Derivative: IcedTea 2.5.3
# Distribution: Custom build (Wed Nov 19 09:07:09 UTC 2014)
# Problematic frame:
# C  [libnettle.so.4+0x220b2]  nettle_yarrow256_update+0x72
#
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
#
# An error report file with more information is saved as:
# /home/live/hs_err_pid28888.log
#
# If you would like to submit a bug report, please include
# instructions on how to reproduce the bug and visit:
#   http://icedtea.classpath.org/bugzilla
#
При этом на Ubuntu устанавливается (который стоит на том же компьютере), из чего делаю вывод что установка не проходит из за особенностей Puppyrus. В чем может быть проблема?

Онлайн Pro

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 9601
  • Репутация: +96/-0
Re: PRA-GAME 1509 . Помогите установить Sikuli
« Ответ #1 : 22 Май 2016, 10:19:46 »
сказано же, libnettle не нравится (если на вобще есть).
jre возьмите из репозитария в pfs, там есть 7 и 8  версии.
« Последнее редактирование: 22 Май 2016, 10:22:38 от Pro »
Я загружаю новые пакеты сюда: http://file.puppyrus.org/users/ а дальше можно найти самостоятельно.

Оффлайн Neyel

  • Старожил
  • ****
  • Сообщений: 201
  • Репутация: +5/-0
Re: PRA-GAME 1509 . Помогите установить Sikuli
« Ответ #2 : 22 Май 2016, 10:36:38 »
Посмотрел в папирусе и в убунту - версия libnettle 4.7 что там что здесь. Java ставил не через pfs а через менеджер пакетов Может обновить систему? пра-гейм у меня еще 1509
Если есть у кого возможность скачать и проверить установку то буду благодарен )
« Последнее редактирование: 22 Май 2016, 10:42:40 от Neyel »

Онлайн Pro

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 9601
  • Репутация: +96/-0
Re: PRA-GAME 1509 . Помогите установить Sikuli
« Ответ #3 : 22 Май 2016, 10:47:56 »
jre лучше через pfs таки.
Я загружаю новые пакеты сюда: http://file.puppyrus.org/users/ а дальше можно найти самостоятельно.

Онлайн Pro

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 9601
  • Репутация: +96/-0
Re: PRA-GAME 1509 . Помогите установить Sikuli
« Ответ #4 : 22 Май 2016, 10:49:15 »
/home/live/hs_err_pid28888.log смотрели?
Я загружаю новые пакеты сюда: http://file.puppyrus.org/users/ а дальше можно найти самостоятельно.

Оффлайн Neyel

  • Старожил
  • ****
  • Сообщений: 201
  • Репутация: +5/-0
Re: PRA-GAME 1509 . Помогите установить Sikuli
« Ответ #5 : 22 Май 2016, 12:45:55 »
Посмотрел ничего интересного не нашел на всякий случай прикреплю

Онлайн Pro

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 9601
  • Репутация: +96/-0
Re: PRA-GAME 1509 . Помогите установить Sikuli
« Ответ #6 : 23 Май 2016, 03:20:10 »
Посмотрел в папирусе и в убунту - версия libnettle 4.7 что там что здесь
что то ты не там смотришь, даже в текущем репозитарии арча
https://www.archlinux.org/packages/core/i686/nettle/ версия 3.2.

Попробуй качнуть, сделать pkg2pfs и подключить полученный pfs.
Я загружаю новые пакеты сюда: http://file.puppyrus.org/users/ а дальше можно найти самостоятельно.

Оффлайн Neyel

  • Старожил
  • ****
  • Сообщений: 201
  • Репутация: +5/-0
Re: PRA-GAME 1509 . Помогите установить Sikuli
« Ответ #7 : 23 Май 2016, 08:18:11 »
libnettle.so.4 указывает на libnettle.so.4.7 что в папирусе, что в убунту. Правда в убунту размер билиотеки меньше.
Цитировать
что то ты не там смотришь, даже в текущем репозитарии арча
https://www.archlinux.org/packages/core/i686/nettle/ версия 3.2.

Попробуй качнуть, сделать pkg2pfs и подключить полученный pfs.
Сделал pfs, подключил - при установке та же ошибка.
« Последнее редактирование: 23 Май 2016, 08:54:23 от Neyel »

Онлайн Pro

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 9601
  • Репутация: +96/-0
Re: PRA-GAME 1509 . Помогите установить Sikuli
« Ответ #8 : 23 Май 2016, 08:25:10 »
hs_err_pid28888.log.zip  если верить этому логу, то кто-то хочет libnettle.so.6.1
я предлагаю дать.
Я загружаю новые пакеты сюда: http://file.puppyrus.org/users/ а дальше можно найти самостоятельно.

Оффлайн Neyel

  • Старожил
  • ****
  • Сообщений: 201
  • Репутация: +5/-0
Re: PRA-GAME 1509 . Помогите установить Sikuli
« Ответ #9 : 23 Май 2016, 09:26:42 »
Создал pfs - появилась библиотека libnettle.so.6.2 а в логе по прежнему ссылается на libnettle.so.6.1.
Посмотрел - libnette.so.6.1 все таки есть
« Последнее редактирование: 23 Май 2016, 09:30:00 от Neyel »

Онлайн Pro

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 9601
  • Репутация: +96/-0
Re: PRA-GAME 1509 . Помогите установить Sikuli
« Ответ #10 : 23 Май 2016, 09:29:14 »
а в логе по прежнему ссылается на libnettle.so.6.1

потому что там информация из внутренностей бинарников :)) ошибка не ушла? тогда делай ссылку libnettle.so.6.1 на тот libnettle который щас в системе.
Я загружаю новые пакеты сюда: http://file.puppyrus.org/users/ а дальше можно найти самостоятельно.

Оффлайн Neyel

  • Старожил
  • ****
  • Сообщений: 201
  • Репутация: +5/-0
Re: PRA-GAME 1509 . Помогите установить Sikuli
« Ответ #11 : 23 Май 2016, 10:24:54 »
Сделал libnette.so.4 на libnette.so.6.1 - установщик вообще не запустился. Вернул на libnette.so.4.7. Сделал libnette.so на libnette.so.6.1 - ошибка выскочила та же. Самое странное что в убунту вообще нет libnette.so.6.* - хотя там установка проходит успешно(смотрел в каталоге /usr/lib/x86_64_linux_gnu, libnette.so.4.7 там есть а libnette.so.6.* нет)  Может libnette.so.4.7 бывает разных версий? В Ubuntu размер на 10 кб меньше этой библиотеки, не много но все же. Так что не знаю что и делать.

Онлайн Pro

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 9601
  • Репутация: +96/-0
Re: PRA-GAME 1509 . Помогите установить Sikuli
« Ответ #12 : 23 Май 2016, 10:26:41 »
Сделал libnette.so.4 на libnette.so.6.1
ты заставляешь меня нервничать.

Ты поставил   libnettle.so.6.2, ну так и сделай ссылку  libnettle.so.6.1 на  libnettle.so.6.2

Самое странное что в убунту вообще нет libnette.so.6.* - хотя там установка проходит успешно
jre там возможно собрано с линковкой к libnettle.so.4
« Последнее редактирование: 23 Май 2016, 10:28:28 от Pro »
Я загружаю новые пакеты сюда: http://file.puppyrus.org/users/ а дальше можно найти самостоятельно.

Оффлайн Neyel

  • Старожил
  • ****
  • Сообщений: 201
  • Репутация: +5/-0
Re: PRA-GAME 1509 . Помогите установить Sikuli
« Ответ #13 : 23 Май 2016, 10:41:07 »
Сам уже запутался =) Вот что у меня в каталоге /usr/lib:
libnettle.so     - ссылка на libnettle.so.4.7
libnettle.so.4 - ссылка на libnettle.so.4.7
libnettle.so.4.7 - билиотека
libnettle.so.6 - ссылка на libnettle.so.6.1
libnettle.so.6.1 - библиотека
libnettle.so.6.2 - библиотека

При этом libnettle.so.6.1 и libnettle.so.6.2  имеют одинаковый размер

В pfs который я создал есть только libnette.so.6.2 Откуда там взялся libnette.so.6.1 - ума не приложу
« Последнее редактирование: 23 Май 2016, 10:43:51 от Neyel »

Онлайн Pro

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 9601
  • Репутация: +96/-0
Re: PRA-GAME 1509 . Помогите установить Sikuli
« Ответ #14 : 23 Май 2016, 10:43:27 »
ну вроде гуд. и как там ошибка теперь?
Problematic frame:
# C  [libnettle.so.4+0x220b2]  nettle_yarrow256_update+0x72
Я загружаю новые пакеты сюда: http://file.puppyrus.org/users/ а дальше можно найти самостоятельно.