Сайт | Скачать | Видео | Wiki

Автор Тема: Upgrade glibc и gtk  (Прочитано 43292 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн andy-voit

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 1252
  • Репутация: +60/-0
  • Расту!!!
Re:Upgrade glibc и gtk
« Ответ #195 : 27 Февраль 2013, 14:01:33 »
бинарника с таким названием в списке не видно. Он точно должен быть? Именно в glibc? Да и в Ivanna он мне не попадался.
XFCE forever!!!
Перешел на приставку 3vi. Теперь издеваюсь над ней! :)

Оффлайн Pro

  • Модератор
  • Ветеран
  • ****
  • Сообщений: 8449
  • Репутация: +92/-0
Re:Upgrade glibc и gtk
« Ответ #196 : 27 Февраль 2013, 14:13:06 »
да он в составе glibc, по крайней мере в arch пакете есть он.
Данный файл нужен для dev части пакета, в основной системе он не нужен, но некоторые программы его используют при компиляции.

и еще, надо бы libexecdir задать на /usr/lib т.к. у нас оно там лежит.
« Последнее редактирование: 27 Февраль 2013, 14:14:51 от Pro »
Я загружаю новые пакеты сюда: http://file.puppyrus.ml/users/ а дальше можно найти самостоятельно.

Оффлайн andy-voit

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 1252
  • Репутация: +60/-0
  • Расту!!!
Re:Upgrade glibc и gtk
« Ответ #197 : 27 Февраль 2013, 14:23:23 »
Не, libexec у нас лежит и в usr/lib/ и там где я его положил - в корне /usr/libexec/ По крайней мере именно там и там у нас находится каталог getconf

В принципе - я могу перекомпилит, давайте определимся окончательно с параметрами и все.

про locale-gen ничего не знаю. Не компилился такой. Может нужен какой параметр.
« Последнее редактирование: 27 Февраль 2013, 14:29:20 от andy-voit »
XFCE forever!!!
Перешел на приставку 3vi. Теперь издеваюсь над ней! :)

Оффлайн Pro

  • Модератор
  • Ветеран
  • ****
  • Сообщений: 8449
  • Репутация: +92/-0
Re:Upgrade glibc и gtk
« Ответ #198 : 27 Февраль 2013, 14:34:35 »
libexecdir надо задать в /usr/lib про существование каталога libexec я в курсе, но почему бы тебе не ориентироваться на те пакеты glibc-2.17-arch которые я ранее выкладывал? в них приведено расположение файлов существующее в нашей системе в настоящее время.
Я загружаю новые пакеты сюда: http://file.puppyrus.ml/users/ а дальше можно найти самостоятельно.

Оффлайн andy-voit

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 1252
  • Репутация: +60/-0
  • Расту!!!
Re:Upgrade glibc и gtk
« Ответ #199 : 27 Февраль 2013, 16:56:27 »
Без dev части сложно ориентироваться, но я попробую. Во всяком случае ничего удалять насовсем не буду. Недостающее возьму из твоего пакета.

Перезалил
http://www.sendspace.com/file/mc1j0s
« Последнее редактирование: 27 Февраль 2013, 17:20:40 от andy-voit »
XFCE forever!!!
Перешел на приставку 3vi. Теперь издеваюсь над ней! :)

Оффлайн Pro

  • Модератор
  • Ветеран
  • ****
  • Сообщений: 8449
  • Репутация: +92/-0
Re:Upgrade glibc и gtk
« Ответ #200 : 02 Март 2013, 13:53:37 »
ты пересобирал пакет или просто переместил файлы из libexec в lib ?

А никто не хочет проверить, помогли ли эти все наши действия наладить работу glib и соответственно запуск скайпа, не или после пересборки glib может заработает.
Я ожидаю что по результатам темы, мы обновим gtk-2, запустим в дополнительные пакеты  gtk-3 и все такое.
Я загружаю новые пакеты сюда: http://file.puppyrus.ml/users/ а дальше можно найти самостоятельно.

Оффлайн andy-voit

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 1252
  • Репутация: +60/-0
  • Расту!!!
Re:Upgrade glibc и gtk
« Ответ #201 : 03 Март 2013, 02:57:51 »
Цитировать
ты пересобирал пакет или просто переместил файлы из libexec в lib ?
пересобирал конечно

Цитировать
А никто не хочет проверить, помогли ли эти все наши действия наладить работу glib и соответственно запуск скайп

Не знаю, в тему или нет. Но в 13.02 перестал собираться libiconv 1.14  раньше собирался влет, сейчас жалуется на ./stdio.h  стр. 1010 я проверил - stdio.h с такими строками в системе нет, есть только в самих сырцах libiconv Это я хотел dev часть получить.

пересобирать glib не пробовал. Попробую, видимо имеется ввиду самая последняя версия?
« Последнее редактирование: 03 Март 2013, 03:05:08 от andy-voit »
XFCE forever!!!
Перешел на приставку 3vi. Теперь издеваюсь над ней! :)

Оффлайн andy-voit

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 1252
  • Репутация: +60/-0
  • Расту!!!
Re:Upgrade glibc и gtk
« Ответ #202 : 04 Март 2013, 13:23:27 »
glib теперь невозможно собрать:
gconvert.c:66:2: error: #error GNU libiconv not in use but included iconv.h is from libiconvпохоже опять проблема с libiconv Переустановка пакетов в том числе и DEV проблему не исправляет. Надо перекомпилировать, а не выходит.
XFCE forever!!!
Перешел на приставку 3vi. Теперь издеваюсь над ней! :)

Оффлайн Pro

  • Модератор
  • Ветеран
  • ****
  • Сообщений: 8449
  • Репутация: +92/-0
Re:Upgrade glibc и gtk
« Ответ #203 : 04 Март 2013, 13:49:33 »
в данном случае вам конкретно пишется что программа хочет iconv.h от glibc а не от libiconv, я думаю надо уважить программу ;)
Я загружаю новые пакеты сюда: http://file.puppyrus.ml/users/ а дальше можно найти самостоятельно.

Оффлайн andy-voit

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 1252
  • Репутация: +60/-0
  • Расту!!!
Re:Upgrade glibc и gtk
« Ответ #204 : 07 Март 2013, 05:00:57 »
Пересобрал glib-2.35.2 в новой версии дистрибутива 13,02. Докладываю - скайп по прежнему не запускается.
XFCE forever!!!
Перешел на приставку 3vi. Теперь издеваюсь над ней! :)

Оффлайн Pro

  • Модератор
  • Ветеран
  • ****
  • Сообщений: 8449
  • Репутация: +92/-0
Re:Upgrade glibc и gtk
« Ответ #205 : 07 Март 2013, 05:35:38 »
Я загружаю новые пакеты сюда: http://file.puppyrus.ml/users/ а дальше можно найти самостоятельно.

Оффлайн andy-voit

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 1252
  • Репутация: +60/-0
  • Расту!!!
Re:Upgrade glibc и gtk
« Ответ #206 : 07 Март 2013, 15:20:45 »
Докладываю:
1.Скайп не работает со всеми версиями glib-2.35, в том числе и glib-2.35.8 (пробовал)
2. Скайп прекрасно работает с версией glib-2.34.3, проверено мной и дядей Шуриком, о чем сказано на предыдущей странице
XFCE forever!!!
Перешел на приставку 3vi. Теперь издеваюсь над ней! :)

Оффлайн Pro

  • Модератор
  • Ветеран
  • ****
  • Сообщений: 8449
  • Репутация: +92/-0
Re:Upgrade glibc и gtk
« Ответ #207 : 07 Март 2013, 15:27:10 »
ну так на предыдущей странице еще glibc-2.17 не было в системе
Я загружаю новые пакеты сюда: http://file.puppyrus.ml/users/ а дальше можно найти самостоятельно.

Оффлайн andy-voit

  • Активный участник
  • Ветеран
  • ****
  • Сообщений: 1252
  • Репутация: +60/-0
  • Расту!!!
Re:Upgrade glibc и gtk
« Ответ #208 : 07 Март 2013, 16:04:55 »
Кстати, при использовании glib-2.35.* работе скайпа мешает всего лишь одна библиотека libgobject-2.0.so* . Все прочие файлы и бинарники работе скайпа никак не препятствуют. Выявлено эмпирическим путем.
XFCE forever!!!
Перешел на приставку 3vi. Теперь издеваюсь над ней! :)

Оффлайн sfs

  • Администратор
  • Ветеран
  • *****
  • Сообщений: 17102
  • Репутация: +137/-0
    • PuppyRus-A
Re:Upgrade glibc и gtk
« Ответ #209 : 23 Март 2013, 15:17:12 »
Дистр и devx 13.2 . Компилю https://github.com/IgnorantGuru/spacefm/blob/master/packages/0.8.7/spacefm-0.8.7.tar.xz Параметры --prefix=/usr --localstatedir=/var --sysconfdir=/etc
usr/lib/libstartup-notification-1.so /usr/lib/libudev.so -lrt -lm -pthread
/usr/bin/ld: spacefm-vfs-execute.o: undefined reference to symbol 'XFree'
/usr/bin/ld: note: 'XFree' is defined in DSO /usr/lib/libX11.so.6 so try adding it to the linker command line
/usr/lib/libX11.so.6: could not read symbols: Invalid operation
collect2: error: ld returned 1 exit status
make[1]: *** [spacefm] Ошибка 1
make[1]: Выход из каталога `/initrd/mnt/dev_ro2/data/spkg/pkgbuild/spacefm/build/spacefm-0.8.7/src'
make: *** [all-recursive] Ошибка 1
Дистр 13.1 и devx 12.12 - все ок
« Последнее редактирование: 23 Март 2013, 21:15:39 от sfs »